Question about 1999 Oldsmobile Intrigue

1 Answer

I have a 1999 oldsmobile intrigue that is misting a lot. It idels rough, and runs rough. I can still take off it is a little slow, but I can still go pretty fast, but it still mist at the high speeds pretty badly. I have checked the mass air flow sensor, the oxygen sensor, I have replaced all spark plug and spark plug wires, and still nothing. The computer at Autozone said there were three codes on it, Misfire in 4, Oxygen Flow Sensor, and Mass Air Flow Sensor. After we changed spark plug and spark plug wires took it back and still said the Mass Air Flow, and Oxygen Sensor, so we replaced the Mass air flow there and checked and still no problems. The check engine light does not come on. Can you help.

Posted by on

  • 3 more comments 
  • Anonymous Mar 17, 2014

    runs fine then runs rough. starts to buck, it has a new fuel pump and fuel filter, oxygen sensor., throttle body sensor, spark plugs, wires, rotor and cap, mass air flow sensor

  • Anonymous Mar 21, 2014

    the service engine light keeps coming on. have changed the oxygen sensors, changed spark plugs. what else can be done.

  • Anonymous Mar 25, 2014

    1998 3S7144376 3Sfe engine was bogging down when I hit the accelerator. I started running rough after sitting dormant for months. The problem persisted and I cleaned the spark plugs. What is the best plug for this engine? Could I have been having an oxygen sensor problem? How could I check this out? After sitting for months without starting it blew some white smoke from the tail pipe. What causes that? It sounds like it's OK now, but I want to be sure.

  • Anonymous Mar 26, 2014

    is it the computer box or the sensors

  • Anonymous Mar 30, 2014

    where is the mass air flow relay sensor

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 422 Answers

Fuel pressure regulator on the fuel rail is probably it or the egr valve is stuck open allowing burnt fuel to flood the intake, im leaning towards the fuel pressure regulator because the o2sensor is probably reading rich or if its reading lean then i would choose the egr valve . good luck

Posted on Aug 26, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Driving car, started to run rough, made it home with engine stumbling, will not start now but cranks over. Strong smell after I made it home, not a fuel smell. Put a reader on it and got codes P304 and...


p102 is your MAF sensor, check the harness connection or, clean the sensor itself-P0304 is a misfire on cylinder #4, that could be related to the MAF, but I would also consider a bad plug wire or maybe an injector problem.

Mar 06, 2011 | 1999 Oldsmobile Intrigue

1 Answer

I took my 1999 oldsmobile intrigue to goodyear because of engine light on . They said that i had a misfire in cylinder 1 and a secondary air injection problem . The person found that i had a bad intake...


Sounds like a lot wromg for a car that's only 11 years old. Unless you have a lot of mileage or drive it rough I'd get another opinion from a qualified mechanic.

Nov 15, 2010 | Oldsmobile Intrigue Cars & Trucks

1 Answer

When ideling the rpms pulse slightly what is the


Plugged air filter - replace.

Dirty throttle body and idle/air control motor - Can of Carb. cleaner sprayed into throttle body and idle/air hole while engine is running.

If engine is also running rough check:
-Spark Plugs.
-Compression for bad valve.

Jun 25, 2010 | 1999 Oldsmobile Alero

1 Answer

I have a 99 intrigue 3.5l no engine lights on,runs a little rough,loud knocking sound seems to be in top end of motor,any tips on what to check


sounds like a valve you can buy a stethascope and run it over the valve cover to be certain if the knocking gets louder then thats your problem if not it could be any number of things take it to have it checked out

Dec 22, 2009 | 1999 Oldsmobile Intrigue

1 Answer

Why does the engine just die in my 1999 Olds Intrigue?


You need to do some basic tests to eliminate or get closer to the issue. Possibilities: 1) Fuel delivery 2) Ignition signal lost temporarily 3) Engine air leak - causes rough slow idle/stalling. 4) Bad MASS air flow sensor. etc, etc.

Oct 21, 2009 | 2000 Oldsmobile Intrigue

1 Answer

Overheating, Miss Firing, and Running Rough


Smell the coolant. Is there any hint of gas smell? Also look at oil, any coffee coloring indicates problems.

Jun 26, 2009 | 1999 Oldsmobile Intrigue

1 Answer

Dimming headlights,blinking headlights


Your alternator may be going bad. Test your battery while it is running with a voltmeter. It should be above 13.0 volts. I would check that first.

May 25, 2009 | 1999 Oldsmobile Intrigue

2 Answers

LOCATION OF FUEL FILTER ON 1999 OLDSMOBILE INTRIGUE


under the drivers door with a bracket holding the filter on. Be carful some of them have clips holding fuel lines on. might have to tak tank off, but that might lead to a leaking tank,straps a hole lot of mess. Best way is to take off filter, leave off put rubber hose on fuel line and put into a fuel can turn on the key and wait to empty.hope not to much gas in tank.

Feb 22, 2009 | 1999 Oldsmobile Intrigue

Not finding what you are looking for?
1999 Oldsmobile Intrigue Logo

562 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...