Question about 1999 GMC Suburban

1 Answer

Front air not blowing

Compressor cycles, fuses are all good and the rear air is blowing. Fan not working at all up front. I've just changed out the front blower but still doesn't blow.

Posted by on

  • Anonymous Aug 11, 2008

    Front air fan and A/C not blowing at all but FAN and A/C works just fine in the Back. When clicking the outside air button near the AC controllers the back A/C and FAN Stops working.

    Could something be clogged up?



1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert that hasĀ over 500 points.


    An expert who has answered 200 questions.

  • Expert
  • 330 Answers

Check the switch, maybe the switch problem

Posted on Jul 09, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

2003 kia sedona Replaced the C/fan H2 relay switch ran fine a few mins then a loud rumble near the front fan and smoke appeared. Switched them back no sound / smoke but now the ac is blowing hot air

Im going to guess that the cooling fan went bad. Smoke is a pretty good indicator that something is no good. It make have blow fuses that also power the A/C compressor. The C/Fan 2 fuse is the one that the compressor uses as well.

Aug 14, 2015 | Kia Cars & Trucks

1 Answer

2003 Pontiac Montana heat gets hot in front, blows but seems weak, and no heat on rear controls but blows ******* rear. what is going on?

Is your heater blower motor working on all speeds ? Are you get any air coming from the rear vents ?

Feb 25, 2015 | 2003 Pontiac Montana

1 Answer

Have a 2005 yukon xl with climate control a/c blows warm air

Does the front blow cold ? Diagnosing rear problems
Taking to a qualified repair shop an having it diagnosed would be your best bet >

Dec 13, 2017 | 2005 GMC Yukon Xl Denali

2 Answers

My 1998 lincoln town car started overheating, took it to the shop and the mechanic said it was the fan motor so he bought a new fan motor, he said the conector for the fan motor was burned a little but he...

Hello,Be sure the compressor clutch is cycling. Also, check the orifice tube, evaporator and condensor for blockages. Freon level should be checked with manifold gauges and compared to specs.

May 29, 2010 | 1998 Lincoln Town Car

1 Answer

1997 GMC Savans 35500, Rear Air only warm air

well what I see you have two problems with you A/C ..1- if the compressor is cycling very fast , the system is probably low in freon , this ban takes like 4lb of freon, now, 2-if we have the right amount of freon and the rear A/C don't work and all the vents are working fine back there for sure the problem is the expansion valve located close to the rear evaporator , that valve get stock open allowing to much refridgerant get in to the evaporator and no cooling at all ,in the back,... you can also have a bad low pressure switch located on the accumulator, making the compressor cycling very fast ..the first you have to do is check the pressures if they are OK , change the low pressure switch..then go to the second problem

Aug 02, 2009 | 2003 GMC Savana

2 Answers

A/c not operating

dryer switch, replaced

Jun 13, 2009 | 1997 Mercury Villager

6 Answers

2001 tahoe front heater not working, rear heater blows warm air

I have the same problem with my 2001 Tahoe. The front blower is working, its blowing strong, but its cold air even with the temp setting as high as it can get. The rear blows hot air. The engine temp guage is at about 210ish which is close to being normal (220). I just replaced the thermostate a few months ago, I don't know if its bad again, or it I deluted the antifreeze too much and it frooze the heater core, or if the heater core just went bad. Any one know what the cause could be?

Jan 05, 2009 | 1998 Chevrolet Tahoe

2 Answers

Aircondition not working....just blowing warm is working

Either you are out of coolent or the compressor is not working.

First check the fuses, then lift the hood and have a friend turn the air on. The compressor should cycle, if not take it to a mechanic. If it does cycle you are low on freon, take it to a mechanic for a system charge. Make sure they check for leaks first.

Aug 04, 2008 | 2001 Mitsubishi Montero

Not finding what you are looking for?
1999 GMC Suburban Logo

Related Topics:

192 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts


Level 3 Expert

78010 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides