Question about 2000 Ford Expedition

1 Answer

2000 ford expidition

I just baught this expidition about 2 weeks ago so it is new to me here recently at acceleration froma stop it seems to want to stall or hesitate real bad i put my second bottle of injector cleaner in today no chk engine light so not sure where to begin yesterday on a road trip it started jerking real bad not sure if these problems are related or seperate

Posted by on

  • lacheal Oct 22, 2008

    I have a 2000 ford expedition and it hesitates when pressing on the gas but once you keep pressing on the gas it kicks in an drive normal. I checked the transmission fluid and that is fine. I also took it for diagnostic testing and they couldn't find out what was wrong but they did say I needed some type of valve



×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Ford Master
  • 70,387 Answers

You may have a failing Mass Air Flow sensor, a quick test is to unplug the connector and drive the truck, if it runs better well their you go, the way this works is that the engine processor has failure mode strategy build in, so it substitutes a good signal for the missing one. After that just clear the codes and replace the sensor. The other issue may be fuel pressure, check the pressure and make sure it is ok under a load, a new fuel filter would poss. cure the issue also.

Posted on Jul 28, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2005 GMC Savana 1500 electrical problems,acceleration


sounds like the BCM is going out on your vehicle .

Mar 03, 2017 | GMC Cars & Trucks

1 Answer

2000 ford escort zx2 fuel injector fuse keeps blowing i dont know what to do replaced 4 fuses within the last 2 weeks and 2 of them were 40 amp fuses


checm fuse box for loose wire connection accelerating will cause it to push to many ampps and blow fuse make sure fuse prongs are nor loose

Jul 12, 2012 | 2002 Ford ZX2

1 Answer

Have some heat in 2000 ford expidition but not


have your heater core pressure checked. it maybe clooged even though you had system flushed. additionally did you buy the correct thermostat? the computer is a sensitive thing and alot of other components are activated because of the temperature. the opening temp is 188-195 degrees. so you should have bought the 185 degree thermostat. i had same problem and bought the higher temp thermostat. i couldn't believe that such a small change would make a big difference. good luck.

Jan 26, 2010 | 2000 Ford Expedition

1 Answer

My 2000 taurus,3.0 surg's when accelerating in


has the fuel filter been replaced recently?

Oct 20, 2009 | 2000 Ford Taurus

2 Answers

My 2000 Ford Windstar LX is randomly losing all power & shutting down for 2-5 seconds while driving. Everything stops working ( like theres no battery in the car ), then it comes back and starts right...


If you just had your battery replaced recently before that, Either your positive or negitive terminal is probably loose and needs tightened. It may get jarred around, and do that shutdown your 2-3 times, until something jars it to a better connecting position.

Oct 10, 2009 | 2000 Ford Windstar

2 Answers

No odometer light, circuit?


I own a 2000 impala ls and encountered the same problem.My solution to my problem was buy a new light switch and it worked.The circuits on the old one seemed to be burned so thats why they would come on sometimes.To install the new switch you need to remove the faceplate on the dash board and behind it you will find two screws holding it in place remove the screws and unplug the switch and replace.

Apr 18, 2009 | 2000 Chevrolet Impala

1 Answer

Slow acceleration from stop and when driving (trying to pass)


I have the same car. So far no problems with the Transmision. I had the Trans oil change out every 60 K Sure sounds like you need to get the Transmision checked. Is the fault light on. I have invested ina fault code reader sure is worth it. 
Good luck.  Vilmos

Feb 28, 2009 | 2001 Ford Focus

4 Answers

Missing and stumbling during acceleration


4.2 ltr missing. 2000 truck, f150. Changed plugs, wires. Ran great for 2 weeks. Started again. Changed coils. Got worse. Changed fuel filter, did nothing. Added injector cleaner and fuel cleaner, nothing. Checked EGR, o.k. It is getting worse. Had new gas about the time it all started.

Feb 07, 2009 | 2000 Ford F150 Flareside SuperCab

1 Answer

Sputturing engine


have your spark plugs, coil pack boots checked for moisture,on many ford water will accumulate around plugs,expeually if it has rained recently.

Jan 13, 2009 | 2001 Ford Expedition

Not finding what you are looking for?
2000 Ford Expedition Logo

348 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

70374 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Ron Lankford

Level 3 Expert

5386 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...