Question about 1998 Chevrolet Blazer

1 Answer

Two Things: Wipers randomly don't work at all, or go too long and fuel gauge not working.

My Blazer has been having many electrical system issues since only 35k miles, one after the other. First, similar blinking sound issues like other post...

For long time, I've just been living with it since dealer fixes cost sooooo much, my wipers are completely random. In Norcal, I've been lucky they worked in rain 80% time, but some storms without wipers were scary.
1) Won't do anything hitting on switch at any rate, or with sprayer - just dead.
2) Won't stop at normal number of wipes, go 5-20 extra wipes.
- almost never work correctly.

Also, since about 80k my gas gauge doesn't work - at full it reads full. It goes down to about 3/4 tank what seems accurately. At that point, it starts going back up to full. Sometimes when I turn on the car, the gas gauge jumps around randomly. This got worse... at 80k, used to work until at 1/4, then would climb. Over the miles, it got worse and worse so now it becomes wrong at 3/4 or little more. I have to track gas tank by my "computer" that gives me compass, temp and mileage/gas used/range. Luckily I have LT with this feature.

Posted by on

  • dtg0217 Jul 03, 2008

    wiper problem i had someone told me that the motor was recalled in 2002

  • chuckkles Jul 03, 2008

    Never got a letter about that, but got other recalls (AC smell, etc...).
    Thanks


×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 373 Answers

Hi chuck. I red your problem.
I anderstand your problem is electrical.

OK.On Chevy wiper motors have a defect " I called"
But the problem is the Wiper module or Wiper board,
That goes inside of the wiper motor. it's cost on dealer about $ 40 or around 20 to 35 on Autoparts.
Is easy to replace it. no need to take out the wiper motor.
Just remove the little torx screw on the black tap and take out
You will see the module.
I hope this work for you.

Posted on Jul 08, 2008

  • Juan Guillen Jul 08, 2008

    Sorry I forgot the problem with the fuel gauge.

    The problem on this come when the fuel sender on the fuel pump assemble come damage due to wear.

    And for fix this you need to replace the fuel pump assemble.

    Is other common problem on Chevys.



    NOTE: if you gonna replace Don't put a cheap, Buy a A/C delco or Carter, if not they come damage soon.

    Thank's for use fixya.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 04 sebring with the 2.4 dohc it started running bad and coded random cyl misfire and ignition ckt b malfunction i changed the wires plugs coil pack timing belt crank and cam sensors still no go...


Random has to universal problem. Think timing belt or fuel or air. All cause random. Get timing marks and check timing. Use fuel pressure gauge to look for constant even fuel pressure at 40 psi even with key off. Listen for loud sucking sound and try find where it is coming from. These things will help if electrical Ctrl issue exists must take to qualified technirian.

Jan 29, 2018 | Cars & Trucks

1 Answer

I have a 2001 Blazer LS, a few things were not working correctly, The Truck wouldnt always start when I tried to crank over, a fe lights on the dash would stay on even when the key was out, the PRND123 and...


not sure if this is your problem or not but in my blazer my gauges would just start going crazy at random times and sometimes the my speed would be accurate and other times it would be 10 mph off and the odometer and prnd123 would work sometimes and other times they wouldn't. after a lot of trying things I finally found the solder on the gauge cluster broke loose specifically at the PRND123 or the odometer I don't remember witch. I had to look at it under a magnifying glass and I could see some very slight movement after I soldered it back together it has been working great and I have not had any other problems with it. hope this helps you out.

Jun 01, 2017 | 2001 Chevrolet Blazer

1 Answer

Dear Sir, I need help to fix engine over heating of my 1997 chevy blazer. For your additional information the engine is not over heated during running whenever I turn on the air conditioning. Thank...


Many things can be leading to an overheating issue.

Is your cooling system full of coolant and is it still good. I simple gauge can be bought to test your coolant condition.

Is the fan moving when running, if it's electric check the relays.

Another odd thing may be your thermostat is not opening.

Check things things and get back with me if this dose not solve your issue.

Good luck.
ramairgto72_4.gif

Nov 23, 2010 | 1997 Chevrolet Blazer

2 Answers

My wipers work when they want to don't always work when it's raining. Is there a recall on the windshield wiper motor for a 1997 Chevy Blazer?


I don't believe there is a recall but I've replaced a lot of the wiper control modules [glorified circuit board] on top of the wiper motor for similar problems. Something in the circuit board goes bad and causes the wipers to malfunction randomly. There are other things that can cause wipers not to work but I'd look there first

Jun 10, 2010 | 1997 Chevrolet Blazer

1 Answer

1994 Chevy Blazer problems. Car starts and runs for a bit. Dies later and won't restart. Next day it will start and dies later. Have changed EGR, O2 Sensor, Fuel Pump three times, fuel filter. No luck....


Have you checked the battery after it died. I would check and see if the alternator is putting anything out. If its not, then i would look into the pink and brown ignition wire that runs the alternator and gauges and such. If any problems with this wire those very things happen. Hope this helps.

Nov 04, 2009 | 1994 Chevrolet S-10 Blazer

1 Answer

Chevrolet Blazer 1997.


If sender is new in the fuel tank, you have a wire problem between conection of fuel sender and dashboard gauge most likely place at dasbboard gauge.

Nov 27, 2008 | 1997 Chevrolet Blazer

4 Answers

Gas Gauge or Sending Unit


more than likely it's the gauge it sets in a circuit board and sometimes the contacts get worn and with vibration it voltage spikes it and then it fails. very seldom is it the sending unit in the tank. please rate this...thanks

Sep 01, 2008 | 2000 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

231 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

79865 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...