Question about 2001 Mercury Cougar

1 Answer

Is it my battery?

I had my car (forgot the term) where i had the radio on but the engine not running. the air on cold, full blast and no lights on. and no battery light or anything on...and then just died. so i had my car jumped and i drove for a bout 15 min. stoped it and turned it on again and it worked fine. next day i started fine. i stoped it and 15 min later came back and it would not start. replaced the battery and again it worked fine. but when i came back nothing worked. no radio no lights no locks. dead. atleast before with the dead battery i could get the radio to work for a little bit....idk whats wrong.

Posted by on

  • tska Jul 02, 2008

    thanks man, looks like the alt. is gone.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 726 Answers

Well this is what you should try ,,jump the car get it running
then when its warmed up take the positive lead of the battery
if the car stops the alternator is gone (thats what charges the battery) if the car runs its fine

and if u have put another new battery in it and the alternator is fine look for any broken wires earths or positives that could be making it drain so quick
and make sure your battery levels are full
hope this helps

Posted on Jul 02, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Now when yu filling up water ,the car must be idling or not?


Yes you want the water pump to move the water so you can properly fill the system also if the engine is hot adding cold water to a motor not running will have a good chance of cracking the block. So best to have engine running. Once the system heats the water to 180 degrees f the thermostat will open allowing the hot water to be cycled out and replaced with cool water, also make sure to have the heater on hot and running full blast cuz the heater core is full of coolant and will leave air bubbles if not being cycled

Oct 11, 2016 | Cars & Trucks

1 Answer

Flickering/Dimming Lights


you forgot, does it do that running engine or not.?
ok the main battery is car is doing that.
use a voltmeter, at the battery or even at the CIG lighter port.
12.6v DC, not running. rested. running voltage is 13.3v to 15vdc,

start engine, is rpm above 800 RPM at all times, or more?
if not, the alternator will be too slow, and drop out and when that happens , the lamps will dim. (a 3 volt drop does that)
1: all fuses good
2: battery term lugs clean, not green
3: fan belt to alternator not loose. slipping.
4: charge lamp on dash not ON, running.
5: check engine lamp not on, running (if yes,scan it now)
6: test the battery , batteries are LOW life objects, (die-easy-not-hard)
test the battery , using a load tester or take it in for testing, it's free.
or try a spare battery from another car. do not reverse POLARITY.
this gets the lions share.


Feb 04, 2014 | Honda CR-V Cars & Trucks

1 Answer

Engine overheats and heater blowing cold air


You have air trapped in system , change thermostat , bleed air from system , let it run hot while adding coolant with blower full blast on all front and rear heaters .

Jan 23, 2013 | 2001 Audi A6

1 Answer

Charged freon in suburban, i think i made a mistake by not having truck running while doing this. when i finished charging truck, i started truck and let it run with a/c on full blast and got no results. i...


Did the refrigerant go in?
You do have to have the vehicle running with the air conditioner on full cold, high when putting refrigerant in. I'm surprised that it went in at all. I did mine a few weeks ago and it took forever with the engine running.
Gary

Jul 20, 2011 | 1999 GMC Suburban

1 Answer

My 2006 ford focus zx4 had a low battery indicator light come on in town. On the highway with the ac on full blast and the radio on and cruise control on she started to lose engine power and the radio shut...


With a multimeter check the voltage at battery terminals. Should be more than 12.6Volts when engine off, and at least 14 volts with engine on. If the battery voltage is less than 12.6 volts then you need a new battery. If the voltage is less than 14 Volts with running engine, then the alternator is not working properly. A stop at AutoZone might help. They scan codes, and check alternators for free.

Sep 07, 2010 | 2006 Ford Focus

1 Answer

Air/heat blower is not working unless it is on high.


The heater resistor is probably faulty, its located near the blower fan

May 23, 2010 | 2000 Toyota Camry

1 Answer

'99 dodge grand caravan, 3.3ltr, battery light coming on, battery and alternator both test good, checked connections and wires they seem ok. multimeter check 12.4vdc engine off, 13.2vdc(+/- fux) engine...


you should have 14.5 +/- with the AC on you might have a week regulator or week brushes in the Altenator . but not enough at this time to cause a no start . but do have the alt tested (Load tested) at a parts store .

Aug 27, 2009 | 1999 Dodge Grand Caravan

1 Answer

Fan blowing while car is off


If the A/C knob is not set to 0 at the time ignition was off, the fan could run for a little and then off itself.

May 17, 2009 | 2002 Volvo S60

1 Answer

Battery and Air conditioner will not work in Infiniti G35


my radio ad a/c works only same times for ten minute and then turn off and no works maybe until next day

Apr 01, 2009 | 2005 Infiniti G35

1 Answer

A few Problems: Starting, Heater & Radio


Problem 1: buy a system heater to keep the engine warm at night.
You can buy them at any autoparts store . You take your pick from the variety.
Place a light 100 Watt Bulb near the battery but not too close to anything else where it might burn anything.

Problem 2. Check your coolant level to see if you have the proper level. Make sure you have 1/2 antifreeze and 1/2 water if you add any coolant /antifreeze and bleed the colant system. By running the car let it cool, then turn the radiator cap or turn the bleed screw provided on some cars near the thermostat outlet. Then adding some more water and coolant etc.The tightening the cap or bleed screw. When radiator is full. Check the radiator and and remove any debris that may be keeping the air out.

Problem 3. Will get fixed because your battery won't die.

Jan 11, 2009 | 2002 Jeep Liberty

Not finding what you are looking for?
2001 Mercury Cougar Logo

325 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

64034 Answers

Fordexpert

Level 3 Expert

5331 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...