Question about 1997 Chevrolet C1500

Open Question

Fuel pump prime test connector

I cant start my truck after replacing the fuel injector pressure regulator. What do I need to do?

Posted by on

6 Suggested Answers

Ajkill
  • 2035 Answers

SOURCE: 1997 S-10 fuel line/fuel pressure regulator

Please this link :

http://www.autozone.com/addVehicleId,2336303/initialAction,repairGuide/shopping/repairGuide.htm?pageId=0900c152800bfe20

Posted on Jul 08, 2008

  • 1 Answer

SOURCE: 2000 chevy blazer, truck cranks

Does your battery go dead?

Posted on Dec 18, 2008

csmock132
  • 4669 Answers

SOURCE: 02 CHEV.TRUCK.will not start

38-40 is not enough fuel pressure. Replace the Fuel pump.

Posted on Apr 05, 2009

emissionwiz
  • 61037 Answers

SOURCE: low fuel pressure

U 1st need to test fuel pressure at the fuel pressure test port on the top of the engione in the fuel supply rail to the injector tops, it looks like a metal tire vale stem, u will need to buy a special fuel pressure tester to do this test. U should have around 55-60 PSI at idle, it should go up when u gun the engine but never go down, if it goes down the fuel filter or pump are suspect.

Posted on Apr 29, 2009

jasperoni
  • 203 Answers

SOURCE: 1992 190e mercedes won't start?

it sounds like your fuel distributer is clogged. Replace your fuel filter. first you can try to bleed your system. take 12mm. wrech and loosen up you lines(one at a time) and crank your engine over(with a battery charger)and force your fuel bubbles out of the lines. while the engine is cranking and the line is loose knock on the line with the wrench and you will probably see a whole buch of rust poor out of the loose fitting. do thius repeatedly untill engine fires off-then with engine running loosen up your lines and repeat if any lines loosen up and there is no idle change that means that cylender is not firing and your injecter is not working. These mechanical style injecter's take alot of pressure to open the poppet valve to spray fuel.hope I have been helpful

Posted on Jun 18, 2009

  • 850 Answers

SOURCE: 2000 elantra no power to fuel pump.

could be a bad earth or [ground]
the power wire ma be brocken or have a loose or dirty connection
you neeed to trace it along its lenght to determine the fault!
so start at the pump & work back
Cheers rob

Posted on Jul 20, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My fuel pressure goes to 60 pounds when the keys is turned on then starts dropping Is it my fuel pump or pressure regulator? 2004 GMC Yukon XL


Fuel pressure may drop due to a leaking injector or bad check valve in the fuel pump itself. The regulator does not come into effect until the engine is running and a vacuum supply is produced to it. If the regulator is leaking internally, it could send fuel back to the tank as well. Prime the fuel line and pinch off the return line ( if possible ) to eliminate a regulator problem. If the fuel pressure drops with the return line pinched off, suspect a leaking injector or fuel pump. If injector is leaking, the vehicle should run rich and cause a hard start/rough run condition

Jul 25, 2015 | 2004 GMC Yukon XL

2 Answers

I have replaced the fuel pump on my 1994 pontiac grand prix with the 3.1 litre v6. But it does not seem to be sending the fuel to the motor? In the instructions it says something about the oil pressure...


Are you sure that the fuel pump is properly installed? Have you tested the fuel pump circuits to see if they are working properly? Did you also replace your fuel filter? (It could be totally clogged up) Have you checked to see if there is any fuel pressure at the fuel rail or are you just assuming that the pump is not delivering fuel to the injectors? Have you checked your fuel injector circuits for power and for injector pulse from the EngineControl Module? Have you scanned your Engine Control module to see if you possibly have a Crank Sensor or Cam Sensor problem?

The oil pressure switch only keeps the fuel pump running once the engine starts. The fuel pump should run for 2-3 seconds when you turn the ignition switch to the "Run" position to prime the injectors. The oil pressure switch is the problem only if the engine will not continue to run on its own after it starts up.

Jan 24, 2011 | 1994 Pontiac Grand Prix

4 Answers

Im working on a 95 s10 blazer.It has the 4.3 engine.It will only start if it is sprayed with starting fluid.the fuel pump,fuel filter,and pressure regulator have all been replaced.Seems like the system...


It sounds like the fuel pump is not working. Perhaps the install was not completed correctly. Things to check, fuel pump relay, wiring, voltage to the pump.
The priming happens as soon as you put the key in and turn it to "acc" (you may hear a humming sound). Then once you turn it to "start" the injectors and spark plugs start firing.
Another possibility is that the fuel filter was installed backwards.

Apr 22, 2010 | 1995 Chevrolet S-10 CA Edition

1 Answer

No/Low Fuel Pressure after replacing in-tank fuel pump & filter


Need to have the fuel pressure checked at fuel rail to know for sure if there is a fuel pressure problem for sure. There may be a in line filter as well, you can also do a check of the pressure regulator by pulling the vacuum line off of it then try starting the car with it off and see if it runs, if it does the regulator is bad, but IF it doesnt run doesnt necessarly mean it is good, a lot of fuel filters have a bypass wich allows the gas to bypass the filter when it is full bad thing is the debris can then plug the injectors causing problems, or there could be a loss of signal to tell the injectors to give fuel to the cylinders from an electrical or a sensor failure. So it is best to test the pressure to know for sure if it is in the fuel line or the injectors if it is truly being starved of gas. hope this helps

Apr 13, 2010 | Hyundai Motor 2003 Sonata

3 Answers

Where is the fuel relay located in Mazda mx6 1988?


On that one it actually called circuit opening relay under left side of dash in fuse relay box


b374e33.gif

Feb 08, 2010 | 1988 Mazda MX-6

2 Answers

2000 jimmy will crank but wont start fuel pump is pushing fuel through thr filter if i put a little gas in the air intake it fires up till it burns that fuel off. i can hear the fuel pump coming on and the...


you need to know what the fuel pressure at the fuel rail is (you can measure fuel pressure with a cheap gauge from harbour freight tools) it should be between
50-60 psi if not then the pump must be replaced
(gm replacment pumps are lifetime warranty )

Nov 17, 2009 | 2000 GMC Jimmy

4 Answers

Low fuel pressure


U 1st need to test fuel pressure at the fuel pressure test port on the top of the engione in the fuel supply rail to the injector tops, it looks like a metal tire vale stem, u will need to buy a special fuel pressure tester to do this test. U should have around 55-60 PSI at idle, it should go up when u gun the engine but never go down, if it goes down the fuel filter or pump are suspect.

Apr 29, 2009 | 2001 Chevrolet Malibu

1 Answer

Fuel Delivery Problem


Hi

Although you say the fuel pump is working properly, you still need to ensure that there is actually fuel getting to the rail, and the easiest way to do this is to first of all clamp the fuel return line from the fuel pressure regulator so that the fuel flow back to the tank is restricted. Now try to start the engine. If it starts and runs, or starts and then cuts out after a few seconds, then you need a new fuel pressure regulator.

If the car still won't start then pop the fuel inlet pipe off the fuel rail, hold it in a glass jar or bottle, and then have someone switch on the ignition so the pump primes. You should get a good jet of fuel from the pipe. If not then you need to turn your attentions to the fuel filter and the fuel pump and its built in check valve.

Next you should use a volt meter or a 12v test lamp to check for battery voltage at the fuel injectors. each injector has 2 wires to it, and one of these wires should have battery voltage to it with the ignition switched on. If not then you need to check the injector harness connector for security and condition, and check that none of the wires in the injector harness are nipped or crimped anywhere, and repair as required.

If the voltage is there then you know that the problem is a lack of injector pulse, or too short an injector pulse, and as you have already replaced the ECM twice, I personally would double check the injector wiring and then fit a new camshaft sensor and see if that solves the problem.

Regards

Geordie

Jun 11, 2008 | 1991 Mercury Capri

Not finding what you are looking for?
1997 Chevrolet C1500 Logo

619 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...