Question about 1999 Ford Expedition

1 Answer

Fuse My turn signals dont work also my back windsheild wipers doesnt work hazards freeze

Posted by on

  • Anonymous Jul 15, 2008

    brake lights out

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,533 Answers

I would check the flasher control unit in the fuse box on the driverside under the dash and on the rear wiper it is either a fuse or the motor may be bad
and for "guest" I would check to make sure that the brake bulbs are good and if they are check the brake switch behind the brake pedal under the dash

Posted on Jan 12, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1988 jeep cherokee,6 cylinder my front windsheild wipers dont work.fuse is good.the wiper motor makes a noise when its turned on.is there a relay that could be faulty?wiper switch is the same as the turn...


No relay in the circuit.
There is a delay module but if it fails that usually causes the wipers to stop in the middle of travel or only run on high.
And the switch is working if you hear noise coming from the motor. The wiper switch is not the same switch as the turn signals but it is near that assembly.
I would say if you have power to the wiper motor the motor is probably dead or something happened to the linkage to the arms.

Feb 27, 2013 | 1988 Jeep Cherokee

1 Answer

Wiper/turn signal relay locations on a 1999 ford taurus


Denise,the relays are under the hood.They're in an electrical box of their own. The car owner's manual will tell you which one it is.However,I've found the problem is usually a fuse that's under the dash.

Feb 05, 2012 | Cars & Trucks

1 Answer

The turn signals do not work when you use the signal switch. However, the emergency flashers do work. The fuse was checked and is good. Everything else on the signal stem works: the cruise control,...


if the fuse is good and all the lights work(if you checked them when the hazards were working)then you need a signal flasher,the signals have a separate flasher and it looks like the hazard flasher.if you turn on the hazards and look for it under the dash then you know what the signal flasher looks like,it is located on the fuse panel of in that area.

Mar 18, 2011 | Oldsmobile Bravada Cars & Trucks

1 Answer

My blinker lights wont work by themselfs but theyll work on the hazards and the fuse is good i dont know whats wrong


It is the switch. Some call it a combination switch. The lever that works the turn signals, may also work the wipers thats why its called a combo switch. If the work with the hazards, then that tells you that the fuse, wiring, bulbs are all good. Has to be the switch.

Sep 03, 2009 | 2005 Chevrolet Impala

1 Answer

2004 monte carlo. Turn signals dont work. The stalk still works with other functions, such as wiper, brights. The fuse is fine. Could it be a bad relay? When u push the stalk up or down nothing happens on...


try pressing the hazards on and off if they still don,t work replace the flasher unit. it is built into the hazard switch( all one unit ) change this and all will be good.

Aug 30, 2009 | 2004 Chevrolet Monte Carlo

1 Answer

1993 mark VIII blower motr stopped working, Also the hazard and turn signals not working. I replaced the 30 green fuse. did not solve problem,but this 30 fuse controls both haz and blower. So it must be a...


Dont know whay the blower motor doesnt work, but that age with these cars (I have two 94 Marks) both have had the turn signal switch replaced for problems with hazards not working, wipers not shutting off, etc.
To check your climate control system: Press OFF and FLOOR at the same time, release, then hit AUTO. That will make it self-test. You will get 888 (ok) or an error code (024, 025, or such)

Jan 18, 2009 | 1993 Lincoln Mark VIII

Not finding what you are looking for?
1999 Ford Expedition Logo

290 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...