Question about 1994 Chevrolet Corvette

1 Answer

Corvette sarting Hi, I have a 1994 corvette LT1, It takes about 15 seconds turning over to start.once started it runs fine, but it take the same 15 seconds to start every time. I replaced the fuelpump & fuel regulator & it dose not show signs of a leeky injector. also the check engine lite is on. any idea what this mite be?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have a 94 as well and had a similar problem before, the Opti spark was replaced and it starts imediatily like in less than one second, but its kinda expensive. Im no mechanic though just personal experience.

Posted on Jul 08, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1994z-28 after it running about 20mins it start spitting and spatting every few seconds. what is this?


Trouble with my new- to- me '94 z28 already - CamaroZ28.Com ...

www.camaroz28.com > ... > LT1 Based Engine Tech
Apr 9, 2012 - Couldn't reach the other side before running out of time. .... Does the carstart up after it has sat for a while and cooled off? 1994 Z-28 LT1 A4, Supercharger 6 psi, 3.73 Gears, GMPP 1.6 Rockers, LT4 Springs, ... Ten minutes into a drive it willstart to sputter and then die, ... so nice!...for about 20 minutes.

how long does it take to heat up?? - LS1TECH

ls1tech.com/forums/lt1-lt4.../1371680-how-long-does-take-heat-up.html
Jan 8, 2011 - 1994 z-28 m6 procharged all the goodies ... to get hot lol.. change back to stock if you want it to run a regular temp ... I hit the freeway almost immediately afterstartup so the car doesn't really get a chance to "get hot". ... To answer the original question my old LT1 took about 15-20 minutes to blow warm heat.

Dec 01, 2015 | Cars & Trucks

1 Answer

What arm the specs for 95 camaro lt1 350


Block and Basics
Displacement: 350 cubic inches, 5733 cubic centimeters, 5.7 liters
Block Material: Cast Iron
Main Bearings: 2-Bolt Centers and Ends (The Corvette LT1/LT4 had 4-bolt mains)
Stroke: 3.48"
Bore: 4.00"
Compression Ratio: 10.4:1
Combustion Chambers: 54 cubic centimeters
Factory Redline Rating: 5700 Rotations Per Minute

Bottom End
Piston Material: (10159437) Eutectic Aluminum/Silicon Alloy
Connecting Rod Material: (10108688) Powdered Metal
Crankshaft Material: (12556307) Cast Iron

Top End and Valvetrain
Cylinder Heads: (10168448) Cast Aluminum, 2 valves per cylinder/16 valves total, ~212 CFM flow (Impala SS and Caprice heads were made of cast iron*)
Valve Diameter: (intake- 10241743, exhaust- 12550909) 1.94 intake, 1.50 exhaust
Valve Overlap: 41*
Valvesprings: (10206040) 85 lbs, seated
Camshaft Specs (12551705): 205/207 duration @ 50*, .447/.459" lift, 117 Lobe Seperation Angle
Rocker Arms: (10089648) 1.5:1 Stamped Steel
Timing Chain: (10128485) Powdered metal link

Intake and Fuel Delivery
Fuel Delivery: Electronic Fuel Injection, sequential port
Injector Size: (17124248) 3.0gps, 22lbs/hr speed density (1992-1993), 24lbs/hr mass airflow (1994-1997)
Throttle Body: 48 millimeter twin butterfly
Intake Manifold: (12552137) Aluminum

Factory Power Ratings
92-96 LT1 Corvette: 300bhp, 330lb-ft
1996 LT4 Corvette: 330bhp, 340lb-ft
1992 LT5 Corvette: 375bhp, 370lb-ft
93-95 LT5 Corvette: 405bhp, 385lb-ft
93-95 LT1 F-Body: 275bhp, 325lb-ft
96-97 LT1 F-Body: 285bhp, 325lb-ft
96-97 WS6/SS: 305bhp, 335lb-ft
93-97 Firehawks: 315bhp, 340lb-ft

Factory LTX Camshaft Specifications**:
1992 Y-body: 205/207 0.451/0.450 lift 117 LSA
1993-1995 Y-body, F-body: 202/207 0.450/0.460 lift 116 LSA
1994-1996 B-bodies (including L99 4.3L): 191/196 0.418/0.430 lift 111 LSA
1996 Y-body, 1996-1997 F-body: 200/207 0.447/0.459 lift 117 LSA
1996 Y-body, F-body LT4: 203/210 0.476/0.479 lift 115 LSA


hope this helps

Mar 04, 2015 | Cars & Trucks

1 Answer

Wont start when hot


If you recently had a waterpump replaced or leaking, i would say its the opti spark distributor. Main problem with the LT1 engines the water leaks all over distributor that sits behind pump causing the start no start up. When ever you change the waterpump always include the opti spark and wired connector.

Aug 08, 2014 | 1994 Chevrolet Corvette

1 Answer

1994 camaro lt1 wont spark


No it is likely the OPTI SPARK distributor has failed, it is the Achilles heal of the LT1 V8. The distributor is located under the water pump on the front of the engine, if the water pump leaks it goes right into the distributor. To replace the distributor you must drain the cooling system and remove the water pump and all other obstructing parts to get to it. Before you replace any parts I suggest you have a trained technician run a scan of the system for fault codes, other things can cause this as well. The distributor is very expensive and i am only guessing based on my experience with my own 1996 Corvette LT1

Jun 29, 2012 | Chevrolet Camaro Cars & Trucks

1 Answer

I want to install an LT 1 engine taken from a 1994 chevy z 28 with a 6 speed automatic transmission.into my 1992 corvette which also has a LT1 engine with a six speed automatic. what would be the...


The wiring harness will be completely different as well as the engine mounting locations. The computer will also need to be from an LT1 Camaro.

Nov 16, 2010 | 1992 Chevrolet Corvette

1 Answer

94 lt1 cranks a while before car starts. When car starts the car runs fine.


You may be losing fuel pressure. There is a fuel pressure regulator in the fuel line. It has a check valve in it. If the check valve is bleeding off then you have to get fuel pressure pumped back up. You can verify by turning the key on and letting it sit for about 5 seconds, turn off and then back on and repeat 3 times. This will pump fuel back up to the regulator and should start right away.

Sep 14, 2010 | 1994 Chevrolet Camaro

1 Answer

1994 corvette very hard to start spins for about 5 seconds then runs fine


you may have a leak fuel injector is it smell gas when you first start?

Mar 08, 2010 | 1994 Chevrolet Corvette

1 Answer

Long Crank times before starting


Sounds like it could be losing fuel pressure to the rail, try turning ignition on for 10s, then off then on then off then try start. That should make sure the pump has pressurised so will see if it is pressure.

Chris

Jun 27, 2008 | 1994 Land Rover Discovery

Not finding what you are looking for?
1994 Chevrolet Corvette Logo

Related Topics:

234 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...