Question about 1993 Mercury Villager

1 Answer

Won't start I bought a 93 mercury villager than has been sitting for 6 months. I boosted it and it started fine. I charged the battery and it is still good. I started it up to move it and it went about 6 feet and stalled out. Now when I turn the key absolutely nothing happens. only the dash trouble lights come on. all other electrical works.

Posted by on

1 Answer

Have you checked the distributer

Posted on Jun 26, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1999 mercury villager will not start all dash lights out


Do any lights work? IS the battery fully charged or does it need a boost

May 10, 2015 | 1999 Mercury Villager

1 Answer

I own a 97 mercury villager an just won't start


I have a 98 model.
Someone will have to figure out if you are dealing with a no spark or no fuel problem when it won't start.
Could be a long list of causes depending on which issue.

Sep 14, 2012 | Cars & Trucks

1 Answer

93 won t start, clicking when i try to start... it started after sitting for a few days than now it won t don t know if its my starter battery or alternator


I would change all three. alittle expensive, but on this old of a vehicle I would not waste time and trouble. if this doesnt work then maybe some ignition problems. But i would guess that battery, starter, alternator, should do the trick

Mar 11, 2010 | 1993 Mercury Grand Marquis

1 Answer

Is it the starter


most likely is the alternator.
jump start the car and pull off one of the cable for the battery terminal. if the car stop. then it is the alternator. if not then you have to check the regulator. it should out put 12-14v.
the battery is not being charged.

May 29, 2009 | 1993 Mercury Villager

1 Answer

Door issue


no difference from 93 to 98. you need to move door hinges.

go here for villager/quest help

http://autos.groups.yahoo.com/group/villagerquest/

Apr 18, 2009 | 1993 Mercury Villager

1 Answer

Car running rough when raining


check the spark plug wires, put water in a spray bottle and spray along the wires,especially by the coil,if the car starts to run bad or you see sparks, the wires are no good, hope this helps, Ray

Apr 03, 2009 | 1999 Mercury Villager

Not finding what you are looking for?
1993 Mercury Villager Logo

Related Topics:

241 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Fordexpert

Level 3 Expert

5331 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...