Question about 1995 Buick Park Avenue

1 Answer

95 buick pv run a little rouf & loses coolent.

I have a 95 PV and it was running great and all of a sudden it started to run rouf and the coolent light came on and when I looked there was nothing on the ground so no hoses was brok. I got it home and I parked it .I went out started it rolled it down on a flate spot on the drive way and I put more coolent in and when I went to start it it just clicked. all the light came on so I know it wasn't the battery. but now we cant start it help!
Lori

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 169 Answers

If I am following you, it sounds like you may have a bad head gasket. Do you still need help with this?

Posted on Aug 31, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1994 dodge grand caravan. It starts up and runs great every morning. But after driving for an extended amount of time, it will just all of a sudden run like ****. It sputters while idle and if I...


check the coolent as sometime when the coolent is empty the gauge will show the temperature right but actually it's not.... or there can be some dirt in the engine

Apr 16, 2013 | Cars & Trucks

1 Answer

Loses coolent


about how much coolant are you losing?

Have you had the cooling system pressure tested?

Apr 02, 2013 | 1999 Cadillac DeVille

1 Answer

HELLO I GOT A ISSUE WITH MY 1996 BUICK LASABRE ITA START FINE IT DRIVES FINE UNTIL IT REACHES THE NORMAL TEMPS OF 195 200 DEGREE AND ITA SPUTTER AND STALL OUT IT WILL NOT START UNTIL THE MOTOR COOLS...


the one thing in your statment is the knockes/knocking this what is known as the big ends and indicates the engine is under pressure and needs a lot of repair.If when you start the engine when cold if you stand at the back of the car and if the smoke coming out of the exhaust has a blue tint/ie like a old ladys hair tint ,as im sure you will see.[bottom line] the engine needs replaced.adrian,,,,

Sep 02, 2011 | Buick LeSabre Cars & Trucks

1 Answer

1996 buick century v6 3.1L all of sudden not wanting to start but after a couple mins of turning key to start, finally starts and then runs great. now problem only occuring at starting of vehicle. once...


It sounds to me like the fuel system is not getting primed during the initial start up. By cycling the key several times, the fuel pump has time to deliver enough fuel to start the engine. The inexpensive way to go at this point is to change the fuel filter. It is cheap and one of the first things to check. Hope this helps.

Dec 29, 2010 | 1996 Buick Century

1 Answer

95 Regal 3.8 Runs great but today started


Try a new distributor cap and rotor button,they are known problem areas.If the problem is not in the distributor then you will likely need to replace the catalytic converter,a plugged converter will not let the engine get to full horse power because it can't get rid of the fuel as fast as it is coming into the engine,which is not a problem for the engine at lower rpms but it is a problem when you need the power.

Jul 17, 2010 | 1995 Buick Regal

1 Answer

The 96 park avenue will start great and run great. No security light comes on and everything runs smooth. No bucking or hesitation. A great ride. Then all of a sudden it will die. Lights stay on and radio...


It cannot be the VATS system. The TDM, that is the core of the VATS system, is engaged only at the time you start your car. I have a problem exactly like yours on my 95 LeSabre and just discovered it is the alternator that sometimes charges and sometimes doesn't and when it doesn't, the battery's voltage goes lower than a certain threshold and the computer (PCM) is unable to work anymore and shuts down the engine. Took me months to discover this!

Dec 29, 2009 | 1990 Buick Reatta

1 Answer

Engine 258 i6 was running great - suddenly started to run rough and stall at idle - will start and run but not idle - when revving it smokes alot


Pull the plugs & have a look at them. Look for oil deposits, or liquid on them. Are you losing any coolant? Is it using any oil suddenly?

Aug 27, 2009 | 1983 Jeep CJ5

Not finding what you are looking for?
1995 Buick Park Avenue Logo

Related Topics:

78 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...