Question about 1998 Volvo S70

1 Answer

Not getting any gas, abuzzing noise under hood near where throttle cable hooks

Car started cutting out at speed and finally stopped. it wants to start but just stalls. i dont think it is the fuel pump. now there is a buzzing noise under a cover near where the throttle cable hooks. like a solenoid in fuel injection system not doing it's thing.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 60 Answers

Could be a bunch of things, possibly a bad injector relay, will need to have someone troubleshoot the fuel injection system. Have you checked the fuel pressure?

Posted on Dec 03, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 1998 200sx stopped accelerating while getting on freeway.


Could be the cable that actavates the throttle plate on the intake..
The cable comes from the gas pedel and pulls on the throttle plane in the intake manifold.. opening the plate to let air flow through to the engine. On the other side from the cable is a plastic sensor with wires attached to it this is the Throttle position sensor.. if this is disconnected or broken the computer cannot receive the single that you are pushing on the gas pedel.. very rare for the throttle position sensor to break completly.. best posibility broken cable.. open hood find cable connected to throttle body, have someone in car push pedel see if it moves. Good luck.

May 11, 2014 | 1988 Nissan 200SX

1 Answer

Cruise control diagram 99 kia sportage


there is a vacuum control under the hood of the car usually on the drivers side and will have the throttle cable attached to it.. so follow back from the tbi near the air cleaner and you will find it..usually a round metal peice mounted with a rubber side that will flex back into itself and pull on the gas linkage to hold the speed of the car..some have moer than ne cable on them and a connector on the back with a vacuum hose connected also(or plastic tubing) check for movement and is the connection tight..repost findings...

Jan 20, 2013 | 1999 Kia Sportage

2 Answers

My car is making an awful groaning grinding noise noise when it starts. The noise stops after it starts. Put my foot on the brake it starts again. put thr car in reverse no problem put it in,drive it...


It's your exhaust mounts or broken exhaust bolts. It does it in drive st idle n under load because the motor is sitting in rubber mounts made to dampen vibration. Therefore the motor tilts to the left in reverse pulling the exhaust away from your under carraige, and to the right in drive causing the loose exhaust to vibrate against something. Check your heat shields also. They fall apart n do the same noise. Piece of cake.

Sep 24, 2012 | Cars & Trucks

1 Answer

Sometimes when starting the rpm revs up to 2000 and then continues to climb rather than come down. Going along the road it seems to run itself...when I take my foot off the gas it maintains speed for quite...


The throttle body can be sticking. Also you could have a broken throttle position sensor. Vacuum leak, near the rear of the intake can cause increased RPM's. Check around under the hood for loose connections, I always start there.

Sep 19, 2011 | 2004 Pontiac Grand Am

1 Answer

When I was driving the deville yesterday I was having a problem getting the car to stay at speed. It almost seemed like when I let the gas petal up it would get a small boost of power. Do you know what...


Check under the hood for the throttle body, and look where the cable connects to the throttle plate control. If there is corrosion there the gas pedal could be sticking.

I had this happen to a 1990 Cadillac Deville. It was cruising and then it would not slow down on the highway.

Had to pull of the road after hitting the brakes several times and finally turning the ignition off.

A piece of theblack powder coat or coating got caught in the cable.

I'm not sure, by what you're saying, if this is the problem in yours, but it's worth a look.

Jul 05, 2010 | 1996 Cadillac DeVille

2 Answers

My car cuts off when I slow down or come to a complete stop...


May need a tune up, or may have carbon build up in throttle body/intake or possible vacuum leak, listen under hood for a sucking air noise and find it/fix it. Mass air flow sensor maybe.

Apr 14, 2010 | 1995 Nissan Maxima

2 Answers

Starts well,runs wellfor five mins but then cuts


My first guess would be the fuel filter. It is probably almost completely plugged.

Oct 23, 2009 | 1991 Volkswagen Passat

1 Answer

I Have A 93 Ford Escort Lx Im Having A Problem Accelerating After Driving It For About Ten Minutes I Will Drive It For A Little Then When I Come To A Stop Light It Sputters And Jumps Around And Sometimes...


By the sounds of it, its like once your car gets hot its starts playing up. You should run a compression test on all ur cylinders..you can get a tester from your local automotive store quite cheap, you just screw it in or shove it in and hold it, start the car and use the throttle cable hinge to rev the car slowly up to redline.. do that while the engine is quite hot though to get a more accurate reading, especially because i think thats when your car starts playing up (when its hot) im just going to say it should be around 140 for all cylinders.. just double check that and cross check your readings with ford. It also could be a ECU problem, once your car is running hot (normal temp) the tuning is wrong.

Sep 09, 2009 | 1993 Ford Escort 4 Door

1 Answer

1989 Cherokee stalls at low speeds, i.e. stop lights


could also be bad map sensor and crankshaft sensor postion on top of trannny near engine and map on firewall behind engine with one plu and a vac line same problems on my ride and this hooked it up

Apr 30, 2009 | 1989 Jeep Cherokee

2 Answers

Battery dead cant get in trunk with key to jump start car for 200


Look under the boot handle near the number plate light and you'll see a hole where you can use your key to open the boot.

Mar 08, 2009 | 2001 Jaguar S-Type

Not finding what you are looking for?
1998 Volvo S70 Logo

126 people viewed this question

Ask a Question

Usually answered in minutes!

Top Volvo Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6879 Answers

Are you a Volvo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...