Question about 2004 Chevrolet Corvette

2 Answers

A/C Heater fan not running

The A/C fan was running full speed right after I started the engine and it abruptly shut off.

Posted by on

  • crazym55 Jun 25, 2008

    I checked the A/C fuse under the hood, both HVAC control fuses and the blower fuse inside the pasenger side compartment. I can hear the compressor clutch and all the damper controls working ok. The control center is showing the need for the fan both in manual and auto. Looks like I will need to check for voltage at the blower motor. Next step will be to purchase a service manual as warrantee was up 3 months ago lol.

    Thanks for input!

  • stanuram Oct 15, 2008

    I have a '04' C5 Coupe. The A/C does not come on and blows warm air. When I push tha A/C button or the auto button, the A/C button lights up, stays on for a few seconds then goes out. The owners manual doesn't show an A/C fuse but shows a relay in pos. 34 in the fuse box under the hood. I don't hear the clutch engaging and the temp control is set to 60 for driver and passenger. Suggestions please.

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 284 Answers

Check the AC fan FUSE under the hood. should be a 15 amp fuse most likely.

if the fuse blows again it could be the fan is sticking. or over heating(not moving fast enough).

good luck

Posted on Jun 23, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 68 Answers

Check the fuse box go by a fuse at a gas station and replace the one that says fan and it may fix the problem

Posted on Jun 23, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine cold. Start engine reading says engine hot ac off. Fans run all time.


Are the fans running on low or high ?
Circuit/System Description
The engine control module (ECM) commands the fans ON in either high speed or low speed, depending on cooling requirements. In low speed, both fans are turned ON at a reduced speed. High speed has both fans turned ON at full speed.
In low speed operation, the ECM applies ground to the coil side of the fan low relay. This energizes the coil and applies voltage directly to the left cooling fan through the switch side of the fan low relay, which is fed by the fan 1 fuse. The right fan is connected in series to the left fan through the de-energized fan control relay so that both operate at low speed.
In high speed operation, the ECM applies a ground to the coil side of the fan low relay, the fan control relay , and the fan high relay. On the fan high relay, the energized coil closes the switch side of the relay and applies voltage directly to the right cooling fan through the switch side of the relay, which is fed by the fan 2 fuse. At the same time, the ECM energizes fan control relay pulling the switch side over, providing a direct path to ground for the left cooling fan, which has voltage applied through the energized fan low relay. In high speed mode, the fans are operated as a parallel circuit with full voltage applied to each.
You should have it hooked up to a scan tool that can read engine sensor data parameters . Check for DTC'S - diagnostic trouble codes etc...
Circuit/System Verification
  1. If DTCs P0480 or P0481 are set, perform those diagnostics first.
  2. Ignition ON, verify with a scan tool that the control module is not commanding fan activation.
  3. Ignition ON, observe that the fans are not activated.
Your best bet is to take it to a ASE certified repair shop !

Jan 10, 2016 | 2009 Chevrolet Silverado 1500

1 Answer

In cold temp,heater motor do not run


you mean low heat. at all ducts with full fan speed and blows hard,
here is the correct order.
1: engine at 180F or more holding, a absolute must.
2: fan runs at full speed on HIGH, (sounds like it)
3: fan actual blows (felt) at full speed, to any vent, try all vents.
4: now heat, will happen, if not, the dampers are closed or wrong.
damper can be complex on newer cars,they have motor controlled damper servos';

is this just blower fan dead? problem. on high, if yes say so.

Jan 26, 2014 | 2008 Suzuki Grand Vitara

1 Answer

1998 buick lesabre the blower motor keeps running after car is turned off


if you are talking about the engine electric cooling fan..it will run after car is turned off until temp goes down then it shut off..unless you're talking about the heater blower motor..then i would look in the engine compartment passenger side firewall for the heater box ..on the box there is speed control resistor for the heater fan speed..that might be shorted.if not fan switch on dash..give more info next time..it makes it easier answer with more info

Sep 21, 2010 | Buick LeSabre Cars & Trucks

1 Answer

Why is my heat/front defrost not working very well. Only shoots warm air? And not very forceful.


hi from uk can i offer this advice ? when you start engine let it warm up a little then drive untill temp guage reads warm at least ? then when you put front screen defrost on only select screen and No 2 speed then as temp reaches normal screen will clear fully if you select full speed on heat blower to clear screen at first start it will not work because the coolant from engine passing thro the heater matrix/radiator will be rapidly cooled by fan of heater TRY IT? in years gone by it was common remedy if you were stuck in traffic and temp rose towards hot you could cool system down by putting heater on full heat and the fan on max this cooled the engines coolant as it passed thro the heater ?hope you understand how heater/fan should work for optimum efficiency my wife has owned 2 of these accents and never had heat/demist problems it is surprising how many people consider the demist/heater systems are poor on many cars not just hyundai hope this helps best wishes

Dec 15, 2009 | 2001 Hyundai Accent

1 Answer

2000 kia sportage new heater core no heat


You most likely have air in the cooling system.You would need to bleed the cooling system of air.There should have bleed screws near water neck,or thermostat.Do this cold.Remove the radiator cap and fill full.Then start the engine and loosen the screws and watch for nothing but coolant to flow out(no air or bubbles).When you are sure the air is gone out of the cooling system,shut the bleeder screw off,and fill radiator up and test to see that engine runs cool,and you have heat at all speeds and rpm s.The electric cooling fan should come on at a tempuratue of about 215 or so.But just as important,the cooling fan should cut off at a lower tempurature.If the cooling fan does not do this,you still have air in the system.If you can not get the air out this way,then do this.Remove the radiator cap and reservoir cap and fill them both up full.The reservoir needs to be over the fill mark a good deal.Replace the caps.Start the engine with ac and heat off.Let it run until the engine gets to about 212 or 215 degrees and shut the engine off.Wait about 30 minutes and check the reservoir to see if the coolant has dropped.It should have dropped.If the reservoir has dropped or not ,do this again and again untill the reservoir drops in coolant level,and engine temp is good(fan goes on and goes off).Remember to refill the reservoir as needed as it drops,not to run out of coolant.

Sep 20, 2009 | 2000 Kia Sportage

1 Answer

01 Suburban engine, 8.1 liter, abruptly turns off


Its the crank sensor. There was a recall a few years back for 2001 8.1 liter engines crank sensor. Engine would shut off perodically and sometimes would not restart untill cool. Plus it just happened to mine. about a 350 dollar dealer fix.

Feb 22, 2009 | 2003 Chevrolet Suburban 1500

1 Answer

Compputer shuts down abruptly


If you have recently fitted new hardware. Take it out.
If not, buy a power surge protector from your local pc store

Jan 30, 2009 | 2005 Mercury Villager

2 Answers

1994 mercury villager


Start with engine cool. Remove rad cap, top up coolant, start engine, & turn on heater (not defrost). let it run until up to normal operating temperature & radiator fan comes on, then shuts off. Let it do this about 3 times before you put rad cap back on & top up return bottle to proper level. Every once in a while, rev engine slightly for a few seconds while your doing it, to speed up bleed by increasing flow. Keep an eye on temperature gauge for too hot, and fan not coming on, if so, shut it off.

Jan 29, 2009 | 1995 Mercury Villager

1 Answer

Running hot


Sounds like Clutch in your fan

The coolant level is right on, no hoses are leaking and the accessory belt is intact. You start the engine, let it idle and make a visual inspection. There's no sign of belt slippage.
If your car is like most, the cooling fan is mounted to its drive pulley via a clutch. Clutch fans operate at different speeds under different conditions to help reduce drain on the engine and to save fuel. When the engine is hot, the clutch fan runs nearly as fast as the engine. When the engine is cold, the fan runs much more slowly.
The fan clutch operation is regulated by a valve that is opened and closed by a thermostatic spring. The valve controls the flow of a viscous silicone fluid between chambers in the clutch assembly. When the engine is cold, the clutch is essentially disengaged, which is why the fan runs at its slowest compared to the engine's speed. As the engine warms up, the air flowing to the fan assembly becomes hotter. The hotter air causes the thermostatic spring to unwind and open the valve. Silicone fluid from the reservoir chamber flows into the main chamber, engaging the clutch, and the fan spins faster (though it's still slightly slower than the engine.

Hope this helps!

Nov 30, 2008 | 2002 Pontiac Aztek

Not finding what you are looking for?
2004 Chevrolet Corvette Logo

Related Topics:

180 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...