Question about 1999 Ford Expedition

1 Answer

Vaccum leak ford expedition 99 - 1999 Ford Expedition

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 625 Answers

Whats the question? how to find it?

Posted on Jun 22, 2008

1 Suggested Answer

wireguy212
  • 1627 Answers

SOURCE: radiator leak 99 Ford Expedition back drivers side

You are likely leaking coolant from a heater line or hose,check the hose that comes from the water pump{smaller of the two] and see if it has a leak in it or if there is just a loose hose clamp.If you can't find a leak in the hoses or any steel tubes then you need to take it to a radiater shop and have it pressure tested to see if you have a leak in the intake manifold gasket or maybe even the head gasket,good luck.

Posted on Dec 02, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Po 174 on a 2003 expedition 5.4 engine


If its running rought at idle, check for a vaccum leak, check over by the top back of engine, vaccum leak will give you that code, hope ths was very helplful.

Oct 10, 2011 | 2003 Ford Expedition

1 Answer

I have a 2000 Ford Expedition with 4.6 litre Triton engine. The ac blower air quits at front vents and goes to defrost vents when acclerating or when I am going onto the freeway on the ramp. It seems the...


yes you have a vaccum leak some where. there is a vaccum cannister attached to the battery tray so it could have corroded something or you have a one way valve that clould be bad on the black vaccum hose coming out of the fire wall goin to the engine

May 09, 2011 | 2000 Ford Expedition

1 Answer

What is code po171 on a 1998 Ford expedition


refers to o2 sensor bank 1 s1 is reading lean check for exh leak vaccume leak egr intake check for misfire


let me know if this helps comment reply if you need more info

Jan 18, 2011 | 1998 Ford Expedition

1 Answer

System adative fuel too lean bank 1 and 2 1999 ford expedition when driving try to give gas it chooke back fire in air intake


Sounds like a vaccum leak or air intake leak. Check all hoses for cracks,cuts,ect. Also check all hose clamps. If this helps great if not I might have a few other simple things to share with you. Get back to me

Sep 13, 2010 | 1999 Ford Expedition

1 Answer

Cruise Control is just not working / 2002 Ford Expedition 4.6 Motor


try looking all around the unit for a vaccum leak , it fixed mine

Jun 03, 2010 | 2002 Ford Expedition

1 Answer

Radiator leak 99 Ford Expedition back drivers side


You are likely leaking coolant from a heater line or hose,check the hose that comes from the water pump{smaller of the two] and see if it has a leak in it or if there is just a loose hose clamp.If you can't find a leak in the hoses or any steel tubes then you need to take it to a radiater shop and have it pressure tested to see if you have a leak in the intake manifold gasket or maybe even the head gasket,good luck.

Dec 02, 2009 | 2001 Ford Expedition

1 Answer

My 98 expedition will crank right up and run at a


high idle it may have a big vaccum leak that could cause the whole problem check all vaccum lines for cracks, collapsed, or off

Oct 21, 2009 | 1998 Ford Expedition

Not finding what you are looking for?
1999 Ford Expedition Logo

Related Topics:

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60792 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...