Question about 2000 Nissan Altima

1 Answer

2000 altima dash goes out,no odometer,tach,or temp gauge,then will come back on,is there a relay or contol box i could replace to fix this problem????

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 4 Answers

I had same problem i just took and cleaned conection on positive battery cablewhere they all conect with wing nut also replaced 80amp main fuse in box next to battery it was coroded inside never happened again

Posted on Jul 18, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I fix my gauges? (Ie, gas gauge, temp gauge, speedometer, odometer)


Fuses? Blown fusible link? Most gauges work by getting 12 volts from the ignition switch when on, and getting a ground from the sender. Often the 12 volt supply wire goes to more than one so if dead, both will fail. If you have a wiring diagram, you might find which wire to cluster should be hot, and trace it backward to find the issue. Easier to check for ignition switch feed first.

Jul 01, 2015 | Cars & Trucks

1 Answer

Instruments don't work, key stuck in ignition, doesn't shift correctly


Sounds like you need a new car.
With joking aside, the problem with your speedo, tach, gas guage, temp gauge and odometer can probably be one of two things. Check your fuses. If they are fine you may need to replace your cluster panel. I had to have the entire thing changed over my speedo not working right. It was not cheap. You might want to check the relay box under the hood. Does your transmission leak? Check the fuses and relay on it also. Get a new ignition switch and replace the old one if your key is stuck. You can try WD40 on that key but don't expect any miracles. The bearings are likely shot. Sorry I posted all of this bad news. Good luck.

Jan 05, 2014 | 1998 GMC Jimmy

1 Answer

I have a 1995 nissan altima.I changed the motor on it twice .The third motor I got from a 2000 altima ,same motor different year. Anyhow when running the motor,if I plug in the fan switch the fans will not...


You have quite a situation. It sounds as though the Coolant Temperature Sensor is faulty. That sensor will control the temp gauge in the dash as well as control the cooling fans when necessary. As to why the fans are constantly running whether the switch is on or not would mean that there is power to the fans bypassing switch, possibly from another connection in the harness. First off I would try replacing the fan relay, it may be stuck closed, just switch it out with another of the same type connection from the fuse box to see if there is any change. If that doesn't work then I would check to see if the wiring from the coolant temp sensor and the fan switch run through the same area of the harness. Its possible that you may have a short circuit at that point. That may possibly explain why the gauge is reading hot when the motor in fact is not. Hope this helps. Good Luck.

Nov 08, 2011 | 1995 Nissan Altima

1 Answer

Dash board gauges not working on voyager 2000


You need to check your main fuses under the hood first and then check them under the driver side dash board.

Jan 25, 2010 | 2000 Plymouth Voyager

1 Answer

Instrument Panel Problem - Electrical


check all wiring and maby youl get it right

Sep 18, 2009 | 2005 Chrysler PT Cruiser

1 Answer

Everything on dash panel not working.


Fuse for the instrument panel is possibly blown. Check your owners manual for the proper location of the fuse. If you do not have a manual they are available online in PDF version.

Jan 09, 2009 | 2000 Chrysler Town & Country

2 Answers

2001 Nissan Altima - Instrument panels gauges stop working


My 2001 Altima's instrument gauges die out after high-speed driving for 40-50 miles. Engen also loses power. Everything is back to normal when the car cools down. It turned out the ingition relay was bad. I could duplicate the problem right away by removing the relay. Actually, it is very easy to find the relay which is located above the fuse panel. The ignition relay is the bottom left one among the five relays there. It costs only $20.

Aug 14, 2008 | 2000 Nissan Altima

Not finding what you are looking for?
2000 Nissan Altima Logo

Related Topics:

161 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

64052 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

705 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...