Question about 1996 Chevrolet Camaro

3 Answers

Stalling at speed 3.8 liter

1996 3.8 liter automatic stalls at speed 45 mph and above. It does not miss or sputter it just stops sometimes it will restart on its on without pulling over like you turned the ignition off and back on at highway speed
other times you have to pull over and restart. It acts like an ignition problem
but never sets a code in the ecm. Seems to occour when engine is warm.
Any advice will be greatly appreciated

Posted by on

  • 1 more comment 
  • Jack71252 Jun 21, 2008

    the cooling system was just flushed and refilled level seems fine and temp gage stays just over 160° I will recheck

  • Jack71252 Jun 22, 2008

    1996 Camero 3.8 135,000 miles stalls and check gages light comes on. Replaced temp sending unit and water pump cooling system flushed and refilled, oil is fresh and at proper level
    alternator replaced. It still stalls.

  • Jack71252 Jun 23, 2008

    It just stops it feels more like an ignition problem that is it stops no spit or sputter but then you can restart at once this is an intermittant problem have a new fuel filter will install Maybe fuel filter overheating? Would that not set a trouble code?

×

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 638 Answers

This the best link to solve all your car problems it mentions A to Z reparing

http://www.ptdoityourself.net/tl/tl_indexmain.html
or
http://en.allexperts.com/q/Buick-Olds-773/Ignition-tumbler-replacement.htm

feel free 4 further assistance .rate the particular experts solution as fixya that helps u understand n solve ur problem

Posted on Jun 23, 2008

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 426 Answers

This sounds like a bad fuel system somewhere you have a blockage or a bad pump where the engine can not supply gas, to test this put the car in netural and rev the engine and see if it stalls if it does not rhen your speed limiter has a bad sensor and needs to be checked, OR you might have a bad transmission in one of the gears does it make any noise or does it just stop?

Posted on Jun 23, 2008

  • 1 more comment 
  • Lee N.
    Lee N. Jun 23, 2008

    no it prbly wouldnt set a trouble code, the engine simply doesnt know its not running the pc and every thing are standalone from the actual car, the computer might see that the temp is dropping but it doesnt think that there is anything wrong there i still would say its your speed limiter, this happens a exactly 45mph right? had this happen to my car but it happened at 63.2mph and the computer thought i was doing double because offaulty wiring on a speed sensor

  • Lee N.
    Lee N. Jun 23, 2008

    and please rember that a tft rating when something is still being discussed discourages alot of people because these ratings hurt us...

    ~Lee


  • Lee N.
    Lee N. Jun 23, 2008

    let me know what the results of the rev test are and i will try to help you from there

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 848 Answers

Just frequently check the coolant

Posted on Jun 21, 2008

  • gopinath pasupathy Jun 21, 2008

    replace the coolant periodically so that the engine works well

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i stop my 1994 ford explorer from sputtering and shutting down when driving at low speed


Not getting enough fuel. There are two coolant temperature sensors one for the gauge. one for the computer. the one to the computer monitors fuel. When it fails the engine is slow to start the first try and there is a strong odor of gasoline. The engine will run rough at some speeds and sometimes stall.

Dec 27, 2014 | 1994 Ford Explorer Limited

1 Answer

Stuttering acceleration


Has the engine light come on yet?

Mar 28, 2014 | Chevrolet Cars & Trucks

1 Answer

What deos 4d means in a automatic


4 D refers to 4th gear overdrive for highway driving sustained speeds above 45 mph, 3 D for speeds under 45 mph

Mar 24, 2014 | 1995 Honda Accord

1 Answer

Misses when accelerating


sounds like the lambda sensor or crank sensor. does it work fine from cold?

Mar 11, 2014 | Nissan Pickup Cars & Trucks

1 Answer

Stalls sometimes when stopped at lights engine misses at stop


Engine stalling and rough run issue at low speeds

This problem is commonly caused by a dirty automatic idle speed control valve and throttle valve. Buy a can of throttle valve cleaner (do not use carburetor spray cleaner!) from NAPA or Carquest (made by CRC chemicals) and spray it into the air intake while the engine is running, use up about 1/2 the can, engine will try to stall hold the speed up, shut it down and let it soak for 30 minutes, restart and blow out the remaining fluid, shut it down and disconnect the negative battery cable for 5 Min's to reset the base idle control

Sep 04, 2012 | Cars & Trucks

1 Answer

1999 Dodge Ram 1500 5.2L 2WD Sputtering Problem


Take it some where else and get it scanned for codes.. it sounds like a ground issue to me. Throwing parts at it will only get expensive and you may never end up changing the right part before you get sick of it.

Jul 24, 2010 | 1999 Dodge Ram

1 Answer

Car sputters and stalls


IF I UNDERSTAND YOU RIGHT YOU ARE HAVING A MISFIRE ISSUE UNDER LOAD MOST COMMON FIX IS PLUG WIRES. CHECK VEH FOR BASIC TUNE UP FUEL FILTER PLUGS WIRES FUEL INJECTION CLEANING

Feb 11, 2010 | 2002 Ford Escort

2 Answers

My 1996 cutlass ciera stalls out sometimes after I start it and put it in gear. It has also died out when I was driving at lower speeds as well as higher speeds as 70 mph. It acts like it is just losing...


Try the fuel pump Relay. I had the exact same problem and thats all it was. It will eventually stop sending fuel at all. The relay is under the hood on the passenger side front corner. Ther are I think 5 there, the fuel pump relay is all the way to the right looking down into the engine compartment. Hope this Helps

Nov 10, 2009 | 1996 Oldsmobile Cutlass Ciera

1 Answer

Sputtering


Have You Changed The fuel filter? Surging at higher speeds or cruising speeds, My guess is fuel filter.

May 30, 2009 | 1997 Dodge Ram 1500 Club Cab

Not finding what you are looking for?
1996 Chevrolet Camaro Logo

131 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...