Question about 1994 Chevrolet K1500

2 Answers

Truck's dogging it

When truck is cold it idels fine but under load it will sputter till i power through it then when its warm the sputter goes away and just seems to fall on its face during accel.The things i've done are a compleat tune up including throttle body serv. intake gsk. some help would be greatly appriecated. thanks in advance.

Posted by on

  • 1 more comment 
  • bob_kat Jul 01, 2008

    could it be the oxegen sensor?

  • bob_kat Jul 02, 2008

    i've done a ompression test and i have good compression and all 8 cyl hold pressure. No more than 5 pds difference between cyl. It's a 5.0 l with 220,000 km. the problem just happened then my teck noticed the intake gsk leaking antifreeze so i changed them did a full tune up ,plugs,wires,cap,rotor,fuel,air and oil filter,pcv valve,oil change, valve cover gsks, cleaned the entire throttle body including the IAC motor,did a TPS sweep,is ok,checked for vac leaks,none,even cleaned the ing.module and checked the magnet in the distributer for cracks and none. runs strong but has this bad sputter and seems sluggish. Was hoping all this might have fixed the problem but now i have a clean top end and some new parts

  • bob_kat Jul 05, 2008

    no it did not

×

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 34 Answers

VALVES AND VALVE SPRINGS. While your at it change the timing chain.

Posted on Jun 29, 2008

  • scott gibson
    scott gibson Jul 01, 2008

    There are a few sensors that can create your same problem, at $40.00 and up you really should pull the engine trouble codes first.

    What size and year is the engine and how many miles on it.

    how long has this been happening and was there anything that could have caused it to go south on you? like did anyone pour something in your fuel tank that should not be in there?

  • scott gibson
    scott gibson Jul 03, 2008

    When the valve cover gaskets were changed, did an inspection on the valve springs and seals reveal any dried and cracked seals or broken springs?

×

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 2,920 Answers

Its probably going to be the catalytic converter my truck did it too and proved to be a clogged converter

Posted on Aug 09, 2008

  • Ronnie Houston Aug 13, 2008

    catalytic converter is clogged

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Whining noise when extreme cold days, that goes away when my 2005 Mariner warms up. Seems to come and go until the car warms up.


Alternators can sometimes whine when start up on a cold morning, they run on full load till they get the battery back up to full charge. When the whining stops, switch on electrical equipment (Headlights, fan full boost, heated rear window) if the whining starts again its the alternator.

Jan 23, 2014 | Cars & Trucks

2 Answers

My 1991 Jeep Cherokee runs great till it warms up, once it warms it seems to sputter and miss


easy way to strat is check all your spark plugs.jeeps are also known for the crank positioning sensors going bad.another possibility is the oxygen sensor

Jan 21, 2011 | 1991 Jeep Cherokee Limited

1 Answer

1986 Ram 50: Engin and carburator sputter and lose power when g...


i have an 86 dodge ram 50 that sputters when i step on gas going up hill after it warms up ive changed the gasket twice with no luck solving problem it runs fine in neutral but in gear under a load it sputters

May 14, 2010 | 1986 Dodge Ram 50

1 Answer

1990 full size blazer starts fine idles then dies


sounds real easy either a bad idle air control solenoid or more likley a blown throttle body gasket. to test fro a blown gasket, with engine running and cool spray carb cleaner or brake cleaner around base of tb were it bolts to intake. when it hits the bad area, should idle down and be normal for a second or 2. iac is possible,try this first since its so common and let me know

Aug 26, 2009 | 1990 Chevrolet S-10 Blazer

1 Answer

Wont idel when warmed up


seems to me there may be a problem with the transmission, because you say it runs fine in neutral and dies when you put it in gear!!!
only logical thing if everything else you mentioned has been ruled out!!!

Jun 18, 2009 | 1995 Dodge Dakota

1 Answer

Rough idel when cold start


if u have a damaged plug it can be running on 1 less cylinder ,it will idle very rough,change it!

Mar 26, 2009 | 1993 GMC Safari

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

194 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

78289 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...