Question about 1993 GMC Sierra

1 Answer

Changed roter,cap.nows it runs like **** theres a pink knock.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 64 Answers

You probably bumped your dist to one way of the other. advance will cause a ping. also check the placement of the plug wires to make sure your not off by one.

Posted on Nov 13, 2010

Testimonial: "thanks but wires are on properly,never touched anything else.could the EGR valve be MY PROBLEM. "

  • 2 more comments 
  • j_ettinger Nov 13, 2010

    DOES ANYONE NO THE FIRING ORDER ON TH DIST CAP WHERE NUMBER ONE STARTS.THANKS

  • j_ettinger Nov 13, 2010

    94 GMC 5.7 ENGINE.FIRING ORDER ON DIST CAP WHERE ONE IS

  • james sasser
    james sasser Nov 13, 2010

    number one is at the 11 o'clock position

  • james sasser
    james sasser Nov 13, 2010

    get a test light and while running stab each wire at the cap to see if it is firing. I just tuned mine up but runs the same. i've got bigger problems with mine.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1994 corolla cranks but, won't start, and blows a 15 amp fuse of some kind


There is a possibility this could be your fuel pump fuse. Without current the fuel pump will not pump fuel and the engine will not run. Can you be more specific about which fuse is being blown? The fuses in the engine compartment are identified in the diagram on the fuse box cover. If this is not legible, take a picture and post it here to identify the fuse. The fuses in the inside compartment are identified in a diagram on the fuse panel door.

Does the fuse blow as soon as you turn the key in the ignition, or does it blow after you crank the starter?

Try this: turn the ignition key to the on position. The fuel pump is right under the rear seat on the passenger side. If it is running you will hear it humming. You can also hear it humming from outside the car. It will run even with the engine off, but with the key in the on position. If you do not hear anything, the fuel pump is not running.

If the fuel pump is not running it could be due to a number of causes. Could be a faulty pump, or faulty wiring, or faulty harness. You will need to diagnose the cause with a voltmeter.

ad9d9e6.jpg

Jan 19, 2010 | 1994 Toyota Corolla

1 Answer

Car ran fine then on a long trip developed some loss of power now


does the engine get over heated if so check the radiator system, also check oil level.

Sep 22, 2009 | 1991 Cadillac DeVille

1 Answer

Firing and cylinder order for 91 dodge dakota 5.2L


isnt there a sticker inside the engine bay somewhere?

Aug 23, 2009 | 1991 Dodge Dakota

2 Answers

Mazda mx 3 1992 not start


Check for possible vacuum leak, maybe a hose off or partially broken. Make sure your firing order is correct when reconnecting those wires to the new cap.

Jun 28, 2009 | 1992 Mazda MX-3

2 Answers

2000 nissan xterra knock senor and plug 5


Have you changed all the plugs to platinum and wires? My xterra was doing that and I changed all of them and now it runs great. Also, I changed the distribitor cap and rotor button.

Jun 10, 2009 | 2000 Nissan Xterra

1 Answer

Wont start


are the plugs firing in the right order?

Dec 29, 2008 | 1990 Dodge Dakota

1 Answer

Bmw 525i (1990) intermitent ignition prob


Install hotter plugs and run it harder between stops. Also check your fuel pressure regulator.

Dec 29, 2008 | 1990 BMW 5 Series

1 Answer

4.3l 1990 blazer


wehad this problemb when ou mecanic changed the roter cap he bumped the timeing so it was off just a little then of course wanted to charge to fix it we just turned or nudged the poins module under the cap alittle and it idles now. not perfect but better

May 24, 2008 | 1990 Chevrolet S-10 Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

79 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...