Question about 1998 Ford Ranger SuperCab

1 Answer

My truck idles rough and dies at low rpm, runs decent when driving at normal speeds. This is after replacing mass air flow, plugs, plug wires. Cleaned throttle body, ran injector cleaner, and high octane gas. Runs better in normal driving, but still idles rough. Scanner says oxygen sensors The truck has been burning more fuel over the last few months until It missed so much you couldn't drive. Any ideas?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 539 Answers

Uh, maybe the scanner is right!?

Posted on Jul 26, 2017

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 2 Answers

SOURCE: 1998 olds intrigue trouble code p0171

I have a dianogstic machine and the code you were given indicates that the system is too lean. (Bank 1) Were you go from here i'm not too sure. Steve

Posted on Oct 01, 2008

  • 17 Answers

SOURCE: '92 Mitsubishi Diamante - Stalls sometimes when come to a stop

find the Idle air control valve on the side of the intake and then take off and clean or replace you could try taking a small ball peen hammer and tapping it lightly while it is idling let will genarly free them up

Posted on Mar 04, 2009

jagjeffery
  • 318 Answers

SOURCE: throttle body injectors not fiering but there is fuel pressure

the injectors are fired thru the engine cotrol module but it gets its signal to fire from the pick-up located inside the distributor if you are loosing injector pulse only the ignition module is bad if you are also loosing spark when you loose injector pulse your pick up is causing the problem if you replace the pick-up i recomend you change the ignition module when doing so because they work together and you have to remove the distributor to change the pick-up

Posted on May 31, 2009

co7196
  • 3433 Answers

SOURCE: my 1993 GMC Suburban 5.7 liter with throttle body

Wow, That has gotta be a pain. The Maf sensor regulates the fuel supply needed for proper air fuel ratio by telling ecu how muc air is moving thriugh the intake. Check it first, Then the TPS. Good Luck.

Posted on Jun 05, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a 2003 jeep grand cherokee limited. it starts alright but dies almost instantly. when it does stay running it idles rough and at a low rpm. I think it could be the cam sensor but im not sure.


Checking for diagnostic trouble codes would be a good first step before assuming anything . Could have a vacuum leak , a Idle air contorl valve problem ,Mass air flow sensor problem, tps -throttle position sensors . A dirty throttle plate . Suggest you check out videos on youtube on rough running ,stalling problems !

Dec 14, 2016 | 2003 Jeep Grand Cherokee Limited

1 Answer

My 1995 Mustang GT won't run right!


Your problem is it is a ford,LOL:

Nov 03, 2012 | 1995 Ford Mustang GT

1 Answer

'93 D21 ka2.4. miss fire,surge, and runs rich


sounds like you have a very dirty mass air flow meter. invest in a new one and be sure to clean the throttle body with an appropriate cleaner and tooth brush.

Nov 03, 2009 | Nissan Hardbody Cars & Trucks

2 Answers

Hi, I have a 2006 Altima with 31,500 miles. Recently, the engine start shaking when car is Idle but I still feel the shake when driving or at red lights. My second problem is a weird loud (humming) noise...


You don't need to change the spark plugs since it has only 31.5 K. The plugs should last 60K. There is a an adjustment at the gas cable end at engine to increase the idle a little bit. You can increase rpm at idle to 600 RPM. Since your RPM at idle is low that why it is shaking at idle, red lights. Let me know it it is shaking at high speed ( 2500 RPM)

Sep 13, 2009 | 2006 Nissan Altima

1 Answer

98 Lincoln Navigator Check Eng light on


fuel pump is going out causing the truck to run lean and miss

Aug 22, 2009 | 1999 Lincoln Navigator

1 Answer

1988 ford festiva


start with a tune up, (air filter ,spark plugs, plug wires ext)..adjust carborater(air fuel mixture could be off)

Jun 02, 2009 | 1991 Honda Accord

1 Answer

Runs bad


I had to replace ever frigging vacuum hose on mine, and that seemed to help...

Apr 04, 2009 | 1985 Nissan King Cab

Not finding what you are looking for?
1998 Ford Ranger SuperCab Logo

Related Topics:

155 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

fordexpert

Level 3 Expert

5537 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...