Question about 1993 Oldsmobile Cutlass Supreme

1 Answer

OKay so the guy who had my car before me didnt out oil in it and it stopped working. i filled it up with oil and it started up after a few tries. It worked perfectly for about 50 km then it started to make this insanley loud noise in the engine. Can i fix this? and what is the problem?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 7,353 Answers

It needs a new engine. I hope you bought it cheap.

Posted on Nov 12, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

How long can a musso 622 engine run without water


Hi Stefan:
I would not even consider trying to run the engine without coolant.
Diesel engines run hot and the engine will be ruined if run without coolant.

Sep 18, 2015 | Cars & Trucks

1 Answer

1996 izuzu trooper oil gauge is at 0


The gauge could be broke,or you may be out of oil ,or your oil pump may have stopped working . if out of oil fill it , if the oil pump is no longer working usually the engine will tick but if you didnt hear it ,Dont drive it any further without replacing oil pump or you will seize your engine,

Oct 08, 2014 | Cars & Trucks

1 Answer

Oil light on and engine making a lot of noise


put oil bank in the crankcase. the dip stick shows this.
always check oil levers. every 2nd fill up.
all engine burn oil. All.

Mar 19, 2013 | 2006 Suzuki Forenza

1 Answer

Low oil pressure warning keep coming up but my oil pressure is fine


Could be a few things, first Get it checked with a mechanical gauge to test low motor oil, clogged oil filter, bad oil pump, clogged oil sump (pick up tube) or bad oil sending unit. Then replace sending unit sensor.

Mar 01, 2012 | 2006 Chevrolet Monte Carlo

2 Answers

Hello i have a question i just bought a 2000 ford expedition and the person i bougt it from didnt run it for about 4 months and when we crack it up the ac didnt work we put atifreeze and still didnt work...


add R134a freon and use a fill hose with a gage and keep in safe range. Keep can upright to fill system as a gas. Inverting will send a flood of liquid freon in - not good.
Can you hear the a/c clutch engage and disengage a few times/minute?

Jun 23, 2011 | 2000 Ford Expedition

2 Answers

Had oil changed at first service as light was flashing didn't take to suzuki dealership ,garage couldn't reset .how do you reset and stop the light flashing . my car is 08 suzuki swift


Okay in your owners manual look up oil service light and it will give you a few steps on how to reset it this has to be done every time you change the oil and most mechanics should know how to do it except wal mart their not certified mechanics. But you can take it to any mechanic or say like a Jiffy Lube or who ever doe's oil changes like these guys and have then help you reset the light but it should tell you in the owners manual.

Feb 07, 2010 | 2007 Suzuki XL-7

1 Answer

Won't start after stopping


sounds like the thermostate is no good and you probably overheated the car hope you didnt ride to long while overheating ---fill all fluids to normal and try to turn the car over when the engine is cold to see if it starts. if it runs and sounds fine dont let it get to hot watch gage let it go to 180 - 200 if it climbs higher shut car off and have a mechanic check it out or replace thermostate cheapest way out. if car does not run right or makes noise as soon as it starts u have added problems. u didnt mention if there was antifreeze leaking any where

Mar 18, 2009 | 2001 Chevrolet Metro

1 Answer

Xterra no oil pressure


inner timing cover y shaped oil gallery gaskets..make your own or order the complete cover..costs from nissan are 500 canadian for the cover and around 1500 total for the replacement.oil pressure goes back up immediately after the install..alot of work to replace a cheezy piece of paper...

Nov 04, 2008 | 2000 Nissan Xterra

1 Answer

1996 Cavalier--PLEASE HELP


Maybe try to replace the map sensor and the oxygen sensors

Jul 26, 2008 | 1996 Chevrolet Cavalier

Not finding what you are looking for?
1993 Oldsmobile Cutlass Supreme Logo

Related Topics:

73 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8514 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...