Question about 1999 Oldsmobile Alero

1 Answer

1999 Olds Alero 4 cyl running hotter than normal. One mechanic says it's Heat sensor that opens and closes. The other mechanic who ran car says it was thermostat that turns on dual fans. Ok well one was fixing it was the last one so we did that. Noticed water leaking but running ac thought normal. Still running hotter than normal. Went to town got it hot had to pull over. Antifreeze/coolant overflow now empty. Let it cool for a little while. Added Antifreeze/coolant, coming out as putting in. Lines and tank dry. Drove it under 5 miles home. Fluid leeking out.

Posted by on

  • richard allen Jun 15, 2012

    you have a coolant leak have it press. tested

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Oldsmobile Master
  • 14,036 Answers

REPLACE THERMOSTAT.ITS STICKING CLOSE TO KEEP COOLANT FROM CIRCULATING THROUGH ENGINE AND RADIATOR. THE FANS SHOULD COME ON WHEN VECHICLE SETTING AT A LONG IDLE.THE COOLANT TEMPERATURE SENSOR GET TO CERTAIN TEMPERATURE WHICH WILL COMPLETE CIRCUIT PCM SEND POWER TO COOLANT SENSOR THEN TO COOLANT FANS RELAYS AND FANS.IF VECHICLE OVER HEATING WHILE MOVING THERMOSTAT FAULTY.IF YOU TURN AC AND COOLANT FANS DONT RUN CHECK COOLANT FANS FUSE AND RELAY.IF COOLING FANS DONT TURN ON WITH AIR CONDITIONER ON EITHER COOLANT TEMPERATURE SENSOR FAULTY OR PCM FAULTY.IF ALL LOOKS GOOD.IF ENGINE OIL LOOKS LIKE MILK SHAKE.YOU HAVE BLOWN HEAD GASKET.

Posted on Nov 12, 2010

Testimonial: "This was all checked and fixed. You are right however the downpour of the radiator fluid out of the overflow tank area said it was the water pump. "

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Location of MAP sensor on 2002 Alero GX 2.2?


Oldsmobile Alero MAP Sensor - PartsGeek.com

www.partsgeek.com > ... > Oldsmobile MAP Sensor > Alero Parts
Oct 29, 2008 - 04 2004 Oldsmobile Alero GL MAP Sensor 3.4L V6 VIN: E Delphi · Click to Enlarge ... Vehicle, Engine. • 2002 (02) Oldsmobile Alero, 3.4L V6. 04 2004 Oldsmobile Alero MAP Sensor 2.2L 4 Cyl Standard Motor Products.

Part 1 -How to Test the MAP Sensor (GM 2.4L Quad 4)

troubleshootmyvehicle.com > GM > 2.4L
Jun 7, 2011 - GM 2.4L MAP Sensor Test with a Multimeter. ... 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002. Malibu 2.4L. 1997, 1998 ... Alero 2.4L. 1999 .

Nov 08, 2015 | Cars & Trucks

1 Answer

Why does my 1999 Oldsmobile alero runs rough when the track off light is on


1999 Oldsmobile Alero Stumble and Loss of Power 3000rpm

www.2carpros.com/.../oldsmobile-alero-1999-oldsmobile-alero-stumble-...
Sep 28, 2008 - Engine Performance problem 1999 Oldsmobile Alero 6 cyl Front ... Hey All, Had a very rough running Mazda 626 on LPG, engine code FP.

1999 Oldsmobile Alero High Idle Fix - YouTube

? 1:47
www.youtube.com/watch?v=xBV9BmjFZVs
Jul 4, 2010 - Uploaded by GrindTimeAuto
1999 Oldsmobile Alero High Idle Fix ... How To Fix Or Prevent Stalling, Surging Or Rough Idle, Cleaning Throttle Body and MAF Sensor ...

Feb 17, 2015 | 1999 Oldsmobile Alero

1 Answer

How to run the exhasut pipe on a 1999 alero 4 door 4 cyl


BEST TO LET MUFFLER SHOP DO THE JOB FOR YOU.BECAUSE EXHAUST SHOULD NOT RUN CLOSE TO FUEL TANK AND FLOOR PANEL FACTORY PUT HEAT SHIELDS UNDERNEATH VECHICLE WHERE EXHAUST RUNS UNDERNEATH.LET THE MUFFLER SHOP DO THE EXHAUST PIPE WORK.PIPE HAS TO BE BEND IN A WAY IT WONT DRAG HIGH WAY AND HIGH BUMPS IN THE ROAD.

Nov 02, 2010 | 1999 Oldsmobile Alero

1 Answer

How do i know my ETS is on on my 99 olds alero


IF YOU TALKING ABOUT ENGINE TEMPERATURE SENSOR.MOST OF TIME WHEN IT GOES BAD.YOUR ENGINE WILL OVER HEAT.COOLANT FAN WONT TURN ON.I SEEN A BAD COOLANT TEMPERATURE SENSOR CAUSE ENGINE STAY IN OPEN LOOP.CAUSE POOR ENGINE PERFORMANCE.FUEL CONSUMPTION.

Sep 22, 2010 | 1999 Oldsmobile Alero

2 Answers

2004 Olds Alero - Just curious - does this


2.2 L 4 cyl timing chain. 3.4 L 6 cyl timing chain

Mar 02, 2010 | 2004 Oldsmobile Alero

1 Answer

Where is the camshaft position sensor on 1999 olds alero?


ON THE 4 CYLINER ENGINE CAMSHAFT SENSOR LOCATED AT THE LEFT DRIVERS SIDE OF THE TIMING COVER. THE V - 6 ENGINES CAMSHAFT POSITION SENSOR LOCATED AT THE FRONT OF ENGINE BLOCK BELOW THE POWER STEERING PUMP.

Feb 13, 2010 | 1999 Oldsmobile Alero

2 Answers

1999 Olds Alero leaking coolant and running rough


in my experience it sounds like a head gasket problem it maybe leaking into the cylinders or could be a small leak from one of the hoses I would do a compression test just to make sure and then pressurize the entire system using radiator and coolant tester if pressure holds then its not a leak as far as the fans go just have the car running when it reaches the middle of the temp gauge it should come one if not you may need to run check on temp sensor or fan switch and fans them selves I would follow repair manual troubleshooting section on heating and cooling haynes or chiltons will do.

Jan 31, 2009 | 1999 Oldsmobile Alero

3 Answers

99 olds alero 2.4


I'm sure you have installed a fuel pressure gauge and monitored the fuel pressure while the problem is occurring?Another diagnostic tool which is easy to do,is while the problem is occurring,unplug one sensor at a time beginning with the Mass Air Flow first,.if it uses one.Many times,not always,depending on the sensor,if the sensor is taken out of the picture as far as what the PCM is seeing,like unplugging the MAF,the PCM will substitute the missing sensor output with a generic value that will allow the engine to at least run,and if unplugging for example the MAF,the engine idle speed returns to normal,you know you're onto the problem.You didn't mention if the engine ran ok other than the idle problem.As far as checking for vacuum leaks,i use something like brake cleaner or WD 40,more of a liquid,and it does sound like a vacuum leak.Plastic intake manifolds do develop nearly invisible cracks that open up more with heat.Revsisit the possibility.And as for the PCM,it is possible,but more likely a mechanical problem.Lastly,remove an O2 sensor or two before the catalytic convertor,run the engine and see if anything changes.Cheap way to verify the catalytic convertor is flowing and not restricting engine airflow,as i have seen bad cats cause misfire codes and strange problems.Good luck.

Dec 03, 2008 | 1999 Oldsmobile Alero

2 Answers

1999 oldsmobile alero


also check he hoses to the map sensor...its a small sensor on the back of the upper intake plenum. Pretty common issue....

Oct 03, 2008 | 1999 Oldsmobile Alero

Not finding what you are looking for?
1999 Oldsmobile Alero Logo

582 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...