Question about 1997 Dodge Avenger

1 Answer

LOOSE POWER AFTER ABOUT 15 MINS ON.. STAYS ON BUT THE IDLE DROPS BELOW THE 1 .. WHEN DRIVING IT RUNS GREAT .. STOPPED AT A LIGHT IT LOOSES POWER.. BUT STAYS ON DOES NOT SHUT OFF.. THE FUEL PUMP AND FUEL FILTER HAVE BEEN REPLACED .. ALSO NEW TIMING BELT AND NEW DISTRIBUTOR ROTOR AND CAP AND WIRES AND SPARKPLUGS .. NEW EGR VALVE AND NEW TAC AND PCV VALVE AND FUEL PRESSURE REGULTOR REPLACED AND IDLE SENSOR REPLACED AND OXYGEN SENORS REPLACED AND TPS AND IAC REPLACED .. WHAT ELSE SHOULD I LOOK FOR OR WHAT ELSE IM I MISSING ??????????

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 134 Answers

I am gussing you are not getting an engine light it seems you have ruled out all the usual suspects?

Posted on Nov 11, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 1995 ford explorer looses power after 40 minutes of driving. I turn off wait for 10 to 15 minutes then resumes again.


Bummer deal! Sounds like the fuel filter is clogged. My motorcycle did the same thing and a new filter and a special kind of additive treatment restored its like new power - though 15 years old. The product from Mega Power is listed below and can be ordered on line. Its made for cars - and a motorcycle works exactly like any car does. Rarely, a fuel pump going dead will overheat and stop. Then restart. You can change the filter. A mechanic can check out the gas pump - Hope this helps. DIY fuel injector cleaners fast acting Ends several tune up problems

Nov 05, 2014 | 1995 Ford Explorer

1 Answer

2007 chevrolet impalahave a 07 impala runs great till ur rpm meter goes past 4000rpm then drops down to 0 runs bad after shut down engine for around 10 mins then runs good again check with scanner no


It needs a scanner on it to find the problem while driving it. Several things can cause this. At 4000 rpm's in park the ecm will suppress the engine. this would be the Neutral safety switch. So going from there, if not the switch, it could be wiring or a bad buffer in the ecm.

Oct 16, 2014 | 2007 Chevrolet Impala

1 Answer

Chrysler rough idle and rough idle when stopped in drive


check for loose/ missing vacuum lines on the engine . Easy enough when replacing an engine.

Feb 24, 2014 | Cars & Trucks

2 Answers

2003 chevrolet check engine light flashes going up hills looses power


flashing is usually a sign of a bad misfire situation, check the plugs and wires, also check for coolant in the oil or oil in the coolant.

Sep 03, 2012 | Cars & Trucks

1 Answer

When I start the car it stays at 2000rpm for a few moments then drops down. I'll drive for a few minutes then put it in park and it revs up and down.


idle air control valve is bad replace it. at start up choke control runs till warm up while driving throttle opening controls engine at idle ,the idle air control valve.

Aug 01, 2012 | 2005 Chevrolet Aveo

1 Answer

Looses power on hills 2.0L eng runs great on level, loss of power drops at least 15 MPH going up hill on interstate


I removed bottom cataytic converter it look good but I put a pipe in place and have great horse power

Oct 11, 2011 | 2001 Kia Sportage

1 Answer

1990 Fox Drops to Slow idle speed after 10-15 minutes Driving


I had the exact same car, and almost the exact same problem, it was the Mass Airflow sensor, you will have to get a new one, or look in the forums for a way to modify it, there was some problem with it fouling, it was really strange. But also, if it was even drivable, it would lose all power within about 30minutes. I hope that helps

Feb 22, 2009 | 1990 Volkswagen Fox

Not finding what you are looking for?
1997 Dodge Avenger Logo

Related Topics:

156 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

76132 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...