Question about 1996 Mercury Villager

1 Answer

Vehicle idles fine but sputters and wont accelerate hardly at all when i put it in drive and try to go

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mercury Master
  • 4,369 Answers

Clean MAF sensor first with carb cleaner.

go here

http://groups.yahoo.com/group/villagerquest/

Posted on Dec 03, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What to do with sputtering and lack of acceleration


Scan for codes stored ion the OBD computer. Many auto parts stores can do this for you at no charge. Based on the results - a complete tune up may be in order.

Good luck!

Apr 14, 2015 | 2002 Ford Taurus

1 Answer

1992 pajero auto temp light stuck on when motor wasn't running long when accelerating vehicle stopped then hard to start now won't start at all,


Sir if the starter is not even turning im sorry to inform your engine might be broken. Lack of oil could be the reason. I d reccomend to send to a mechanic shop inmediately.

Jul 12, 2014 | 1995 Mitsubishi Montero

1 Answer

Acceleration problem


Could be a clogged fuel filter, could also be a slight crack in the throttle body gasket. get a spray bottle with water in it, set it to mist, while the vehicle idles, spray around the base of the throttle body, if it bogs down replace the throttle body gasket. Just curious, was it doing it before you changed the plugs and wires? If not make sure you have the firing order correct.

Dec 24, 2013 | 1997 Nissan Pickup

1 Answer

When i accelerate my 1987 rx7 which is fuel injected starts to sputter and at times shuts off what could be the mal function?


Too many things it could be with a burn car. It is very hard to give a proper diagnostic evaluation without being able to put your hands on the vehicle. You probably still have some sensor or component issues. I recommend you download the FSM at http://foxed.ca/
That will give you the diagnostic procedure.

Dec 21, 2012 | Mazda RX-7 Cars & Trucks

1 Answer

Intermittent cut off. Will start but will not accelerate over 2K


this is the fuel pump. Sorry to kill the electrical theory but your description says fuel pump any way its read

Jun 16, 2010 | 1992 Dodge Dakota

1 Answer

Rough idle, sputtering, and backfiring.


try turning ur idle up its the pin on the throtle body just make sure u tuen the engine off and on again fter each adjustment to reset ur computer on ur engine

Apr 04, 2010 | 1994 Oldsmobile Eighty Eight

1 Answer

Sputters When Idling


clean throttle body intake ,,,run cleaner, thru injectors or carb, check all air hoses and tighten,check air filter,,,check idle air,,,or replace idle air,,,they go bad

Apr 16, 2009 | 1999 Pontiac Bonneville

1 Answer

Rough idle, Car shakes, sputters and misfires upon acceleration


It sounds like you may have a problem feeding the fuel to your engine, I had the same problem with my 89 RS. All the 1989 model's fuel systems were recalled. I think you may need a new fuel pump. The fuel pump is located inside the gas tank in the rear of the car right under the rear axle. The fuel pump itself isn't too expensive, but with other small parts such as the electrical harness upgrade and fuel filter and the labor you should be looking somewhere in the $500 range. I hope this helps.

Dec 23, 2008 | 1989 Chevrolet Camaro

Not finding what you are looking for?
1996 Mercury Villager Logo

Related Topics:

172 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

fordexpert

Level 3 Expert

5546 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...