Question about 1993 Mercury Villager

1 Answer

Its stalling out wont pick up speed just sputtering theres a hose run from the trasmission cant figure where it goes..or why the van is running rough.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mercury Master
  • 4,369 Answers

That is just a vent hose. it goes no where. mounts to clip on air intake hose.
sounds like dirty MAF sensor.

go here and join group.

http://groups.yahoo.com/group/villagerquest/

Posted on Nov 10, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why is My 1998 chevy astro van running so bad?power loss, sputters pops and stalls.runs better at hi rpms.and blinking service eng.lite on


Did you replace the distributor cap and rotor as well ? Has the coil been checked for signs of arcing, carbon tracking ?

Mar 09, 2015 | Chevrolet Silverado 1500 Cars & Trucks

1 Answer

1986 Nissan King Cab pick up. Runs good when giving gas, but cuts off at an idol. Have replaced Altenator.


Based on the information provided, it sounds like a bad TPS (Throttle Position Sensor). The TPS controls your idling speed under all conditions. When a TPS goes bad, you will usually notice the vehicle will idle when the engine is cold but once warm or with the AC on, it will sputter or stall.

Jul 18, 2011 | 1986 Nissan King Cab

3 Answers

I have a 2000 chevy astro and it runs but porly every time i step on the brake it wants to stall if i press on the breake hard it stalls and i have an awful vibration when mantaining a sdeedy speed and all...


i would check the spark plugs and distributor cap and rotor if equipped. If not, then check the spark plugs, and if worn, replace all six and fuel filter...and any other tune up parts....the stalling with the brakes applied could the be the hose running from the power brake booster to the intake manifold. If that hose is plugged, it too will cause the rough running and stalling...however your van may have a hydra boost and that hose will not exist...in that case, spark plugs might be so worn out that its in such dire need of a tune up, the engine cannot keep up and stalls out everytime you hit the brakes.....okay? good luck

Nov 16, 2009 | 2002 Chevrolet Astro

2 Answers

1990 chevy lumina apv - pickup coil -runs ok 15 mi & stalls


I'm assuming you have the distributor out? You will need to, as the shaft has a gear on the bottom end that has a roll pin. Make sure ALL is marked so that you re-assemble it the same way. You also need to mark the rotor position, and the base of the distributor so you can put it back where it was, or you will have to re-align and time everything!

Jul 10, 2009 | 1990 Chevrolet Lumina APV

1 Answer

Stalls when i put it into gear


Is the check engine light on? If so I would have a scanner put on it and have the codes read.. Otherwise it may be hard to determine. It may be the vacuum actuator on the tranny. It would be good idea to have fuel pressure checked and also any vacuum hoses.

Jul 06, 2009 | 2000 Plymouth Voyager

1 Answer

2000 Plymouth Grand Voyager SE


try a fuel additve called LUCAS fuel treatment along with two bottles of HEET.sounds like water and such ,contamination in fuel

Jul 06, 2009 | Chrysler Voyager Cars & Trucks

1 Answer

Engine Stalls When stopped and in Drive


Question, did you replace the throttle body, or clean the throttle plate, it will carbon up and block air needed for the idling speed to be correct. Also check for vacuum leaks, as the older vehicles didn't have good vacuum hoses. Good luck

Apr 18, 2009 | 1990 Chevrolet Astro Extended

1 Answer

When i start my 1997 Geo Metro, it often sputters


Try this
Here are the most common causes of surges, stalls at stops, low erratic idle speed, rough idle and engine hesitation, it is in most cases the idle speed control air-bypass valve and or throttle valve and upper intake, these area's get full of gunk and combustion residue over the miles and cause idle issues (stalls, low idle) like yours, Get a can of intake cleaner from any local parts store, not carb spray, intake cleaner, it is made by a company called CRC, remove the air intake hose to the engine, hold the idle high so the engine won't stall, then spray the can of cleaner into the intake while keeping the engine running, use at least 1/2 the can, shut down the engine and disconnect the battery for 5 minutes, then restart and complete a number of mixed driving cycles, town, freeway, stop and go etc., after a few days the problem will go away as the system will relearn to the clean intake.

Apr 03, 2009 | 1997 Geo Metro

2 Answers

Po 108


if there is not a vacuum leak it seems that the signal wire to the MAP is either open or shorted to 5 volt reference wire. if not either of those may be the PCM

Jan 09, 2009 | 2001 Dodge Ram 1500 Truck 2WD

1 Answer

1991 chevy lumina


if you go under 80km the lock up swicht in the trasmission wont ingage but if you go over the lockup engage when you slow down its suppose to disengage but our stay on and when our almost stop the car kick it like driving a standard car and not pressing the clucht when you stop the car stall a quick fix it doesnt fix it but our gonna be able to drive the car open the hood on the trasmission in the front you got a scare connector remove the connector the lock up swicht wont engage car wont stall take care good lock from montreal canada pierre

Jun 22, 2008 | 1991 Chevrolet Lumina

Not finding what you are looking for?
1993 Mercury Villager Logo

131 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

fordexpert

Level 3 Expert

5495 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...