Question about 2005 Ford Focus

4 Answers

Battery light came on then went off again,drove for 5 miles light came on again stopped car went into work came out car started ok bat light still on but also abs light and have now lost power steering checked belt it is ok any ideas??

Posted by on

4 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Your alternator belt may not be tighten enough. Turn off your engine, press the belt with your thumb, it must have à 0.5 " depression.

Posted on Nov 09, 2010

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,672 Answers

Better check ur charging system, ur alternator might be producing less CURRENT than a normal one! or Some loose connection that needs to be tighten up, battery terminal, fuse, alternator connection, etc... Try to get to ur nearest garage to check on that probs.
Tah!

Posted on Nov 09, 2010

Stop driving it

Take to a local repair shop

We can not guess at your issues,need the vehicle

Posted on Nov 09, 2010

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 7,772 Answers

It is likely that your alternator is failing. Recommend you have it tested. OR, if you have a voltmeter, test it yourself. Voltage should be at least 14 volts at the battery with the car running. Let me know if you have questions.

Posted on Nov 09, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine won't start after battery change.


When disconnecting your battery you need to hook up an alternative power supply . Vehicles with the electronics there have now a days . Something's need to be relearned an some of the modules may not wake back up at all , unless hooked up to a factory scan tool . Battery Disconnect or Replacement Problems

Dec 18, 2015 | 2006 Buick LaCrosse

1 Answer

2002 ford windstar first wouldnt start, jumped and started, drove 200 miles and turn


You need to have the factory security system scanned, it is most likely locking you out due to a fault.

Jul 07, 2017 | 2002 Ford Windstar Cargo

1 Answer

I changed the battery and the alternator and my lights went out and the car shut off


Check your fusible links leaving the positive battery cable,wires could be burnt or swollen.just check all wires coming from positive side of battery.Also check all fuses in fuse box.

Aug 19, 2012 | Ford Taurus Cars & Trucks

1 Answer

Car shuts off after starting


You can try this Autocom tool to check the problem. And you can also enquire the technician on line for technical help.

Jul 20, 2012 | 2008 Ford Fusion

1 Answer

I had a po102 code, i replaced the map & maf sensors, the engine light went off. I drove the car 25 miles and then the car turned off and a volt light came on the dash. I checked the serpentine belt it...


alternator is probly failing--have it load tested at a shop to confirm--just checkin it at a partsplace isnt sufficiente-------get battery inspected too

May 18, 2012 | 2000 Buick LeSabre

1 Answer

I have a 2004 Yukon denali and while driving, I got check gas cap alarm. 2 miles later check engine light is on. Checked gas cap, cleaned gasket and tightened. Drove for 2 days. Reset fault and drove 160...


Hello, have you tried to unhook the negative side of the battery for about 10 minutes and then go from there . It should reset the computer completely .

Sep 14, 2011 | 2003 GMC Yukon Denali

2 Answers

Oil light goes on...had a dry stick 4 1/2 qts put in. no oil on ground. after oil change light went on at 70 miles.. on 15 secs then off for 5 miles then on again 15 secs--- off 4 miles--off 3 miles- off 2...


if it's not going onto the ground, and it's not being burned, check the positive crankcase ventilation and the exhaust gas recirculation valves for oil seepage...also check your air filter, if its got oil on it replace the pcv valve.

Jun 19, 2009 | 2003 Volkswagen Jetta TDI

1 Answer

Cars lights go dim or won't work,radio stops working, air stops w


Have the charging system rechecked. It sound an AWFUL lot like an alternator not charging the battery to me.

Feb 17, 2009 | 2002 Kia Rio

1 Answer

Oil pressure light comes on after driving on highway for 10 miles


Sounds like your sending unit sensor - if it was your pump going out, your engine would be history by now. Rule of thumb, if your oil check light ever comes on, it's usually too late to remedy the problem. You have a major issue, but since you've obviousely drove it quite a bit since then and it still hasn't seized up, I'm guessing you're ok...for now. Since you took it to a shop and they said you're ok, I'm assuming they checked your level and visually checked for leaks and found nothing. Either, you've got somethijng partially blocking your pick-up tube for the pump which is in your oil pan, or a electrical issue with the sensor. I would start by having someone check the sensor out and go from there...good luck.

Dec 29, 2008 | 2002 Jeep Liberty

1 Answer

Van has been starting ok but yesterday battery was flat. Tried to bump start it but ended up getting a jump start. Drove it for approx 5 miles but had to put lights & heater on. Left it for a couple of...


5 miles is not enough to recharge battery. Have battery completely recharged or take it to major auto parts store where they can test battery,
What caused battery to go "flat"? Did you leave dome light on?

Dec 28, 2008 | 1999 GMC Sierra

Not finding what you are looking for?
2005 Ford Focus Logo

128 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5474 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...