Question about 2004 Ford F150

1 Answer

2004 Ford F150 5.4L 8cyl., Has been having problems accelerating over 30mph especially with OD on. OD off seems to run just OK. Has stalled a few times when coming to a stop after long driving...started right back up. Took it to the dealer and got codes P0104, P0121, P0221, P2104 and P2111. They wanted to replace the Throttle body and MAF sensor for $1000, changed them out myself for about $300, but the problem persists. I disconnected the battery also for a few minutes to try and reset everything. Truck is still running ****...any ideas?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,098 Answers

Hi

Does this model have an EGR Valve, if so try take that out and clean it with carb cleaner, it certainly sounds like thats the problem, the EGR is an Exhaust Gas Recycler Valve. the other alternative would be the air mass sensor alothough you would normally still get decent speed from it even when shot, but it would depend I guess on how shot it was.

Lastly make sure that there is no rips or leaks in the pipes sucking in to much air.

Hope this helps
Regards
Dan

Posted on Nov 08, 2010

  • 3 more comments 
  • sellyp_02 Nov 08, 2010

    Would the problems you mentioned give out codes? Or possibly result the codes I got?

  • sellyp_02 Nov 08, 2010

    Oh and the Mass Air Flow sensor..which I think you mentioned has been replaced...per the dealerships suggestion.

  • Dan Doherty
    Dan Doherty Nov 08, 2010

    Yes if it was the EGR valve most likely it would give a code, although on rare occasion it does not, as you say the speed is badly affected though it should be giving a code, also an air mass sensor fault would give a code no doubt.

    Air leaks though may not prodce a code but if it was an air leak or poor vacuum then it would show up on the code reader as an air mass sensor fault anyhow.

    Regards
    Dan

  • Dan Doherty
    Dan Doherty Nov 08, 2010

    Right well that would rule it oyt, are they a goo dealer? just to be sure they have changed it is all. but if its new then theres no way that would cause the fault. Look at the EGR it's the only plauseable thing I can suggest.

  • Dan Doherty
    Dan Doherty Nov 08, 2010

    EGR makes you loose a lot of power even when dirty, they are quite expensive not sure how much in Dollars but in GBP they are around £200 so worth trying to clean it, do you know the location of it or would you like me to send you over a picture?
    Regards
    Dan

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Hi have an ford focus 2.0 diesel auto 2012 and it shudders at 30mph when i accelerate seems like it is under powered so i have to give it more gas


unbelievable
they fitted a plastic accelerator pedal sensor to the diesel model

have that sensor part checked out as well

26371385-0kfckaigd130bklen40pkn45-4-0.jpg

26371385-0kfckaigd130bklen40pkn45-4-1.jpg

Nov 25, 2016 | Ford Cars & Trucks

1 Answer

My Falcon seems to take a while to start and I have to press the accelerator as well or it will stall, whats the deal?


My 2004 BA Falcon won't start. Apparently it's low - Fixya

www.fixya.com/cars/t12343045-2004_ba_falcon_start_apparently_s_low
Apr 8, 2012 - Apparently it's low on - Ford 2005 Falcon 4.0 question. ... Ba engine generally is strong, common fault is ecu, if hard starting when cold, pour hot water on computer and it ... If the headlights do not dim or go out, then the battery is likely ok..... Automatic 2004 BA Falcon stalls while driving ... Open Questions:.

My xr6 won't start. Comes up saying immobilized. - Fixya

www.fixya.com/.../t12430461-xr6_start_comes_up_saying_immobilized
Feb 6, 2012 - My xr6 won't start. ... Question about 2005 Ford Falcon 4.0 ... you will get airbag errors popping up for a few weeks then after a while it .... in a while it willstart and run for about 20 seconds, then it dies and won't start. ... Open Questions: ...You may NOT copy or distribute the content that appears on this site ...

Ford falcon sometimes won't start - Ford - Automotive - Whirlpool ...

forums.whirlpool.net.au > Automotive > Ford

WhirlpoolOct 26, 2010 - I have a EF Falcon that has an intermittent problem with starting. ... It might take a minute or 5 minutes or persistent retrying. ... Normally if you wiggle the T-Bar around it will then start. ... motor with a rebuilt unit, I had a remove starter on myalarm, and would use the remote start while using my jack-handle to ... Worst Car You Ever Owned
Jun 1, 2012
LPG conversion problems with stalling - Ford
Jan 16, 2012
More results from forums.whirlpool.net.au

2006 Ford Explorer Engine Stalls While Idling: 24 Complaints

www.carcomplaints.com/Ford/Explorer/.../engine_stalls_while_idling.sht...

Jan 27, 2016 | 2005 Ford Falcon 4.0

1 Answer

Automatic 2004 BA Falcon stalls while driving


IT MAY BE WORTH CHECKING YOUR IN LINE FUEL FILTERS AS I HAVE EXPERIENCED A SIMILAR PROBLEM WITH MY VAN ,ONCE I REPLACED THE FILTERS PROBLEM NEVER AROSE AGAIN FOR SOME REASON THESE ALWAYS SEEM TO BE OVERLOOKED BY THE SERVICE TECHNICIANS

Jun 06, 2013 | Ford Falcon Cars & Trucks

1 Answer

2004 F150 auto trans, no OD. seems like it is in neutral and the rpm goes crazy when it needs to shift


check fluid levels add if low..if not replace filter in transmission..od should return.. make sure detent(downshift )cable is not hung up either..connected to the accelerator linkages..good luck

Jan 17, 2013 | 2004 Ford F150

1 Answer

Check engine light is on and engine appears to run out of fuel when driving for a few seconds and then runs ok. I had it checked and computer says low fuel pressure. Fuel filter was changed recently.


No that is not a low fuel pressure what you have is what million of other 2002 to 2004 explorer tract has the code is not low fuel pressure but a fuel pressure regulator located at the right top engine when this give false reading you will stall out at 1500 rpm especially when taking a turn it is a fuel pressure regulator code that has failed

Aug 21, 2011 | 2004 Ford Explorer Sport Trac

1 Answer

1998 Ford Contour sedan shifts with small 'bump' only when slowing down and at 30mph. Only last about 1 or 2 seconds. No problems at all when accelerating . Transmission shop tested the computer...


i had a ford escort with lots of miles on it that did the same thing. trans was ok also. if the shop says its ok, then run it[ my escort is still on the road]

Jul 09, 2011 | Ford Contour Cars & Trucks

1 Answer

Acceleration Issues - Fuel Injection Problem?


A pressure test needs to be done to determine if the right amount of fuel is being delievered. Another thing that can happen is the TPS can be out of range, or even bad.

Mar 04, 2010 | 1996 Saturn SL

1 Answer

2002 Ford Ranger transmission slipping?


The longer you drive with that condition, the more damage you will cause. Park it until you can repair it.

Think of it as how long would you think it is okay to run your engine without oil? Zero.

Doc

Sep 14, 2009 | 2002 Ford Ranger Regular Cab

1 Answer

Hesitation when accelerating, mostly between 20-30mph,


the funny thing is , we have had this problem also , the check engine lite came on , said downstream 02 sensor bad. replaced it. still had hesitation. change plugs and wires. still had hesitation, replaced fuel pump/fuel filter/fuel screen assembly, and the S.O.B. still has this problem. im running out of ideas except that i have run into other posts that say the crank position sensor , or the computer itself could be the culprit... all my switches and and other components seem to be working fine, though it makes me wonder also if tha cam sensor could also be going bad....

Apr 05, 2009 | 1998 Jeep Grand Cherokee

1 Answer

Ford fiesta 2002 1.4 diesel lx


sounds more like the ECU

Jul 09, 2008 | 1999 Ford Escort

Not finding what you are looking for?
2004 Ford F150 Logo

536 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5470 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...