Question about Ford Expedition

1 Answer

My battery is dead on my 2003 expedition. I am jump starting with my chrysler 300 and the radio somes on and the locks work, howevr the expedition won't start and the alarm keeps coming on. Please help.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,016 Answers

Hi,
Firstly is the battery going flat? When you jump start it is the radio coming on and is the alarm going off?
If the battery is going flat then you may have a faulty battery so get this checked first. If the battery is ok then get the charging system checked. Let me know about the other 2 things first then we can more in-depth into this.
Thanks
Jason

Posted on Nov 07, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Battery problems. First the radio stops working, then a few days later the car will not start.


You may have loose or corroded terminals at the battery, that will affect the alternator's ability to charge, affect all electrical components including the radio. So you end up with radio and starting problems.

Mar 03, 2015 | 2001 Chrysler Concorde

1 Answer

Hello, I have a 2005 Chrysler 300 and it wont start. I changed the battery in my key and it wont start. Initially it would start and shut right off. Now it wont do anything. I had to push it across the...


it started for two seconds and shut off because the immobilizer is active. those fobs are notorious for having bad contacts to their batteries, if you look closely you will probably find that one of the contacts for the battery has come loose. unlock the car with the key itself and it will probably run because there is a switch on the driver's door lock which disables the immobilizer. your lights are flashing because your battery is dead or there is a poor connection to the battery somewhere. get a jump start.

Apr 15, 2013 | 2005 Chrysler 300

1 Answer

2003 EXPEDITION CHARGING SYSTEM OK BUT STILL WONT STAY CHARGED


Go to AUTOZONE,they will test you electrical system for free,takes only a few minutes.

Nov 25, 2012 | Ford Expedition Cars & Trucks

1 Answer

2006 Chrysler 300 Touring will not start


sounds like a dead battery & bad alternator

Jun 28, 2012 | 2006 Chrysler 300

1 Answer

2005 Chrysler 300 C. Battery went completley dead. Jump it . It holds a charge. Now check engine light on. Runs rough multiple missfires. Replaced battery. Ran good for 10 miles. Check engine on again....


Fill up your gas tank and ad a bottle of Lucas gas treatment/lube to the tank, be sure it's the treatment in a little clear bottle and not injector cleaner. After you've added the gas and treatment drive the car, with the head, driving lights, radio, heater, etc. all turned off. It may take ten miles or more but the check engine should go off and car will run normal. NOTE: Never jump start your car or use it to jump someone else's without referring to your owners Manuel.

Oct 15, 2011 | 2007 Chrysler 300c AWD Sedan New Cars

2 Answers

My battery went dead on my expedition. When i


I too ran into this problem when battery was removed and re-installed, the radio would power on but no audio. Called Ford dealership and they said they would have to flash the computer at a fee of $95.00 for it to work again. Fortunately my teen aged son who has been at school learning about today's cars said that in most cases removing the negative battery lead for 10 mins and reconnecting will also reset computer. Sure enough it worked and saved me some big coin.

Dec 25, 2009 | 2006 Ford Expedition

1 Answer

2000 Jetta Radio is dead after a dead battery jump start


Some German cars have anti-theft device inside to make it useless to steal...check at the dealership to see if jumping the battery will activate this(the car thinks its being stolen) .

Apr 29, 2009 | 2000 Volkswagen Jetta TDI

1 Answer

2003 expedition xlt


when you have a dead battery and jump start you half to drive the vehicle for 10 to20 miles to allow the altinator to recharge the battery. if this dont work then i would have the altinator checked to see if it is charging ,your local auto parts store will do this for free

Jul 31, 2008 | 2001 Ford Expedition

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

47 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5467 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...