Question about 2006 Chevrolet Impala

1 Answer

2006 CHEVY IMPALA TEMPERATURE GAUGE NEEDLE IS READING A QUARTER PAST HALF, AND THEN GOES BACK TO HALF. HEATER BLOWS COLD AIR UNTIL CAR REACHES 50 MPH OR HIGHER. WHAT COULD IT BE? PLEASE HELP!!!

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 116 Answers

Heater core could be plugged up. flush cooling system.

Posted on Nov 06, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

97 chrysler concorde lxi wont blow hot air


before doing anything, make sure your coolant level is up to the mark on the reservoir bottle, and that the car actually reaches correct operating temperature. on this car, temperature is easy to check because there's a gauge on the dash. after warming up, the needle should be about half way up. if it isn't, replace the thermostat.

if none of those things are wrong, then there's a malfunction in one of the blend doors in the hvac box. gaining access to that is extremely involved and best left to a very experienced mechanic.

Jan 21, 2014 | 1997 Chrysler Concorde

2 Answers

Heat gauge goes way up,then by reeving motor it will go down.blows cold air


Check out related help links with solutions to troubleshoot the problem:---
Click the link below:---
2004 Toyota Tundra: Oil Gauge and Temp Gauge Not Working?


http://howtobyme.blogspot.in/2012/05/2004-toyota-tundra-oil-gauge-and-temp.html

---------
Toyota 4Runner: Temperature Gauge Sensor http://technoanswers.blogspot.in/2012/04/toyota-4runner-temperature-gauge-sensor.html

-----------
Temperature gauge sits over half way mark? http://schematicsdiagram.blogspot.in/2012/04/temperature-gauge-sits-over-half-way.html
----------
Heater blows intermittently and temp gauge goes erratic?


http://technoanswers.blogspot.com/2012/01/heater-blows-intermittently-and-temp.html
------------- No heat on Oldsmobile Silhouette? http://technoanswers.blogspot.in/2012/02/no-heat-on-oldsmobile-silhouette.html
-------------
Temperature gauge does not move and no heat when heater is ON? http://technoanswers.blogspot.com/2012/01/temperature-gauge-does-not-move-and-no.html
----------
Temperature gauge keeps fluctuating up and down close to red? http://technoanswers.blogspot.com/2012/01/temperature-gauge-keeps-fluctuating-up.html
----------- Temperature gauge on the dash quit working on Pontiac Grand Prix? http://technoanswers.blogspot.com/2012/01/temperature-gauge-on-dash-quit-working.html
-----------
Dodge neon gauges not working? http://technoanswers.blogspot.in/2012/02/dodge-neon-gauges-not-working.html

---------
Heater blows cold? http://schematicsdiagram.blogspot.in/2012/02/heater-blows-cold.html

----------
Heat blows cold on drivers side and hot on passenger side? http://schematicsdiagram.blogspot.com/2011/12/heat-blows-cold-on-drivers-side-and-hot.html

-----------
1992 Lexus LS400: Engine overheats, Antifreeze out of reservoir and heater Blows Cold Air? http://whatisbyme.blogspot.in/2012/05/1992-lexus-ls400-engine-overheats.html

-----------
These details will help.
Thanks.

Nov 22, 2012 | 1997 Ford Taurus

2 Answers

My chevy impala 2006 is overheating. I checked the coolant reservoir and it was empty. I added Dex-Cool coolant to the reservoir, cranked the car but gauge still goes past the normal temperature. How...


Sounds like your thermostat is not opening. When you replace it (engine cold) make sure you obtain the correct temperature setting (170-190 for example) for you specific vehicle.

Aug 18, 2011 | 2006 Chevrolet Impala

1 Answer

Heater donot get hot whil running


It could be a plugged heater core or heater control problem. I assume the blower is working, but the air is cold. The first thing to check is the coolant level, make sure there is coolant in the resivoir. Next see if the temerature gauge reaches the normal operating temperature range. If the gauge reads cold most of the time, it would tell you that the thermsotat is faulty and not allowing the engine to reach full operating temperature. If your car doesn't have a temp gauge, the blue cold engine light might stay on for an extended period of time. The thermostat is supposed to not allow coolant flow in the radiator until the engine reaches operating temperature. If you drive the car for a couple of minutes, from cold start, the radiator or upper hose should be cool until the engine reaches operating temp.

Mar 15, 2011 | 2003 Volkswagen Beetle TDI

3 Answers

I have a 2003 chevy impala. just changed the thermastat because the temperature was fluxuating. Since changing the thermastat the temperature gage constantly read in the red, however the coolant level...


You probably need to bleed the cooling system properly.

Open the cooling system bleeder screws.

Slowly fill the cooling system with a 50/50 coolant mixture until coolant runs freely out of bleeder screws.
Close the cooling system bleeder screws
Install the coolant pressure cap
Start the engine.
Run the engine at 2,000 - 2,500 RPM until the engine reaches normal operating temperature. (midway on gauge)
Allow the engine to idle for 3 minutes.
Shut the engine off.
Allow the engine to completely cool.
Top off the coolant as necessary.
Run engine again at 2000 - 2500 RPM until the engine reaches normal operating temperature.
Allow engine to idle until cooling fans come on. It should come on with the gauge about 3/4 of the way to red. - if it gets to where is touches the red, shut down immediately.
When the fan comes on, put your hand behind the fan and observe the temperature of the air coming from the fan. It should feel hot. If it is blowing cold air, the coolant is not circulating through the radiator like it should. This could be caused by lots of things including an improper/defective thermostat, corroded water pump impeller, or a blown head gasket.

Dec 02, 2010 | 2003 Chevrolet Impala

1 Answer

2006 chevy silverado 2500hd truck heats up to operating temp while in parking lot blower works well but truck will not blow any hot air until truck is driving at at least 15 to 20 mph. fuses good think...


If I understand you correctly, your temp gauge shows correct operating temperature, your blower fan blows air that you can feel with your hand from the right floor or dash outlet, but that air doesn't feel warm until you are moving?

If so, several possibilities come to mind. One is that your coolant level is low. Even though your temp gauge reads in the right range, the coolant level could be low enough that it doesn't reach the heater core until there is enough engine RPM to create more pressure from the water pump and force what coolant is there toward the heater core. Another possibility is that your heater controls are not able to do their job. A stuck flapper in the duct or a malfunction with the temperature control system could be causing the problem, and at 15-20 MPH there is enough air coming through the outside air vents to provide some heat.

I'd check the coolant level first, though. The other possibilities are more far-fetched.

Nov 26, 2010 | 2006 Chevrolet Silverado

2 Answers

2006 impala heater motor blows like normal but some mornings it blows cold if we shut it off and turn it on a couple of times it will blow hot and work fine. the heat gauge is at half way when the engine...


this problem is caused by a sticking air temperature control blend door actuator or blend door, this door moves back and forth to get the desired temp, the actuator is electronic and prone to this type of problem, suggest u replace it.

Sep 23, 2010 | 2006 Chevrolet Impala

1 Answer

2004 Chevy Tahoe. Heater working only at higher speeds.


you have air trapped in the cooling system. A good indication is that one or both of your heater hoses going into the heater core are cold when they should be hot.
Park facing uphill, raise front of vehicle so radiator cap is higher than top of engine. (You want bubble to get to radiator and out the cap.)
Leave cap on but loose, so bubble can purge.
Turn heater on.
Fill radiator and reservoir with 50/50 mix of antifreeze.
Start engine and run at about 1500 roms until the engine warms up and thermostat opens.
You will know themostat opens when top radiator hose is hot indicating coolant is flowing.
Shut off engine.
Fill radiator and reservoir. Install cap.

please Rate as fixya if this works. good luck

Mar 04, 2009 | 1997 Chevrolet Tahoe

Not finding what you are looking for?
2006 Chevrolet Impala Logo

507 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76673 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8531 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...