Question about 2002 Ford E-Series

Open Question

I have a Ford E350 econoline 15 passenger and the brake light do not work. None of them. All appear to have gone out at the same time. Auto parts p lace could not help - where is the fuse located for the brakes? Thanks

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: Passenger brake (only) locks up when cold or wet

Same here guys damn brakes stick can only go in reverse. However i do find storing the car in a warm garagef yo can get there) usally will fix the problem after a few kicks to the bck ties whne the cars warmed up

Posted on Mar 26, 2009

Ad
  • 15 Answers

SOURCE: No turn signals, hazards or brake lights

replace the turn signal switch in the steering column

Posted on May 16, 2009

  • 78 Answers

SOURCE: Passenger side front brake caliper is not releasing.

well your brake porportion valve is not working right oh well good luck

Posted on Jun 03, 2009

  • 65 Answers

SOURCE: 1989 Ford Econoline 350 fuse box location?

here is manual from ford

https://www.fleet.ford.com/maintenance/owners_manuals/default.asp

Posted on Jul 07, 2009

jigsaw_9077
  • 308 Answers

SOURCE: I've checked all the components, relay, pedal

The mechanic needs to check again the connection of the brake light to the fuse and the wires . then try checking terminal sockets of the brake light that can also be the problem.if still not working try to look at the sensor .

Posted on Aug 11, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I need a heater/A/C temperature control cable for a 1987 Forde Econoline E-350. Where can I find it?


Hello! Google; Temperature control cable 1987 ford E350...Click on the second choice; Ford E350 Econoline Car Parts Used...You can identify it by looking at the bottom line...The service advisor.com/part...
It searches the country for your part....Guru........Saailer



I’m happy to help further over the phone at https://www.6ya.com/expert/david_6df67de3b14de867

Aug 10, 2010 | 1987 Ford Econoline

1 Answer

1994 Ford E350 transmission seems like it slips at 45-55 MPH.


If you went 1k miles since that same issue occurred I would look at the transmission. A faulty torque converter, clogged fuel filter, or a clogged CAT can cause a delay in the shifting but it would happen right away not 1k miles later.

May 05, 2010 | 1994 Ford Econoline

1 Answer

Van needs new fuel pump. Is it in the fuel tank? What pump part# do I need? Ford E350 15 passenger van


It is in the tank,there are too many fuel pumps on ford to know a part number,napa can give you the right one for the van with your v i n number.

Apr 11, 2010 | 1991 Ford Econoline

1 Answer

Front brake squeal from ford e350, has only 31k miles, just installed new factory pads,, squeal came back after only 3500 miles,, very loud,, what can i do?


i use a spray on adhesive that i spray on the back of the pads before i install them. called "brake quiet" it's blue in color. auto parts stores sell it.

Oct 22, 2009 | 1992 Ford Econoline

2 Answers

'93 Ford Econoline 150 E-brake pedal teeth gone!


Try http://fordpartscenter.net , I found the parking brake control for my 95 E350 on this site, they also had the cables.

Jul 15, 2009 | 2000 Ford Econoline

1 Answer

Engine wont run when reved up


sound like you have a bad senser. it would be a good i dear to have it scanded. i would check the fuel presher. you may have got a bad fuel pump

Apr 07, 2009 | 2002 Ford E350

1 Answer

2005 E350 XLT Rear heat not working


check the big fuses under the hood next to the bat

Jan 24, 2009 | 1990 Ford Econoline

Not finding what you are looking for?
2002 Ford E-Series Logo

Related Topics:

91 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

80417 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

fordexpert

Level 3 Expert

5687 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...