Question about 1987 Chevrolet Corvette

1 Answer

1987 corvette starts and runs smooth. 5 to 10 seconds later it shuts down like the key was turned off. Alt. tested and was bad. Replaced alt. Battery tested. Failed test and replaced it. Still quits after running well for 5 to 10 sec. Thanks for your help,

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 3,489 Answers

This sounds like you may have an ignition module failing. Run it and when it dies, have some one crank it while you check for spark. If no spark is found, replace the ignition module. This piece runs about $75. Not too bad relatively. Let me know what you find.

Posted on Nov 02, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

New battery new alternator battery still wont charge ??


91 , (is the charge lamp glowing key on, (shoe drops)?????
there are many ways to make it stop doing 13.3v to 15vdc running,
lots. ill list them all..
the 2 stated. in blue above. and.
1: bad dash lamp this lamp boot staps the field current or the alternator is born dead. so is it dead key on, , yes, BINGO.

2: bad alt ground, or starter top bolt , ground to battery bad or loose.
3: bad wires to the rear of alt. all 3.
4: bad battery cables. (or just corroded ends or conn. wrong)!!!
5: alt belt loose or missing.
6: engine hot RPM not 750 to 850 Rpm if 500 BINGO.
and more.
http://www.fixkick.com/Charging/charging.html

here is the drawing.
IS the sense wire is dead, not 12vdc.???

http://www.fixkick.com/Charging/charge89.jpg


the reg inside can shut the ALT down for.
over voltage
over current.
or if it THINKS(sic) that the batter internal resistances is too high. for ANY REASON what so ever. it will shut down
these protections prevents the ALt. from blowing expensive electronics (all of it) to kingdom come. $$$$$

its a feature.

Jul 08, 2014 | 1991 Suzuki Sidekick

2 Answers

Battery warning light turn on what could be the problem


Clean battery terminals first. If still no better, get parts store to test alternator.

Jul 06, 2014 | 2012 Jeep Grand Cherokee Laredo 4dr SUV...

1 Answer

Battery light alternator


The Charge lamp comes on with the Alternator fails to keep battery charge going. (lots of way to fail, and ALT Is 100% good) it's a system. each part of it must be good, end to end.
so...
i put my voltmeter across battery, i start car, i see 13.3 to 15vdc, alt is good.
no? , i see now, 12.2v. ALt is dead, (i didnt say bad) and battery is sightly discharged, 12.6v is charged. (key off, rested voltage)
This 12v tells me the ALT is shut down. only why is the question.

how can any charge system fail,
bad battery tops the list here, they LOVE to fail.
1: belt slips.
2: belt missing
3: bad alt.
4: bad wires to ALT . (corrosion on any wire or lug)
5: fuses blown , any listed below.:
your alt is not an ECU controlled, alt ,its 100% self contained

did you ever remove the ALT and blow the 100 amp fuseable link
the first step of any alt pul, is the pull the NEG, battery lug or BOOM.

im logged in to alldata.com so can you.

and what do i see.
a 5 wire ALT. one is the frame ground, so it must not be rusty or..... it fails. frame to engine block. no rust here.

wire L , yellow.goes to dash LEDs (alt failure idiot lamps) (this works)
wire. S white goes to ALT 5a fuse, is it blown?
wire :B B/G color, goes to the 100 amp link fuse. (blown>?)
wire IG Red-white, goes to a fuse marked 10A gauge.

i think the IG wire is the voltage sense wire.
no sense, no charge. I think the whole I/P dash cluster goes dead when this fuse blows.

The S wire is the boot strap voltage sense, it wakes up the regulator .
if open , the reg stays asleep, as does ALT.
Alternators can not self start, the regulator has boot strap device
that cures that. called self excitation. so this wire is critical.
All wires except the L wire is critical. in this case.

the B wire is the big wire, it charges the battery . 50amps or more..

any of the 5 paths open , kills the ALT dead.
The REG inside the ALT can also shut it down.
eg: battery bad, with huge cell resistances. total.
eg: overvoltge for any reasons. including attempts top run car with no battery, (dont ask)
eg: over current (battery cells 1 to 6 shorted) or 25 KC lamps added.
eg: over temperature shut down.

that is about it.







Dec 31, 2013 | 2003 Toyota Matrix

2 Answers

2000 vw jetta alternator won't charge


the alternator gets power on big wire battery voltage the wire runs to starter, fuse box .alternator fuse goes to automatic shut down relay to relay control in ecm/pcm the field wire comes from ecm /pcm to alt.other field goes back to automatic shut down relay back to charge battery . if not charging at alt. try new alt. and retest.

Aug 05, 2012 | Cars & Trucks

1 Answer

95 Geo Prism head lights, dash board lights go dim, slows in power, check engine light comes on.


does the alt light glow, keyon (aka. chargelamp)? if not BAD !
fix that FIRST !
This is really simple in most cases.
it's a system, called a charge system.
it has 3 /4 parts.
1: Alternator must spin about 2 times crank speed.
if the engine RPM is 400 , the Alternator will give UP.
so first engine RPM 800 then i strobe the alt pulley, oops belt slips, mine runs at 1.8 ratio or 1400 rpm at alt pulley.
for a DIY is the belt tight?
2: is engine RPM at 800? no , fix that first.
3: RPM good.
The system now is ALT wires and battery. 3 things.
if the ALT is good and the battery is good (tested)
then it must be what. the wires.
The alt can put out 50+ amps..
there are at least 4 wires on most alts and any can fail.
1: big red. (huge charge wire,, or the inline fuse blown.
2: ground, old cars , and for sure in the SALT belt the gound fails
do to RUST, or better word, Corrosion and both.
alum and steel (iron) both corroded, add salt and its worses
in 2 ways corrosion and electrolysis. (google that)
so the ALT case must be grounded to the engine. 100% perfect
then engine ground stap to battery minus. if not the ALT will FAIL.
now we land on 2 more wires, most cars.
that rear connector.
1 is ignition sense wire, if open alt goes nuts.
2: is the idiot lamp. if lamp is bad, (dead) the alt can shut down.
this lamp creates boot up , initial excitation current, so the ALT can start up. most ALTS have no residual magetism to start up.
so it needs a bias circuit, to do that.
and guess what, each brand of ALT uses different parts here.
EVEN REBUILTS, so best practice, is to assume the lamp
must be good, and fix that first (early cars, ) new cars the ECU
runs the alt and is 10x smarter, not this car. at all.

no lie , testing the alt, in car is hard.
many times the ALt just shuts down. (faults)
and with zero current flow, you can not find the voltage drop
that precipitate that fall out/
there is a method but is risky , on car, called "full fielding"
it can blow up electronics,. so that is my warning.
does this help?

one other crazy failure
some cars have DRL , in uSA , some, in canada , many.
i fix them all. but the DRL in many cars, (this year)
connects the alternator, and DRL burns up and kills the ALT.
the reason DRL uses the charge lamp is easy
it shuts down DRL any time the Charge lamp is dead.
allowing more battery volteage (& current) to start, HEADLAMPS off.
same with cruise control some drop out , if change lamp is on.
to understand all this , its all in the manual. (parts effected)
at alldata dot com.

Aug 02, 2012 | 1995 Geo Prizm

1 Answer

1987 Jeep wrangler fires up, but stalls after 1 or 2 seconds


when you take alternator out of play. the vehicle runs. i would be replacing the alt. these units are complex containing modules, regulators that can give you erratic problems, but i think u answered your own question alternator


hope2help shack

ps. good mechanic wont leave you stranded

Apr 17, 2009 | 1987 Jeep Wrangler

1 Answer

87 jeep cherokee tach climbs when ignition is turnd off. and flashers are slow


You say the alt. is dead. Why not replace it? Is the battery light on when you run the car?
If the alt. is bad, you are running all that equipment just on battery power.

Oct 30, 2008 | 1987 Jeep Cherokee

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

242 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

81400 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...