Question about Chevrolet K2500

2 Answers

1994 2500 chevy 4wd 350 have replaced all but ecm we set timing runs great put in gear to drive and it jumps out of time

Posted by on

  • Patricia Mahoney
    Patricia Mahoney Nov 02, 2010

    timing chain already replaced

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 3,489 Answers

Are you basing this on the timing moving with a timing light? The timing is going to move to adjust for load and knock. If it is running bad or "pinging" then a knock sensor is in order. The knock sensor will ****** timing to avoid over advancement and the inevidable "ping" or "knock" when accelerating. If you could kindly send me more info on this, I would be happy to assist. Email me at iambanshee74@yahoo.com as I am going to be away fromthe computer but can answer via blackberry.

Posted on Nov 02, 2010

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 2,299 Answers

It sounds like the timing chain is jumping time.

Posted on Nov 02, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 93 chevy 350 has issues. I'm Stumped???????????


back firing through the carby is an indication of valve timing, bad valves, ignition timing or crossed HT leads. Check the firing order

Mar 09, 2015 | Chevrolet Cars & Trucks

2 Answers

I have a 1993 Ford Explorer that goes into high idle when I put in gear. It does this when the engine is hot or cold.


On some cars there's a speed sensor on the clutch or transmission. That might cause an idle problem.

Mar 24, 2014 | 1993 Ford Explorer Limited

2 Answers

1995 Chevy 350. I'm going make this as elaborate


Could also be a problem with the throttle position sensor

Oct 28, 2013 | Chevrolet Silverado 1500 Cars & Trucks

1 Answer

95 GMC K1500 350... replaced distributor...timed it at 0 with computer unplugged... plugged it back in and timing changed by few degrees, engine surges and runs poorly. Checked plugwire route for...


ok ran great before changes. right. you say unpluged computor to set timing.. yes.. do you mean the plug on the firewall passenger side that looks like a fuse holder kindof..?? (set timing connector ) (tan /blk wire)
did it run good during timing proceedure??? wont be MAP that is engine vacume has nothing to do with what you have replaced.
proceedure is to set timing . shut off engine , plug in.. then restart.
yes timing moves as per ECM specs. check that timing did no get out one tooth when you replaced distributor. retime . restart

Feb 01, 2012 | 1993 GMC Sierra K1500

1 Answer

HAVE AN 89 CHEVY 4WD w/ 350 5.7> l. will not go


Has the fuel filter been replaced with the fuel pump or it could be a restriction in the exhaust. In order to check that properly you would need a back pressure gauge and measure back pressure or just disconnect exhaust from the manifolds and drive it around and see if all the power is back.
(IT'S GOING TO BE LOUD) Let me know.

Mar 01, 2011 | 1989 Chevrolet K1500

1 Answer

1987 Chev Suburban 350 4wd 1/2 ton. Blew head gaskets at about 340,000 miles on the engine. Removed, repaired and reinstalled top end. Fired up on first try. Runs smoother than ever before. Never had...


You said you replaced "it" but did you replace both? Something else to check is you temp sensor, (not for gauge). Should be around the thermostat housing with a 2 wire plug. Bypass it with a jumper. Hope this helps.

Oct 17, 2010 | Chevrolet Suburban 1500 Cars & Trucks

1 Answer

Vortec 4wd 2dr auto trans stalls while drive


you might want to look at your O2 sensors, they can cause the motor to run lean or rich. also you might have an electrical issue that is tripping your ECM. your electronic control module might be faulty. best solution is to get a trouble code reader and find out what your on board computer has stored. from there you can repair and clear the codes.

May 05, 2010 | 2002 Chevrolet Blazer

2 Answers

The car jumps when the wheels are turned left or right


you need to have the front axles checked or replaced,they are not freely turning

Dec 28, 2009 | 1998 Jeep Grand Cherokee

1 Answer

Popping thru exaust while running down road


Your timing might be too far advanced? Try retarding it slightly. Other than that you might look at the exhaust valves. One could be bent or adjusted too tight.

Apr 03, 2009 | 1983 Chevrolet K1500

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

28 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

81400 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22359 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...