Question about 1996 Volvo 850

3 Answers

SPEEDOMETER ... THE CAR STARTS AND RUNS WELL UNTIL I STOP OR IF I PUSH THE BRAKE MORE THAN 2 TIMES THE SPEEDOMETER GOES TO "CERO". BUT ALWAYS IS WHEN I PUSH THE BRAKE FOR EXAMPLE WHEN I'M IN THE STOP LIGHT WAITING FOR THE GREEN LIGHT, AND THE ENGINE IS NOT THE SAME AFTER THAT, I HAVE TO TURN OFF THE ENGINE AND START AGAIN AND IT WORKS OK. WHAT COULD BE THE PROBLEM?

Posted by on

3 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    New Friend:

    An expert that has 1 follower.

  • Expert
  • 109 Answers

SOUNDS LIKE A LOOSE CONNECTION TO TAKE CLUSTER OUT REMOVE MOST VENTS AND UNSCREW TORX SCREWS UNDER VENTS AND UNDER DASH AND LEFT SIDE BY DOOR AND ONE SCREW UNDER CLIMATE CONTROL UNIT 6 (6 VENTS) AND THERE SHOULD BE 2 CLIPS HOLDING CLUSTER IN PLACE UNPLUG UNIT 2 PLUGS IF A TURBO THE HOSE AND THE CLOCK AND always disconnect neg battery FIRST and LAST thing to hook up

Posted on Apr 12, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have the similar problem. My car's failure signal (e.g. brake failure signal) comes on occasionally. When I step on brake, the speedometer and tachometer needle goes to zero and audio turn off by itself, and then they return to normal state. It repeats. I think that it happens because of wiring connection failure or short circuit.

Posted on Jul 09, 2008

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

I have the same problem. I think it is a loose connection rather than anything else but I do not know how to open the back of the speedo. Can anybody help?

Posted on Jul 06, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Automatic Nissan wheels keep on locking


What kind of Nissan? Model/year?

Apr 11, 2015 | Nissan Cars & Trucks

1 Answer

When i first crank the car it idles at like three or so then goes to zero and cuts of it does this a few times especially if i push the brake, i have learned to rev engine lightly and press brake and put...


Might be a leak on your brake booster (this will most probable give you a hard brake pedal or a "sucking sound " when applying brakes) also check the vacumm pipe from the engine to the brake booster. It might have a leak, so when you press the brakes it influences the air mixture.

Dec 14, 2012 | 2000 Nissan Maxima

1 Answer

I will be in stop and go traffic and I feel the brake peddle goes high. Then car will not go very fast, gets stuck at about 15 mph. Feels like car wants to stop. I push the gas peddle all the way down but...


Sounds like you may need the flex lines replaced,it seems like the brake fluid is getting to them but when you let off the brake they still have pressure on them,i could be wrong ,but it is a place to start,good luck.

May 18, 2010 | 2006 Chevrolet Malibu

1 Answer

The Oil Gauge of my 2004 Avalanche drops to cero while driving, it doesn't stop the engine or any other system, no noise, no nothing, it just (the messurement) goes crazy until droping to cero. When I stop...


If the tech used a oil pressure gauge on your engine to see if the pressure was good he should of checked the oil pressure switch next. If that proved to be good the gage in the dash is bad. How hard is that to do at any dealership that sells these vehicles. They are require to have all the equipment to service these vehicles to stay in business coordinated by the francised rules. Call the corporate office and file a complaint towards that dealer and demand a refund

Jan 22, 2010 | 2004 Chevrolet Avalanche

1 Answer

I have the same problem. While driving, all of a


its all the TCS they fail all the time they run 1200,00 new or 450.00 used..
Elite foreign auto used saabs parts

Sep 19, 2009 | 2000 Saab 9-3 Viggen

1 Answer

Warning lights


have obd  scanner run on vehicle 

Sep 12, 2009 | 2000 Saab 9-3 Viggen

1 Answer

Saab '02 9-3 "electrical"problem


Most likely it is the ABS module is going bad and needs to be replaced or rebuilt at www.bba-reman.com, hope this helps.

Sep 02, 2009 | 2000 Saab 9-3 Viggen

1 Answer

Car goes berzerk


did it do this befor the other parts were replaced. sounds like some wires touching or grounding out.

Jul 10, 2009 | 2000 Cadillac Seville

1 Answer

Speedometer


does it jumps to 20 and tyen go back to cero? or keeps at 20?

May 24, 2008 | 1998 Ford Contour

Not finding what you are looking for?
1996 Volvo 850 Logo

296 people viewed this question

Ask a Question

Usually answered in minutes!

Top Volvo Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Mark Jones

Level 2 Expert

76 Answers

Are you a Volvo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...