Question about 1987 Chevrolet Celebrity

2 Answers

Help.. im having issues with my car...it stalls at slow speeds and has a bucking issue before the service engine light goes on...most times car runs great except this issue...car has a 2.8...i tapped on the tps and disconnected harnes and seems to run better but now idile is high ...switch bad?replace?or could it be something else??any help to offer??thnks

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 625 Answers

If this is happening only when engine is warm i recomend you to hom the injector number 5 or check resistance on all the injector specially number 5 the closes to the egr because that one gets too much heat from egr, if off for 2 or more homs replace all the injectors, i used to own a celebrity and that's is very coming problem on htis type of engine

Posted on Jun 09, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 702 Answers

Sounds like the TPS isn't operating properly.

Posted on Jun 09, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why it stalls at stops and low speeds


accord stalling on every stop. (1/2) - EricTheCarGuy ...

www.ericthecarguy.com/.../8.../46884-accord-stalling-on-every-stop
The car runs good but stalls every time i come to a stop. ... a stop then it diesagain.only on the stops does the idle drop very low to the point of stalling.what ... only when I start slowing down and come to a complete stop RPM's go down and the cardies. ... The popular Honda Civic and Accord vehicles share many powertrain ...

1998 Honda Accord loses rpm/ stalls coming to a stop ...

honda-tech.com/honda-accord.../1998-honda-accord-loses-rpm-stalls-co...
Jan 10, 2013 - I just bought a 1998 4 cyl 2.3 L Honda Accord two days ago. ... 1998Honda Accord loses rpm/ stalls coming to a stop. .... Is clockwise high idle or low idle? all in all i probable rotated counterclockwide 1.5 or 2 turns. maybe this ...

1999 Accord, 130k+, stalls when slowing to a stop - Honda Accord ...

www.hondaaccordforum.com > ... > General > General Tech Help
Mar 10, 2010 - My fiancee's '99 Accord EX Coupe 4-cylinder automatic, with 130,000+ miles, has recently (in .... No low RPM & feeling like it's GOING TO stall.

99 Honda Accord - Strange Stalling Issues! HELP!

https://www.2carpros.com/.../1999-honda-accord-99-strange-stalling-issu...
My 1999 Honda Accord is having sporadic stalling problems. I've noticed a pattern. Itstalls while going slow speeds and stop and go traffic, etc. The engine just ...

Stalling or Low Engine Idle Speed Due to Dirty ... - Repair


Jan 02, 2016 | 1999 Honda Accord

1 Answer

04 saturn L300


Next time the engine light comes on, get the codes pulled and get back to me

Apr 15, 2013 | Cars & Trucks

2 Answers

1999 mazda 626 lx engine stalls when put in any gear


It can be low fuel pressure issue or clogged fuel pump. Or its engine related issues,---------------
Check the help link mentioned below to troubleshoot the problem: ------

Engine stalls, car stalls while starting, vehicle stalls while starting, Engine stalls and dies, Car stalls and stops,
http://alltypesofpartsreplacing.blogspot.com/2012/12/engine-stallscar-stalls-while.html

------
These will help.
Thanks.

Dec 17, 2012 | 1999 Mazda 626

1 Answer

1999 for escort zx2 stulls when im at a stop light


Engine stalling and rough run issue at low speeds

This problem is commonly caused by a dirty automatic idle speed control valve and throttle valve. Buy a can of throttle valve cleaner (do not use carburetor spray cleaner!) from NAPA or Carquest (made by CRC chemicals) and spray it into the air intake while the engine is running, use up about 1/2 the can, engine will try to stall hold the speed up, shut it down and let it soak for 30 minutes, restart and blow out the remaining fluid, shut it down and disconnect the negative battery cable for 5 Min's to reset the base idle control

Aug 20, 2012 | Ford Escort Cars & Trucks

1 Answer

Sitting in car in parking lot with engine running - it dies, won't turn over... I get a jump start No changes in termperature gages at all Idles rough, check engine light on, reduced engine power reading -...


Hi and welcome to FixYa!
It is safe to drive and I assume that you are on limp mode. This is to restrict the speed to avoid further damage to the engine. You can be facing some sensor issues like the MAF (mass air flow) sensor or TPS (throttle position sensor). If one of these sensor is faulty the car tends to run sluggish, run rough or may even result to stalling.

Have the sensors replaced and observe how it goes. This can fix the issue.

Hope this helps and thank you for using FixYa! Have a good one!

Feb 17, 2011 | 2003 GMC Yukon XL

2 Answers

Toyota Echo 2004, Intermittent problem, engine goes off while on road, we close the inition key an wait 10 seconds and it restart. Problem occurs around once a week an no fault code as been...


Sounds like a weak power cable somewhere... either a partly blown fusible link, or a bad connection that has grown over time to become the issue it is today....I do not know if, when the car stops, does the entire vehicle power goes out, meaning that there are no lights (idiot lights in the dash, service engine, check engine, etc).. If absolutely no lights are visible anywhere, then I would hazard a guess that there is an issue with the power cable coming off of the battery terminal, or alternator (generator) problem. I can't really give you more than that with out more information. for an example, is the "power off" issue, repeatable under the exact same circumstances? Can it be repeated every time you try to repeat it or is it something that is just happening when ever it feels like it?

Dec 26, 2010 | 2004 Toyota ECHO

2 Answers

When I slow down to a complete stop, my 1999 chrysler sebring cuts off. Can you help me?


Possibly a transmission issue. The transmission has a "lockup" mode, where a clutch connects the engine directly to the transmission at cruising speeds. It is then supposed to unlock at lower speeds and for stopping. If it doesn't unlock, the car will stall at a stop. Try putting it into neutral (carefullly, so you don't go into reverse) as you slow down, if it doesn't stall out, it is most likely the transmission lockup mechanism.

If it stalls in neutral it is an engine issue. Bad idle control, bad ignition (it's easier to fire at high speed), bad fuel injector, bad air flow/pressure sensor... and more possibilities.

Feb 02, 2010 | 1999 Chrysler Sebring

1 Answer

Truck dies when i stop or slow down


this may be the cause, try it and see if it helps, it is a very common cause of problems like yours.
Here is the most common cause of surges and stalls and low idle rough idle, it is the idle speed control air-bypass valve and throttle valve (IAC for short), they get full of gunk over the miles and cause idle issues (stalls, low idle) like yours, Get a can of intake cleaner from any local parts store, not carb spray, intake cleaner, it is made by a company called CRC, remove the air intake hose to the engine, hold the idle high so the engine won't stall, then spray the can of cleaner into the intake while keeping the engine running, use at least 1/2 the can, shut down the engine and disconnect the battery for 5 minutes, then restart and complete a number of mixed driving cycles, town, freeway, stop and go etc., after a few days the problem will go away as the system will relearn to the clean intake.

Mar 03, 2009 | 1999 Chevrolet Silverado 1500

1 Answer

Truck dies when i stop or slow down


Here is the most common cause of surges and stalls and low idle rough idle, it is the idle speed control air-bypass valve and throttle valve (IAC for short), they get full of gunk over the miles and cause idle issues (stalls, low idle) like yours, Get a can of intake cleaner from any local parts store, not carb spray, intake cleaner, it is made by a company called CRC, remove the air intake hose to the engine, hold the idle high so the engine won't stall, then spray the can of cleaner into the intake while keeping the engine running, use at least 1/2 the can, shut down the engine and disconnect the battery for 5 minutes, then restart and complete a number of mixed driving cycles, town, freeway, stop and go etc., after a few days the problem will go away as the system will relearn to the clean intake.

Feb 17, 2009 | 2003 Dodge Durango

1 Answer

94 Carava Acts like its out of gas possible electrical brownout


The cause of the low compression could be a valve is not completly sealing or bad piston rings. Depending on weather you have blue smoke out the exaust. If not then I'm sure you have a valve that is not completly sealing. Not some thing to just let go, first try Z-Max. Z-max helps get rid of carbon deposits in the engine.

The relays that you hear clicking away are the problem Im sure. more than one occasion I have seen the relays go out and cause this problem.

The reason the lights dim and the blower slows is the reduction of voltage the alternator is puting out. When the other problem is fixed then this new one will dissappear.

Try cleaning the throttle position sensor like you said. If the contact is dirty it will not run right.

Please let me know if your problems presist.

Thanks, Charlie

Jan 29, 2009 | 1994 Dodge Caravan

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

144 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6880 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...