Question about 1999 Saturn SL

1 Answer

P0500 VSS code

Replaced VSS but code remains. Speedo vibrates for 3-5 seconds when key is turned on. Tach hesitates 3-5 seconds before it starts working

Posted by on

  • 1 more comment 
  • briancar137 Jan 16, 2009

    Same issue with the P0500 code on a 1999 Saturn SL. I replaced the sensor and the code came back. Checked the plug and wiring and all is fine. Is it a prob in the computer? Also the speedometer and all work just fine.

  • brizl Feb 24, 2009

    I have no trouble codes set, but the speedo needle vibrates for a few seconds when the key is turned off & the tach hesitates for a few seconds when the engine is started.

  • Anonymous Mar 18, 2014

    Sputters until shifting to neutral and back to drive. Not sure which sensor is vss

×

1 Answer

Usally a resister in the cluster overheated no good get new cluster or repair old solder in new bigger parts tricky

Posted on Jun 08, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Does my 1996 honda accord have a vehicle speed sensor


most old cars have a speedo cable.
is the odometer dead too. (we need that answer now)

there are 3 class evolutionary systems.
cable
electric sender to cluster
and sender to PCM and PCM drives cluster.
but honda does this on diffr, dates than most cars. (i learned)

so lets do that. we login to alldata.com and look , so can you at any time,
once a month i do random cars.
what engine, sometimes this varies by engine, and trans.
neither stated so Ill toss coin each time.
a/t trans.
1996
has electronic (hall) speed sensor VSS and runs
engine, cruise. odometer and cluster.

the 96 has no speedo cable, and works in modern mode, very advance for this time
also any scan tool on earth fits the PCM scan port
and if VSS is dead, it tells you that with a DTC , vss dead.
saving all that work wondering why it dont work.
see/?
PCM must see it work
and cluster
and cruise
if only cluster fails, and both speedo and odometer then its bad.
if only speedo fails but not odometer , then speedo meter is bad.
its that easy.

Mar 25, 2015 | Honda Cars & Trucks

1 Answer

What is the code p0500 for toyota sienna


code p0500 refers to vehicle speed sensor (VSS) --circuit malfunction===causes-- wiring VSS --ECM
replace the VSS

Feb 21, 2015 | Toyota Sienna Cars & Trucks

1 Answer

99 GMC Yukon Lost Tach, Speedo, Cruise, Odometer and slow to engage when starting to move


this happened to me is your gear indicater light also out if so look at ignition switch

Feb 17, 2013 | Cars & Trucks

1 Answer

DTC P0500 Generic: Vehicle speed sensor A


i would say u need more diag to pinpoint the problem if there are issues with the speedo i would say its the vss

Jan 12, 2013 | 2001 Dodge Dakota

1 Answer

Code p0500 toyota yaris 2006


Error Code: P0500
Fault :
Vehicle Speed Sensor (VSS) - Circuit Malfunction
Possible Cause:
1. Wiring harness.
2. Vehicle speed sensor (VSS).
3. Engine control module (ECM).
4. Combination meter.

Apr 24, 2012 | Toyota Yaris Cars & Trucks

1 Answer

P0500 on toyota tundra 2004


Vss. Speed sensor. For speedo in transmission end of cablw
screws into it?

Jan 15, 2012 | 2004 Toyota Tundra Cab

2 Answers

Hello, I have a 96 tercel with a 4sp man. I recently replaced the speedo cable to fix a MIL on due to VSS code. The cable had been broken for some time. After in stalling the new cable I still have the VSS...


you have to replace the speed sensor itself not just the cable to correct that problem, the cable doesnt do anything with the computer, try that sensor and youll be ok.

Jul 31, 2010 | 1996 Toyota Tercel

1 Answer

No speedo i have a honda civic 1.4 2000


it's missing - or it stopped working?
Check the speed sensor (tach) or VSS wiring and sensor itself for failure.
If you have an aftermarket alarm or remote starter - the installation may be poorly done - and the speed sensor wire cut or disconnected with vibration.

The Tach wire is blue - and found at the coil.
The VSS (vehicle Speed Sensor wire) is blue/white found on the Passenger's Firewall - 3 Pin Connector (top Transaxle for the sensor itself)

Thanks for using FixYa - a Very Helpful Rating is appreciated for answering your FREE question.

Jul 31, 2009 | 2004 Kia Sorento

1 Answer

P0500 code no odometer/speedodometer replaced vss


pull out the instrument cluster
.check the soldering on the plugs.they are known for problems.the computer will generate a code if no feedback from the cluster.
tie them down with ties so it does not happen again.
it is from all the vibration

Apr 26, 2009 | 1999 Jeep Cherokee

Not finding what you are looking for?
1999 Saturn SL Logo

Related Topics:

371 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saturn Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Saturn Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...