Question about 2001 Mitsubishi Montero Sport 4WD

1 Answer

The car wont star

When i put the switch on the check engine should come on but is not it maybe the ecu but i want to make shure of that so i put the scaner and is not reading the ecu you tink it may be the ecu

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 241 Answers

Ecm. ??
try disconnecting the battery first, while disconnected unplug the ecm. check for any moisture or rust.
if you find any, then yes replace ecm. if not then plug it back, connect the battery and see if that help.

Posted on Jun 08, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Crank over but wont start


did u change the ecu its possible that the ecu is coded to the keys and maybe the injectors.also if the engine including loom went in but u still using the previous ecu the pin config on the loom plug is not the same as ecu pin config being different year models

Jan 20, 2016 | 2000 Nissan Altima

1 Answer

Kia Rio5 2009 No spark on any spark plugs. Code P0339 showed up after i scanned, so i changed the camshaft sensor. Still no spark. Verified all relays. Could a weak battery, key chip, ecu.. ?


This one is kind of hard to answer. But I'll do my best with some suggestion.
First, let's find out if the ECU is OK. Put the key in the ignition and turn it without cranking the car, check the display, if you see the check engine lit up, then the ECU is fine. If it doesn't lit up, then your problem is the ECU.
Also, check the spark plug cables, check the distributor cap.
Check the relays, I'm not sure if any of the relays is related to the engine.
Also, make sure the alarm is working fine. If it's faulty, maybe it won't let any current goo thru.

Dec 19, 2015 | 2009 Kia Rio

1 Answer

How to get to brake switch


Putting one foot on the brake to put the brake light on will not stop the engine from running. If the headlamps are on try removing the battery and allowing the ECU to reset.

Jul 29, 2014 | 2003 Mercedes-Benz S430

1 Answer

Will not kick down high rev


maybe the ECU blocks the engine, becase of some kind of fault...
Try to read faults from ECU via some kind of reader... Can buy one on EBAY for few bugs, 10 maybe

Apr 16, 2014 | 2002 GMC Envoy

1 Answer

Own a 2002 isuzu axiom, unplugged my tps on accident while running now wont star?


attach any scan tool then push ECU reset.
if desperate
pull battery neg lug for 5m, and put back.
this bat pull, also resets all things, even things not wanted.
radio, alarm., remote start bs box, and other things.

the ECU on many cars calibrate the TPS, when freshly booted.
so reset the ecu.

Nov 02, 2013 | Cars & Trucks

2 Answers

I have a 1993 nissan pathfinder automatic transmission and it will not move in first gear.it willl move in all other gears,in drive it wont shift out of second unless i push the overdrive button,what


check ecu fuse.your problem could be vechicle speed sensor also. if you dont see any ecu check engine light fuse either blowed or bulb burned out.but if ecu not working vechicle wont shift correct.

Dec 08, 2012 | 1993 Nissan Pathfinder

1 Answer

Was idling it stalled and now wont start


your fuel pump may be that cause, have some one turn da key while you listen for fuel pump by gas tank, no noise pump not working, then get a rubber mallet and has soon they open ingition switch hit gas tank pump may star working may not but you will kown per shure your pump is bad

Feb 03, 2011 | 1998 Ford Explorer

2 Answers

I have a 1995 mitsubishi eclipse, 4 cylinder, 2.0 non-turbo. The car will crank but there is no spark and we are not getting any gas. We've checked all of the fuses and the relays. Do you have any...


if you haven't checked the ASD relay, make sure its working.
175c874.jpg if thats okay, check the Cam Angle and Crank Angle sensors. if it isn't any of those, its probably the ECU

Jul 22, 2008 | Mitsubishi Eclipse Cars & Trucks

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

166 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

60867 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...