Question about 1996 Chevrolet Blazer

2 Answers

Rebuilt heads on 96 blazer 4.3 now no power

Battery checks good,12v at alternater. no power at battery junction block and nothing is working. no lights, horn,starter,etc.nothing.
ground wires that bolt to the back of the heads are showing to be grounds without being bolted up.

Posted by on

  • warlockpain Jun 05, 2008

    under the hood or inside the vehicle? everything was working fine before i removed the heads,had them rebuilt,then reinstalled everything. now i have power to nothing,

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Well, here's an update. When I hooked up the alternator, I hooked it up wrong. There was one red wire and one black wire. I just assumed when hooking it back up that the black wire was ground so I hooked it up to ground. It wasn't. The black wire was positive. I don't know if the manufacturer color coded it wrong or if someone after changed the wiring color. I followed the black wire and found all the inline fuses everyone was talking about. He then decided to hook that up to positive and everything started working. So I guess lesson learned is even if it looks obvious how to hook it back up when taking it apart, to label every wire anyways as to where it went when hooking back up.

Posted on Feb 04, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 868 Answers

Check your neutral switch, its usually on drivers side on the back of stearing column .Its easy to reach and if you consult a mechanics service book, it will be alot easier to find and save you alot of frustration. Please rate this. Thanx.

Posted on Jun 05, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1993 Suburban. Why do only the headlights and dome lights work?


So when you turn the key to on, no dash warning lights and gauges turn on? Did you check the fuses with a voltmeter or test light? With key off, some fuses would have power at all times-brake lights, headlights, horn- but with key on, all fuses should show power.

Just off the battery is the Battery Junction Block, where the power is distributed to various circuits through Fusible Links. These connect to battery power with eyelet connectors at the Junction Block-looks like 5 or 6 Links leading off the Block. Even the small wire from the battery to the Block is a Fusible Link, but if your headlights work, this main Link must be okay. One of the Links from the Junction Block would be to the ignition switch. If your ignition switch has power, you may have a bad switch, but you need to check if it has power first. If no power to switch, check the Fusible Links. The diagram I am looking at does not show which one it is, unfortunately.

Jun 11, 2015 | Chevrolet Silverado 1500 Cars & Trucks

1 Answer

Is there a fuse that run the air condition inthe honda odyssey 2006


Hondas all have a fuse and blower relay located in the battery junction block. You can try swapping relays around if the fuse is good. Then verify the blower motor is good by disconnecting it and applying 12v directly to the motor. If this checks good, check for 12v at the blower connector while disconnected, (key on/fan on). Had a CRV in the shop a few days ago with the exact same issue, power to the motor but a weak ground signal. Replaced the blower resistor.

Jun 13, 2014 | 2006 Honda Odyssey

3 Answers

When I was ajusting my alternater belt my wrench touched, and welded itself to the power cable at the alternater. Now my truck will start and the headlights work but nothing else.No alternater,no...


Check all your fuses. Remember that the first step before any repairs are done is disconnect the negative battery cable.
What kind of vehicle is this???

Oct 10, 2013 | Cars & Trucks

1 Answer

Front wipers do not work


Have you check any fuse related to the wipers, in the junction block and power dist center,JB fuse 6, if the washers work the fuse is good, this will need some test light use, multi function switch on column, pin 4 on connector , dark/blue should have 12v to it,if not ,open power to switch,red/gray wire coming out is to wiper, should be power there when turned on, if not, replace the mfsw,if power, go to the wiper motor and check same wire for power, if there replace the motor, if not, open circuit to motor. GOOD LUCK, RDJRP

Dec 25, 2009 | 2000 Dodge Durango

2 Answers

My engine was running and when i turned on my headlights the entire vehicle died. Now i won't even get dash lights to come on? Is this a fuse that i can't find or a relay that needs to be replaced? 96...


sounds like the alternator went bad. and wasnt charging battery, when headlights demanded power there wasnt enough to supply light and motor , so it shut down, recharge battery check battery connections then have alternater check, good luck. hope this helps.

Oct 31, 2009 | 1996 Chevrolet Blazer

1 Answer

No power to ignition switch


There should be one large hot wire going to the ignition switch thaqt has power at all times...I would check that wire and trace it back to the battery. Quite possibly, it will connect to a fusable link coming from a main junction such as the alternator or the power distribution block. Either the link has failed or there is a bad connection there. I'm going to look through any diagrams I have and see if I can find anything else that may be helpful but that's a good start for now.

Jul 12, 2009 | 1990 Jeep Wrangler

1 Answer

All electrical went out


Use a wire brush to clean the battery terminals and the inside of the battery cables where they connect to the battery terminals. If that doesn't fix it, I suspect the problem is the negative connection from your battery to the car body/engine block. Follow the thick cable from the negative terminal of the battery to where it connects to engine block. Make sure you have a good clean metal to metal contact. Use an ohm meter to check to make sure this cable and connection is good. If the connection to the engine block is bad the hood light might still be able to work if it has a separate connection to the negative battery terminal.

May 21, 2009 | 1989 Chevrolet Beretta

1 Answer

New Alternater will not charge batery


When you touch the hot wire to the manifold you may have damaged your alternator. Take your Blazer to your local car service center such as Advance auto and have them run a test to make sure your rebuilt alternator is charging. Most centers will do this free of charge.

Mar 15, 2009 | 1989 Chevrolet S-10 Blazer

2 Answers

No power t my 96 chevy blazer


try the altenater.had the same problem with my 96 blazer

Nov 03, 2008 | 1996 Chevrolet Blazer

Not finding what you are looking for?
1996 Chevrolet Blazer Logo

167 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6880 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...