Question about Chevrolet Camaro

1 Answer

Danny, I helped my friend who is a good mechanic change the #1 and #3 injectors on my '91 Z28(350 T.P.I.). Before we changed them I was not having a problem with the Idle but after...it's chugging, sputtering and even cutting off when I am at low speeds. I changed the IAC valve and we even went over all of the connections, nuts, bolts, etc. The only things that is different is, I cracked the housing where the wires go into the TPS. I am headed to PullAPart tomorrow to replace that. Do you have any other suggestions ? Do you think that when I cracked the TPS housing that I might have knocked it out of adjustment ? Could it be the injectors ? Thanks for your help, Walt

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 14,036 Answers

THE IDLE AIR CONTROL VALVE NEED ADJUSTING AND THE IDLE SPEED HAS TO BE READJUSTED. THIS JOB IS A HEAD ACHE.I WOULD LET DEALERSHIP DO IT.THEY CAN RESET AND REPROGRAM IDLE AIR CONTROL VALVE.IF TRY FIXING YOUR SELF YOU WILL HAVE HIGH IDLING PROBLEMS AND VECHICLE STALLING OUT ON YOU.

Posted on Oct 15, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

2004 Grand Cherokee (4.0)intermittent #1 cyl misfire and #1 injector control circuit fault (3 wks). Problem began after changing spark plugs. Replaced: coil pack, 6 injectors, & Bank #1-#2 O2 sensors.


I worked on one with the same issue. Ended up being the harness burned at the rear of the engine on the exhaust. Burned wires going to coil pack and shorted when I moved the wires to the coil packs.

Feb 22, 2017 | Jeep Cars & Trucks

1 Answer

Misfiring on bank 1 3 and 5


misfiring is also from injectors and low fuel pressure. To be all on the same side I suspect injector wiring ( possible loose connection on the ECM). Have a compression test done to delete mechanical problems (valves)

Mar 05, 2014 | Cars & Trucks

1 Answer

Hi, I need help with my 2002 chevy express 1500. after tune up (change sparkplugs, wire sparkplugs, fuel filter, air filter, distributor cap and rotor) , I feel my van sometimes cough when driving, when...


I wouldn't give up on it, but I would sure be P.O.ed at the mechanic- $700 for a bad diagnosis. Why would he think 3 injectors were leaking? Was it running rich? Did he do a scan for trouble codes? Did he check fuel pressure?
Probably something minor-anything now should be minor after $700. Well, at least you got new fuel injectors. Have some tests done, scan for codes, check fuel pressure. Carefully clean the MAF sensor with maf cleaner spray, or at least a sensor safe spray cleaner. It is delicate, so use care. Let it dry thoroughly before putting back on. About all I can think of, good luck.

Oct 01, 2013 | 2002 Chevrolet Express

1 Answer

HAD 2001 OLDS ALERO COMPUTOR CHECK SAID # 2 CYLINDER WAS MISSFIRING CHANGED #2COIL PACK STILL DIES WHEN SLOWING DOWN OR STOPING BUT STARTS RIGHT BACK UP DIES WHEN STOPPING OR SLOWING DOWN ALSO DIES AFTER...


Sounds like #2 is still missing. Misfires can be caused by an ignition problem, a fuel problem, or a mechanical problem where there is no compression in the cylinder.
Okay, you have changed the coil. Now try changing spark plugs and the spark plug wire-Swap #2 and #1 spark plugs and the plug wire too, and see if misfire follows now on #1. If it does, bad plug or bad plug wire. Of course you could just drop a new plug into #2 and see what happens. If no change, swap the plug wires and test again. If still misfiring, check the spark at end of plug wire-you need to see a blue snapping spark to know the ignition is working good on that #2.
If you have spark there, need to check if the injector is pulsing and spraying fuel into the cylinder. You might be able to feel the injector pulse if you hold a finger lightly on the injector while engine is running-should be a steady, rather rapid click feel to the injector. If not sure, have the injector circuit checked. You can buy an inexpensive "noid light" at auto parts stores, one that fits your injector circuit, plug it into #2 injector, and crank the car over or run the engine and watch the light-if working, the noid light will be blinking. This verifies the circuit is good. If the spark plug is wet with gas when pulled out, that would verify that injector is spraying fuel into the cylinder.
If still no help, have the compression checked in #2. Low compression from a valve problem or head gasket problem can cause misfires.
Good luck.

Sep 20, 2013 | 2001 Oldsmobile Alero

1 Answer

I have a 91 camaro just got the fuel pump change n fuel filter also cleaned out the injectors in still won't start up full turn n my dash board wus workin just fine now its not working just got a new...


ask a local mechanic to have a look ,you may have left a power supply cable off from the positive terminal ,as for the non start then check for a spark and if a spark then check the fuel pressure it should be 55lbs on the injector rail is a tyre valve looking connection check the fuel pressure here

Apr 28, 2012 | 1991 Chevrolet Camaro

1 Answer

Auto question,I have an 96 Dodge Ram w/ 5.2L V8 eng.the problem is dtc codes P0300 and P0301,random multible cylinder misfire detected,and cylinder #1 misfire detected.Ive replaced the spark plugs, plug...


I would check the injector. Pull the plug and check for corrosion. Use on ohm meter to check the injector. The resistance should be 11 to 15 ohms. Check it against another injector. they should be close. You can also check the injector plug. best to use is a noid light, but you can use the meter. set it to dc volts to check. the numbers should jump everytime it fires. since you got a 300 and 301 misfire it tells me that you have an intermitant misfire in cylinder 1. The other sensors are still good don't replace them. The coil is still good, because when it starts to go, it will have misfires on all cylinders or will not work at all. The crank sensor is the one that detects the misfire, again don't replace it because it's not bad, it's just doing it's job. If the injector and harness check out good then I would start check the cylinder for compression and mechanical problems

Nov 24, 2010 | 1996 Dodge Ram 1500 Club Cab

1 Answer

The engine on my sons 91 Mazda Miata is running ruff. Like on 3 cylinders. If I pull the spark plug wire on the #1 cylinder the engine runs the same. If I pull the spark plug wires on the #2,3, or 4...


You have done a great test but If I assk you to do a swap of the Ist cylinder plug and injector with one from the 3rd , we can come to a conclusion before we can change the full set of plugs and injectors for a good performance.( only if the mileage is time enough to do the change)
If you have confirmed with the spark and the fuel ( hope the fuel pressure is good and the pump calibrated , even though this is not relevant) please also check the wires to the first plug and the fuel line to the first injector.
I hope there is no issues in the pump finally for not releasing enough fuel to the first.( Check for presence of fuel pressure in this line)
I am sure you are confident enough to get to the fault .
Hope you credit me if this helps a bit. Good day

Aug 18, 2010 | 1991 Mazda MX-5

2 Answers

Jaguar s type 3 litre 1999 running badly, has been stood for 2 years, was running lumpy when stood up, hence why I bought it so cheap! have changed spark plugs, air filter and one coil pack and 1 lambda...


did you drain the gas old fuel turn into like gel and can clog injectors and run rough it may take a while and some fuel flush to have it running good again

Sep 17, 2009 | 2000 Jaguar S-Type

1 Answer

Cylinder 1 misfire '02 Ford Escape


CHECK COIL TO NUMBER 1 CYLINDER.AND FUEL INJECTOR TO NUMBER 1 CYLINDER.IF ALL IS GOOD YOU HAVE INTAKE LEAK OR MECHANICAL PROBLEMS TO THAT CYLINDER.

Jun 12, 2009 | 2003 Ford Escape

2 Answers

Idleing Problems Need help


I had the same problem when I first got my firebird. All I did to mine was change the Spark plugs and wires, and had a mechanic friend of mine check and set the timing. since then I haven"t and problem with the idleing on my car. Personally I would also change out the cap and rotor, and see if that helps.

Jun 06, 2008 | 1991 Pontiac Firebird

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

142 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8123 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...