Question about 1988 Audi 80

Open Question

Hi, I have a 1988 Audi 80. The speedo works but the odometer and tripmeter don't. This is a NON cable version. I bought a new instrument cluster from a junk yard and, after substitution, it has exactly the same problem ie. working speedo but no odo or trip. The new cluster had about the same mileage as my car (140,000) Is failure of the odo and trip so common that BOTH clusters are faulty or is it more likely a sendor problem? Thanks.

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 341 Answers

SOURCE: speedo head/cluster

pull on trim around dash will pop off . tilt wheel down. remove 4 screws from cluster. lift out

Posted on Oct 20, 2008

Ad
  • 2 Answers

SOURCE: speedometer and odometer not working 92 audi 100

I had similar problems with speedos in two 1990 Audi 100s, it was some time ago, but the contacts on the circuit boards on the back of the speedo deteriorate and do not give a good contact. I bought second hand speedos, only to find they had similar problems, eventually it was very easy to fix, I shaved matchsticks to chisel points and pushed them into the circuit boards to add pressure on the contacts and improve connection. After that repair drove the cars for a few years and the problem did not recur. It was a long time ago and I cannot remember exactly where the matchsticks were placed but look for soldered points near the edges of the boards. Regards, Michael

Posted on Dec 08, 2008

ccrozier_agr
  • 36 Answers

SOURCE: Audi A4 instrument cluster does not work

Your dash has what is known in the trade as a dry solder joint in the instrument cluster it will have to be repaired by people whom specialise in this work.
You could try BBA remanufacture as they do a lot of this type of work for us.

Posted on Dec 11, 2008

  • 7 Answers

SOURCE: odometer\tripmeter stop working

Pull the drive cable out of the odometer and try to turn it. If it turns the drive in your gearbox is worn out and needs to be replaced.

Posted on May 13, 2009

  • 29 Answers

SOURCE: speedo not working

try replacing the speed sensors.

Posted on Jun 20, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

4 Answers

Ha a new speedo cable but the odometer doesn't work. Why?


Because of the plastic gear on the odometer shaft is some teeth . You'll have to replace the entire speedometer . Or take the vehicle to a shop that does those types of repairs. I went to the junkyard and bought the entire instrument cluster for under 50.00$ . Did it myself. Tedious job don't be in a rush could break something else. .

May 02, 2015 | 1995 Geo Tracker

1 Answer

2003 Jetta Tdi instrumentation cluster both LCD segments are no longer displayed Remove cluster and disassembled carefully removed displays and cleaned contact pads on circuit board and cleaned zebra...


Your LCD display is out of order. You can try to find one new on eBay. Chinese brand is cheaper, but VDO is better. After buying the LCD display you will need to install it.
See this link as an example of a new LCD display installation in the instrument cluster.
http://www.audizine.com/forum/showthread.php/263498-Official-DIY-2000-Audi-S4-LCD-Instrument-Cluster-Pixel-Repair

Aug 02, 2011 | Volkswagen Jetta Cars & Trucks

1 Answer

Yea my odometer and trip is analog and there not working on my 96 ford ranger 4cy all other guages work i was wondering if it is on the rear differental that sensor back there or where its at cause its...


If I am correct that vehicle uses a speedo cable that goes from the instrument cluster to the transmission.
If your speedo is not woorking you may have a bad cable or gear which is on the end of the cable and can be accessed by removing cable from tranny which is held in by a bolt and clip.
If your speedo is working but your odometer is not than you have a problem in the cluster itself.
You can have it repaired at a certified speedo shop or replace it with junkyard unit.

Jul 17, 2011 | 1996 Ford Ranger SuperCab

1 Answer

Odometer not working


Could be that speedo cable has become disconnected or that the inner shaft has broken. The speed cable is connected between the back of the instrument cluster and the left side of the transmission. Check under the car that the cable is securely fitted to the side of the transmission. Disconnect it and and check on the condition of the square drive flexible shaft. The spinning of this inner shaft is what conveys the output shaft speed of the transmission to the instruments. The instrument cluster can be removed but pushing a length of coat hanger wire with right angle turn on its end between the the cluster and the dashboard surround. Turn the coat hanger to hook behind the cluster and pull forward to remove it. Try several points around the cluster. It is best to disconnect the speedo drive cable to withdraw the cluster (after electrical connections have been disconnected. check that the speedo cable is secure to the back of the instruments. If you remove the cluster completely follow the path of the speedo cable. If you have to replace the cable, tying a length of string to the speedo cable end first and posting the string down the cable path will help the re-installation enormously. Simply pull the string whilst reinstalling the instrument cluster until the end of the speedo can be got hold of. Refit the speedo cable to the transmission only after the instrument cluster is back in place.

Oct 17, 2010 | 1990 Mercedes-Benz 190

3 Answers

The odometer does not work. changed it out with other unit and still does not work. appears to be electrical or computer? speedo works fine


Speedometer, Odometer and Trip Odometer are driven by same circuit. Failure of Odometer and Trip Odometer suggests a circuit board fault on the instrument panel. A used instrument panel or repair of yours is probabaly best options.

The speedometer should malfunction too if speed sensor failed. If only the odometer and trip meter stopped working, it will most likely be the cluster itself. I had this problem, but since took the cluster out and give it a nice tap/knock, put it back in and it has worked since. Keep in mind that the VSS provides signal input to circuit that drives speedometer.

Instrument panel removal is not hard if you follow the shop manual instructions for trim removal. I've done it once on my 2.5TL to replace the D4 light bulb. PM your email address and I'll forward the pdf files for the procedure. The Vehicle Speed Sensor goes into the differential, and is what makes your speedometer and odometers work. If that fails, then your D4 light should start flashing, and either the speedometer will be bouncy or not work at all. Perhaps he forgot that 1Gs have a differential, so he said the tranny, but it's in the diff.

Hope helps.

Jun 14, 2010 | 1996 Acura TL Series

2 Answers

Speedometer not working 2003 Tahoe. What are possible fixes and costs?


Is the ODOMETER working? Service eng soon light on? Could be a speed sensor OR a Instrument Cluster problem. If the Odometer works, its an Inst cluster and it wil need to be replaced. Any good Repair shop should be able to get a new one or DORMAN PRODUCTS makes replacement clusters for most GM trucks.

Dec 30, 2009 | 2003 Chevrolet Tahoe

1 Answer

Odometer\tripmeter stop working


Pull the drive cable out of the odometer and try to turn it. If it turns the drive in your gearbox is worn out and needs to be replaced.

May 13, 2009 | 2000 Dodge Caravan

1 Answer

1989 Audi 500 se Automatic - Speedomoter


The gear on the odometer is stripped. Quite the common problem with Audi's of this vintage. Parts available at: http://speedometergears.com/

To fix, you have to pull the gauge cluster, remove the speedo from the cluster, then remove the odometer from the speedo. The gear replacement is pretty easy once you get it all apart.

Mar 26, 2009 | 1989 Audi 200

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

112 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audi Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

76051 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14362 Answers

Are you an Audi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...