Question about 2001 Mitsubishi Galant

1 Answer

The drivers side coil is not firing despite having bought a new one and making sure its getting power. Moving the other coil to the drivers side results in the new coil not firing and the old one now on the passenger side firing fine.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mitsubishi Master
  • 6,826 Answers

Maybe the computer which controls the spark is bad, or the circuit or wiring between the coil and the computer is somehow disturbed or broken.

Posted on Oct 14, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Do you use a ohm meter to test a ignition coil?


The normal way to test a coil is to verify you have power on the positive side and when you take away the ground connection it should send power out the tower. I think if the ohms reading between the posts is zero its dead but otherwise it does not tell you much.

Aug 26, 2014 | Cars & Trucks

1 Answer

Coil not firing


Make sure the coil is getting power. Then you would need to check the crankshaft sensor for continuity after unplugging it. If the coil is getting power and the crankshaft sensor is tested good, then the brain box must be dropping the signals.

Jan 18, 2014 | 1992 Mercury Capri

1 Answer

2000 mazda protege has no power to coils


Not sure where you are getting voltage, but the coils get power from the key and a ground signal from the computer. The voltage may actually come from a relay.
So you should have voltage on one side with the key on, and a ground pulse on the other when the engine is cranked. The coils fire when the ground is removed.

Jan 04, 2013 | Mazda Protege Cars & Trucks

1 Answer

Ive got a 1994 honda accord and i cant get any fire out of the coil. its getting power to it. i put a new coil on it but still no fire


You may have a bad connection on the out side of the coil. Make sure it is connected with the right polarity, The positive terminal should be connected to the ingnition with a negative earthed battery.
Take the spark lead out of the distributor and hold it close to the engine block, crank the engine and see if you have spark then, You may be losing it at the distributor.

Jul 05, 2011 | 1994 Honda Accord

1 Answer

I have a plymouth breeze 1999 model 2.4 engine.It is not firing on pistons 2 and 3. On top of that ,the ignition coil pack on the 2and3 pistons is getting so hot so that the rubber on the two points is...


this could be the ignition coil on the 2-3 side of the coil.inspect the connector on the coil to make sure it is good.if the coil has been this hot replace it(used one)as there will be other internal damage to it.these coils are grounded through the computer and supplied power with the key in the on position.the computer grounds the circuit for the cylinder that is to be fired.these also have coil drivers in the computer which may have shorted out.have the system checked out first before replacing parts as if its a shorted driver then it will take out the replaced coil.

Apr 27, 2011 | 1999 Plymouth Breeze

4 Answers

I have a 1990 mustang 5.0 with a manual transmission and I just had the engine rebuilt. I am not getting any spark to the distributor and I bought a new coil and module but nothing. I checked the...


Are you getting power to the red and green wire on the module with the key on and power to the red and blue wire on the module when cranking? If yes, I would say you pick-up coil is bad.

Feb 14, 2011 | Ford Mustang Cars & Trucks

2 Answers

I have a miss fire


Recheck the firing order; 1-6-5-4-3-2

On the distributor passenger side radiator to fire wall. 2-4-6-coil
On the distributor drivers side radiator to fire wall. 3-1-5

Cylinder passenger side radiator to fire wall. 2-4-6
Cylinder drivers side radiator to fire wall. 1-3-5

Good luck and also check the distributor cap again for proper seating.

Nov 13, 2009 | 1998 Chevrolet Blazer

1 Answer

2001 jeep Grand Cherokee fuel injectors


check the injectors on that bank for pulses.. a regular 12v text light will do it should flash when cranking... its very possible that the crank sensor or camshaft sensor on the replacement engine is bad and giving you all the problems you have now.. are you using the original injectors? if you have injector pulses then check the coil for pulses the same way.. btw make sure you have 12v to them even before cranking engine could be a bad asd relay..wet plugs on one bank would also indicate a possible leaking injector and basicly draing the fuel starving the oposite bank for fuel.. to verify that the rail must be lifted by removing all 4 bolts make sure the clips hold the injectors firmly and turn the key to run but dont crank it then look for fuel leakin from bottom of injector(s) any drips is a bad injector..

Jan 28, 2009 | 2001 Jeep Grand Cherokee

1 Answer

Have a 1979 318 ci dodge motor and I am not getting fire out of the coil, but have power on + side and - side o0f coil


Try pulling the coil & ballast resistor & make sure they have a clean ground. Try the parts on another caaaar if available.

Jan 19, 2009 | Dodge D150 Cars & Trucks

1 Answer

No fire @ coil


make sure the cam sensor is plugged in properly, located on the drivers side on the side of the head, if is is I would check make sure the cam is turing, if is is it could possably be the timeing is out on the belt

Aug 17, 2008 | 1996 Dodge Neon

Not finding what you are looking for?
2001 Mitsubishi Galant Logo

Related Topics:

108 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

75824 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8215 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...