Question about 2004 Chrysler Crossfire

1 Answer

Just fueled up 93 octane. drove approx 1/2 mile to work. started the car, check engine light came on and runs extremely rough and stalls. could it be the fuel and how do i check it. 2004 chrysler crossfire.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Chrysler Master
  • 75,797 Answers

I would suspect the fuel is the problem, most likely water is in the fuel, but get the codes read to see what fault shows up that turned on the check engine light.

Posted on Oct 14, 2010

Testimonial: "confirmed my thinking. will follow this advise."

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a 2000 Oldsmobile Alero, and yoday I stopped at a Cheap gas station for gas, and I didnt even drive it a block, when it started running REAL ROUGH, chugging, and stalling. And it even died. I got it...


Check or replace all your fuel filters. Check for water in your fuel. Drain your tank and replace with 93 octane fuel. Also check your spark plugs.

Aug 07, 2013 | Cars & Trucks

2 Answers

Vibration at idle


it may be idle control sensor or a bad mas air flow sensor--maf sensor in otherwords. or could be engine misfire at cold temp. start. only time when cold? or does run better when warm? try warming engine to operating temperature before driving,if problem removes it's self after warm up,up grade gas to 93 octane for 1 tank full. then see if problem goes away. it's cold where you are right? if so the fuel needs to be at least midgrade 89 octane fuel because 87 octane fuel will not start your honda correctly at cold temps. in cold weather 93 or super gas octane will start ,no problem,low octane fuel sometimes gels, or freezes at low temps. if in warm climate, change the fuel filter, add fuel injector cleaner to your fuel tank[preferablly lucas fuel treatment] this will lube your fuel injectors and give better fuel mileage. thank you for choosing fixya.com

Jan 04, 2011 | 2002 Honda Accord

1 Answer

Lost power to engine


Check make sure all plugs are firing. Sounds like what my 93 Rodeo was doing-Idled okay but very rough when in gear. Turns out only 5 out of 6 plugs were firing due to a defective ignition module- 100 bucks later it works fine.

Hope this helps.

Mar 20, 2010 | 1992 Isuzu Trooper

3 Answers

2002 express 1500 van, will not start


remove dog house locate test port and install guage should be 45-60 psi

Mar 03, 2010 | 2002 Chevrolet Express

1 Answer

2003 A4 Cab no-start then rough start


Rough idle is usually one or more coils on the 1.8t engine - is that the engine you have? If three of 4 coils were replaced (assuming 1.8t engine), change the last one just to be sure - they are not that expensive. No Start is probably something else, like a loose/bad battery or ground connection. Check to make sure there is not a whole lot of corrosion at the battery terminals. Good luck.

Jun 10, 2009 | 2003 Audi A4 Cabriolet

1 Answer

Engine running rough


It sounds like maybe yu have a fuel filter that getting plugged up.
To check this, see if you can remove it from the engine, then very carefully blow thru it in the direction the fuel travels, if clean you should be able to blow thru it easily, if not then replace.
The P132 is (E132) .................. Knock Sensor Circuitry Failure .... The knock sensor is what prevent engine ping from low octane. ...
It could also be you just got some bad gas.
You also might try topping off the tank with gas from another place and bring the octane level up if that is the problem.
Hope this helps
Good luck

May 20, 2009 | 2003 Dodge Ram Maxi

1 Answer

Rough running/Stalling


you need to check your fuel pressure

Jan 02, 2009 | 2000 Lincoln LS

2 Answers

#2 fuel injector not working


There is a little tester calles a NOID, it plugs into the harness connector to the fuel injector and flashes if there is a signal, they only cost a few dollars.

Sep 26, 2008 | 1992 Nissan 240SX Fastback

Not finding what you are looking for?
2004 Chrysler Crossfire Logo

323 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chrysler Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8140 Answers

Are you a Chrysler Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...