Question about 2002 GMC Yukon XL

2 Answers

2002 Yukon XL

We replaced the ABS module and when doing it there was spark from the battery. ABS is working fine. Problem now is the climate control. If you turn the fan on auto at 68 you get hot heat and have to keep it turned to 82 and off and still feel hot air coming thru the vents. Have removed and waited a few mintues with several diffent fuses related to climate control in the electrical center. Got any suggestions?

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 198 Answers

Did u try changing the sensors related to the climate control... just try doing it once....feel free to ask for any help.

Posted on Jun 04, 2008

  • kishore swamy Jun 04, 2008

    may be it has got shorted when ther ws a spark...

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 3,037 Answers

Sounds like maybe something got messed up in the onboard computer. My suggestion is to take it to a local NAPA, AutoZone, Checker or similar store and have them hook a device up to the computer and see what error codes are displayed. After doing this, they should be able to tell you what the codes mean or just post them here and I would be happy to let you know.

good luck and feel free to let me know of any other questions that you may have, just ask

Posted on Jun 04, 2008

  • Benjamin Patri
    Benjamin Patri Jun 08, 2008

    If you are satisfied with your experience here, then feel free to provide me with some feedback by
    rating my solution. If you need any more help, I would be glad to
    assist you, just ask.





    Thanks for your time and service and I hope you have a Great Day!

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Traction active message coming on in a 2003 hummer h2


Hello! This is usually the result of a wheel speed sensor issue. Most technicians look for WSS fault codes, to decide which one is failed, but if there are no fault codes, they don't know where to look. The trick, is with the scantool hooked up, watch the ABS solenoids and see which ones activate during the traction event. If the Wheel Speed Sensor is acting up, it can confuse the ABS module into thinking that wheel is slipping and it will activate the ABS pump and solenoids for that wheel, to try and slow it down.
With the stability system disabled, it won't try and slow the "slipping" wheel down, which is why it won't do it when disabled.
and the noise you hear is probably the ABS motor and solenoids, which are mounted on the Left Frame Rail, below the drivers seat (often heard at the firewall).
There was a bulletin to replace the Yaw Rate Sensor and update the ABS Software, which is probably where the $400 went, and it may have needed it, but obviously that wasn't the problem. I beleive that the issue lies withing the Wheel speed sensors.
the most common symptom of speed sensor failures is premature ABS activation, but I have in some instances see it cause Traction Control events take place as well. Here is a service bulletin for unwanted ABS activation:
Subject: Antilock Brake (ABS) Activation At Low Speeds (Clean Wheel Speed Sensor Mounting Surface) Models: 2002-2006 Cadillac Escalade, Escalade EXT 2003-2006 Cadillac Escalade ESV 1999-2006 Chevrolet Silverado 2001-2006 Chevrolet Suburban, Tahoe 2002-2006 Chevrolet Avalanche 2003-2006 Chevrolet Express 1999-2006 GMC Sierra 2001-2006 GMC Yukon, Yukon Denali, Yukon XL, Yukon Denali XL 2003-2006 GMC Savana 2003-2006 HUMMER H2

Read more: http://www.justanswer.com/chevy/1s7al-2004-tahoetraction-control-turns-during-acceleration.html#ixzz3OcuhIIbz

HOPE THAT HELPS

Jan 12, 2015 | 2003 Hummer H2

1 Answer

2002 gmc yukon xl rear heating problems


There is a climate control module in the head liner of that vehicle. IT needs to be checked or replaced

Feb 14, 2013 | Cars & Trucks

1 Answer

An annoying ABS break chime and lights come on on my 2003 yukon xl every time i drive. the breaks feel ok. i was told the control module is bad and the ABS not working. the price tag to fix by the...


you could always go to the wreckers and pickup used component(s) to replace the damaged ones.i assume that this was checked out by a shop and your not going by what someone has told you.

Jul 30, 2011 | 2003 GMC Yukon XL

2 Answers

My brother's sprayed engine cleaner on my 2003 Yukon XL and then washed it off with a water hose. 30 minutes later while driving my ABS plue Parking Brake lights came on with a message saying Check Brake...


C0550 is the code for the ABS module. It is on the frame under the vehicle around the drivers door area. It is a module with all the brake lines coming from it. Reset the trouble codes and see if the problem returns. If it does, the module is not serviceable and will need to be replaced.

Mar 24, 2011 | 2003 GMC Yukon XL

1 Answer

Blower motor runs with the key off


Does it have auto climate control? If yes replace the blower control module.

Oct 07, 2010 | 2003 GMC Yukon XL

2 Answers

GMC Yukon Denali XL Auxiliary Blower Motor Battery Drain


Could be that the switch itself is shorting and allowing power to flow,if you can get to the switch I would use a voltmeter and see if there is voltage on the output side with the switch off.

May 14, 2010 | 2003 GMC Yukon Denali

2 Answers

Abs system keeps running even when you cut the truck off.


Common problem in GM's. Had it happen in my 2001 Tahoe. There is a company in Russia, IA who rebuilds the module for less than $200 and gives a 5 year warranty. Cheaper and better than you can get from GM.

Go to E-Bay and do a search on ABS module and you can then find their website for full instructions and details about this modification. I did it, and am well pleased with their work.

Dec 17, 2009 | 2002 GMC Yukon XL

1 Answer

2002 Yukon XL


i serviced my 2004 yukon for abs light came on they told me it was the right front abs speed sensor wire , which is sold sepratly or with wheel hub cost$ 300 or 57$ for just sensor wire, i did all brakes changed sensor and for awhile the stayed off but comes on and at about 20 mph it turns off ?

Jan 25, 2009 | 2002 GMC Yukon XL

1 Answer

2002 Yukon ABS Issue - EBCM?


This is caused by a stuck relay in the EBCM which is under the vehicle below the drivers seat.

Sep 18, 2008 | 2002 GMC Yukon XL

2 Answers

ABS Pump wont shut off


go to www.modulemasters.com

The dealer will charge you $1300 - $2000. Contact Module Masters. They are great to deal with. You have to ship it to Moscow, Idaho. It cost me about $15 to ship it (with box, packing, and insurance at a UPS store). They charged me $130 to rebuild it and gave me a 5 year warranty. It cost $8 to ship it back. To in total, it cost me $153....totally turn-key.

Jun 30, 2008 | 2002 GMC Yukon XL

Not finding what you are looking for?
2002 GMC Yukon XL Logo

142 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

60792 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...