Question about 2005 Nissan Altima

1 Answer

My Altima SE R will not run. I replaced the fuel pump, but we are learning that there is no pulsation to the fuel injectors. We checked out the immobilizer and its fine, all the cam sensors are fine, the crank sensor is fine. The timing chain is turning, When you spray starting fluid in the intake, it acts like it will start up, but it doesn't. We have checked all the fuses, and relays, and all are fine. Also, NO CODES are present. Did a compression check it it was very good, and also it is getting spark. Been working on this car for 3 weeks, and burned out. LOL...The car just quit running while driving. It happened as I was shifting gears on the highway. HELP....

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Nissan Master
  • 496 Answers

First guess is anti theft.
Leave key on for half an hour and/or lock unlock doors with remote.
Does the tack on the dash show rpm when cranking the engine?If it does you should have a injector pulse using a noid light.
If you have rpm showing and no injector pulse try borrowing a computer from a vehicle like yours.
No RPM showing when cranking?
Check/change crank and cam sensors and possibly computer.
Cam timing can cause no start but you should have an injector pulse even with a jumped tooth or two on the timing chain.

Posted on Apr 21, 2017

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 100 Answers

SOURCE: I recently replace the crank shift sensor, but

switch on your car but don't start it, let it stay in that position for a few minutes. after start your car, if starts without problems then your problem is your fuel pump. but if problem is still there then it could be your fuel filter or timing of your car.

Posted on Apr 24, 2009

frcs68
  • 1605 Answers

SOURCE: i got 1995 nissan maxima

The knock sensor error could be the sensor, sensor circuit, or some misfire caused by a dirty/bad injector or some ignition problem.

One issue that might tie it all together is coolant leak causing the misfire/knock like a head gasket, but I think you would be throwing more codes or you would see more problems than what you have.

Posted on May 19, 2009

  • 159 Answers

SOURCE: cranks no start

check the coil and the condensor on the dist or the electronic module

Posted on May 20, 2009

  • 77 Answers

SOURCE: xterra car quit running. had no spark @

Yes, there is fuel pump relay, which is generally located on the passenger side kick panel. But in your case, the fuel pump relay on 2002 model Xterra is indeed located under the dash around the steering wheel, but no you don't need to remove the cover just lay in floor and you can see it, it will slide off a bracket and you can remove and replace it.
Good Luck!

Posted on Jan 15, 2011

  • 1 Answer

SOURCE: Engine cranks over but no

regarding the fan speed for heather motor replace the relay under the glove compartment remove the cover and replace it easy to do.

Posted on Apr 27, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1994 Altima will fire but not start on cold or wet days


It may have to do w that timing chain due to vacuum advance being off too.

May 06, 2017 | 1994 Nissan Altima

2 Answers

My 1990 hyundai excel......


It sound like you have an injector problem. the injectors may not be giving the engine enopuph gas to run. so the engine will stall. the fuel pump with shut down as a saftey measure.
have you injectors cleaned and checked for consitancy.

Aug 03, 2008 | 1990 Hyundai Excel

2 Answers

2000 mitsubishi diamante has spark has fuel up to the injectors and power but wont start.


At injector's, need to check if you have ground pulsation, to check, connect test light on pos (+) battery terminal, now your set to check ground, at injector harness, probe wire's, while some one cranks engine, look for pulsation, if you don't have pulsation, it will need a computer, injector pulsation is control by the computer, if no pulsation, then no fuel can get into cylinder.

Sep 09, 2010 | 2000 Mitsubishi Diamante

1 Answer

Replaced everything under the sun on our 87 olds delta 88...wont fire on its own but will fire and run fine as long as u shoot it with starter fluid. We replaced starter, fuel pump, filter, plugs, wires,...


Can you here the fuel pump running?no, check fuse,and pump relay. Check pump fuel pressure,at the fuel injector rail,or throttle body. Check for voltage at the top wiring on the fuel nozzel.While cranking look for pulsating voltage.None, test computer,scan system. let me know the outcome.

Aug 30, 2010 | 1987 Oldsmobile Delta 88

1 Answer

1994 Altima SE idles very poorly and


CHANGE FUEL FILTER.HAVE FUEL PRESSURE CHECK AND HAVE THE IGNITION TIMING CHECK.TIMING COULD BE OFF A LITTLE.HAVE IDLE SPEED CHECK ALSO.

Jun 12, 2010 | 1994 Nissan Altima

1 Answer

Knock sensor in 2002 xterra se/sc


ok if it is getting spark at spark plugs that rules out ignition, let go to fuel, needs to check fuel pressure and also injector pulsation, if no pulsation fuel will not get into cylinder's, also a knock sensor will not keep an engine from starting, it controls ignition timing once engine is running.

Jan 05, 2010 | 2002 Nissan Xterra

1 Answer

It isn't getting fuel to the motor. Fuel pump is working, but does it have a reset button or some sort?


You still need to do a fuel pump pressure test.I seen where you can hear the fuel pump, but no pressure, if good pressure you'll need to check for injector pulsation, unplug one of the injector harness connector (will have two wires) with a test light with key on check for voltage if test light lights up, then reverse test light at battery, now you'll check for pulsation check other wire that will be ground, have some one crank engine test light should flash, if no flash will need to have computer diag. injector get ground from computer (possible bad computer.Good luck.

Dec 26, 2009 | 2000 Dodge Grand Caravan

1 Answer

I am having trouble starting my 93 altima. I have


you have intake leak.bad spark plugs and wires.your fuel pump in gas tank.

May 13, 2009 | 1993 Nissan Altima

1 Answer

Won't crank


Hi,

I am assuming that the engine is cranking (turn over) but will not run.

Most gasoline engines would need only two (2) elements to run; fuel and ignition (spark) at the right moment. Based on your post, "not appeared to have jumped timing", it would then be assumed that the "at the right moment" (at least for the spark) is good. Next to check then would be for the presence of spark; this could be performed by removing one of the spark plugs, reconnecting the said plug to its wire, let it rest on any exposed metal and crank the engine. There should be a pulsating spark at the end, if yes then problem is most likely elsewhere, if none, then next to check (depending on the engine type) would be the:
  • high tension wires;
  • distributor;
  • distributor cap;
  • rotor;
  • ignition module;
  • ignition B+12.
If there is spark and yet would not run, then the fuel delivery to the engine has to be checked. There are two checks on the injector:
  • electrical - pulsating +12 on each of the injectors while cranking;
  • fuel spray - you need to remove all and check if each will spray fuel (while cranking). For safety reasons, pls have several disposable containers ready to catch the fuel, paper towels or rugs to wipe/clean off any spilled raw fuel. If yes, problem is elsewhere, if not and no pulsating +12 while cranking, ECM wiring or connector, if there is pulsating +12 yet no fuel spray, then defective injectors or defective high pressure pump.
In some instances, it could be the alarm/security/immobilizer acting up which prevents the engine to run.

Hope this be of initial help/idea. Pls post back how things turned up or should you need additional information.

Good luck and kind regards. Thank you for using FixYa.

Aug 02, 2008 | 2002 GMC Safari

Not finding what you are looking for?
2005 Nissan Altima Logo

Related Topics:

36 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

705 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...