Question about 1995 Oldsmobile Cutlass Ciera

3 Answers

1995 olds ciera heater not getting hot enough. Change the thermostat and antifreeze but still only warm 60 0r 70 degrees. Thought maybe the heater door is not opening properly how do I get to it, It use to have great heat.

Posted by on

  • 2 more comments 
  • michaeljhorv Oct 11, 2010

    1995 olds ciera heat was running cold to warm flush engine etc. Change the thermostat temperature is a little warmer maybe 60 to 70 degrees but not where it should be.Maybe heated door is not opening properly what do you think and how do I get to it?

  • michaeljhorv Oct 11, 2010

    flush the heater core out put a thermometer in the underneath heater vent temp was 120 degrees then in the upper vents temp was 110 next I tried the defroster vent it read only 100 degrees is that normal? I went out drove a little came home tried the vents again this time heater went only to 110 degrees and the upper vents to 100 and the defroster to about 95. Why the heater was at normal temp range as before

  • michaeljhorv Oct 12, 2010

    I pull the glove box out and it expose some of the linkage. When you move the control knob from hot to cold the cable will close the blend door but when you move the knob to hot it hardly moves so the heat is cool. But if you reach in and manually move the attach lever with your finger the heat will get stronger. So , I spray some lubricating silicone spray on it but I think I will need to remove the control box and examine the linkage there to see why it does not retract or open the heater door up again. Why should it push the door close but not open it back up? I only see one cable connected to the door lever by the fire-wall side. Where do I start at it is all time consuming. You can not remove the blower motor without moving the alternator can I reach the blend door another way or is it the control assemble connection. Linkage not right somewhere.

  • michaeljhorv Oct 12, 2010

    The hoses have even heat but I took out the glove box for a better look and I can see the cable move when the control knob is moved to cold yet it seems to only move slightly when moved to the Hot position.I tried to spray some silicone lube on it in the hope that it would help. But I think I need to take the control box out for a better look do you have any suggestions for me as to what to do next.How can I see if the blend door connection is attach to open the door as well as close it.

×

Ad

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,450 Answers

Sounds like your heater core is partially blocked. Feel the hose and see if they are getting hot. if one is hot and one is just warm then your core is not flowing. remove hoses and backflush with a water hose. puit water pressure to side that is not hot and flush out this will fforce out any debris stopping flow.

Posted on Oct 12, 2010

  • TripleTauto
    TripleTauto Oct 12, 2010

    if you can get to the door remove cable and work door manually you should hear and feel door shut all way if not you have a blockage. also might wanna remove lower heater duct and heater core cover to see if you can see up in there for some trash blocking

×

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Guru:

    An expert who has written 7 tips or uploaded 3 video tips

  • Master
  • 412 Answers

The heater blend door is located underneath the dash on the interior of the cabin.This little puppy is buried nicely too.It's powered by a blend door actuator ( motor).I would definitely back flush the heater core first, since these vehicles have had a notorious problem with that.You can locate the heater core on the engine side of the firewall.It has two hoses coming from it.Remove both of the hoses, and place a garden hose on the heater core inlet or outlet, doesn't matter, and back flush it.Do this about three times and make sure to do it on both ends of the heater core.This should take care of your concern.Please let me know how this works out for you and rate me accordingly!!! Thanks!!

Posted on Oct 11, 2010

  • Jason Lewis
    Jason Lewis Oct 11, 2010

    Have you tried the heater core flush out yet?

  • Jason Lewis
    Jason Lewis Oct 11, 2010

    sounds like the heater core flush has worked.You might want to flush it again just to be sure the rest of the blockage is gone.There will be a slight temp difference from the upper defrost/bi level/floor because the air does cool down slightly when it travels thru the ducting.This is normal.To prevent any more blocks in the heater core use some Prestone super flush throughout the whole cooling system.

×

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Oldsmobile Master
  • 17,970 Answers

I suggtes check the right installation of the seals, also its possible that the water pumpo is going to bad, I was hear that the replacement water pumpo solve this problem, test it and tell us news.

Posted on Oct 11, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1996 MAZDA MPV HEAT WONT GET HOT ENOUGH


You need to put a higher temperature thermostat in. Try a 200 degree thermostat and make sure that you have a full radiator. Also you could dilute your antifreeze a little more than 50/50 .
I would also try a 70/ 30 mix. Hope this helps.

Feb 18, 2015 | 1996 Mazda MPV

1 Answer

2003 Lincoln TC heater blows cold air until car warms up


thermostat is broken... if your in car and smell antifreeze then check heater core its behind glove compartment it may be leaking....

May 14, 2017 | Lincoln Cars & Trucks

1 Answer

Heater blows cold air only.


could be low on antifreeze, or if antifreeze is too weak it can freeze up and you wont get any warm antifreeze through the heater core, if its blowing sort of warm but not hot it could be thermostat, and maybe even the hot cold switch is not working

Jan 02, 2011 | Dodge Grand Caravan Cars & Trucks

1 Answer

1997 jeep wrangler will not blow hot air from heater,,, i replaced the thermostat ,, heater core isnt leaking, and my heater knobs are working,, it blows somewhat warm air , but doesnt get completely hot,


sounds like either the antifreeze solution is to strong [ shouldn't be more then a 70% mixture ] or the heater core is plugged [ some "stop leak" products will cause this.

Dec 29, 2010 | Jeep Wrangler Cars & Trucks

3 Answers

Car warms up just fine but the heater blows cold air


both hoses is hot signifies thatcoolant circulation is just fine check the blend door actuator it might be stuck.pan the heater temp controller from hot to cold do you feel any change in temp of the air from the blower?if you dont feel any change check the blend door actuator

Jan 11, 2010 | 2002 Ford Taurus

1 Answer

I have a 1995 Grand Cherokee out a new thermstat


If the engine is getting hot enough it sounds like the flow through the heater core is restricted. When it is hot turn the heater on and feel the radiator hoses. One should be real hot and the other a little cooler, not much. Try taking the heater hoses off and run water from a garden hose through them. Run both directions and maybe it will break something loose. You won't lose much antifreeze by unhooking the heater hoses.

Jan 05, 2010 | 1995 Jeep Grand Cherokee

1 Answer

I have a 1995 ford windstar that seems to have a temp. problem. While driving the temp. gauge goes all the way to HOT. The van never overheats but the A/C will eventually start blowing warm air. I flushed...


oddly enough it sounds like a transmission problem, get a transmission shop to assess the problem, but first try replacing the thermostat. be sure to turn on the heater when adding antifreeze. I have had this problem with my windstar.

Jun 26, 2009 | 1995 Ford Windstar

3 Answers

I have a 98 cavalier. it runs hot after engine is runnung for a while. the fan comes on and helps it a bit but not enough. and the air from the heater inside never gets warm , where do i start? thx


It sounds like you need to service your cooling system. The cooling system may need to be flushed out due to dirty from corrosion. A sign of no heat in the heater and the engine is hot is low on antifreeze in the system. Check the antifreeze level first and add water just to get around to buy the things you need to service the cooling system. Buy antifreeze and a thermostat, drain the old antifreeze and replace the thermostat. Add new antifreeze with a 50/50 mix solution water/antifreeze. Too much antifreeze will gel and the cooling system will still run hot and to much water will boil over. Good luck. Keep me posted be glad to help.

Jun 23, 2009 | 1998 Chevrolet Cavalier

2 Answers

My 99 cougar only blows cold air the hoses are hot,


maybe your thermostat is stuck open, you may need a new thermostat.

Dec 05, 2008 | 1999 Mercury Cougar

3 Answers

Car just blows out cold air from heater


there is something wrong with your coolant system. Turn your car on, check your fan. If the fan runs nonstop, your relay switch to the fan needs to be changed. If its not the fan, its the thermostat. The thermostat is broke. If the thermostat is broke, it prevents your vehicle from warming up. The thermostat is a temperature Regulator for the engine. If your antifreeze is running nonstop in a circular motion, your engine will run cold. Your engine wont start that cold in the winter either.

Dec 03, 2008 | 1995 Honda Accord

Not finding what you are looking for?
1995 Oldsmobile Cutlass Ciera Logo

Related Topics:

178 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8269 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...