Question about 1996 Toyota Camry

1 Answer

I have a 96 camry and i got it started and it was running really rough then it died and i just put a new battery in it, now its trying to start but nothing its not clicking.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Toyota Master
  • 6,826 Answers

OK, if nothing is clicking as you say, then I would definitely check the new battery's connection to the positive and negative cables at the ends. Try to thoroughly clean with a wire brush when disconnected on both leads.

I wouldn't be surprised if there is a large amount of corrosion there, based on the year, 1996, as this is a common problem even if the vehicle is only a few years old.

I had a similar problem on a 1990 Oldsmobile and a 1997 Cadillac Deville Limo that I reconditioned to my surprise. So, I would check this aspect out.

If it still malfunctions, the starter may be the cause, but I think the battery connection is more likely.

Posted on Oct 11, 2010

  • mphillips198 Oct 12, 2010

    my battery connecter are new and are tighten without corrsions

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

96 camry died while driving


Could be crankshaft sensor.

May 05, 2013 | 1996 Toyota Camry

1 Answer

2000 Toyota Camry Not running properly.


Try cleaning your throttle body or checking to see if you TPS sensor or IAT sensor is bad.

Jan 18, 2013 | 2000 Toyota Camry

3 Answers

2002 express 1500 van, will not start


remove dog house locate test port and install guage should be 45-60 psi

Mar 03, 2010 | 2002 Chevrolet Express

1 Answer

P-reg 96 escort, my battery is dead after only a few hours however when the car is running (after jump starting it) the immobilisor light comes on for about a minute, then starts to flash every 3 seconds....


Bad Alternator.
After Starting or Jumping your vehicle: Remove the Negative Cable from the Battery.
If the Engine dies or runs really rough it is a bad Alternator.
The Battery Starts the Engine and runs nominal operations. The Alternator runs the Engine after it is Started by the Battery.
If the Engine does not die or runs really rough after removing the Negative Cable, then you have a malfunctioning Battery.

Let me know if this helped, or if you have additional information or questions. Feel free to contact me at FixYa.com!

Feb 25, 2010 | 1996 Ford Escort 4 Door

2 Answers

I have a 96 eclipse.that was overfilled w/oil new sparkplugs and wires,air filter,and oil changed.now it runs fine for about a mile then it acts like it is running out of gas and dies.wait bout 5min...


check your distributor cap to make sure no oil got in there also check your fuel pressure regulator to see if its a normal pressure any shop can tell you what it should be so just call and ask the fuel pressure tester is about 45 dollars at autozone

Jan 25, 2010 | 1996 Mitsubishi Eclipse

1 Answer

P0355 is a code I am getting on my 96 pontiac grand am. the car starts sometimes and not others. and when it does sstart it is very rough. the engine was just replaced. could the crankshaft position...


the crank sensor will cause intermitent dieing while driving and a no start,,,common gm issue,a p0355 is for the crsankshaft position sensor performance,,or lack there of performance really,lol replace the crank sensor,,it will not cause a rough running though it will either run or not with a bad sensor, you might have 2 issues but i know the p0355 is a bad crank sensor

Oct 14, 2009 | 1996 Pontiac Grand Am

1 Answer

Will start only with accelator to floor.Put in gear,it dies.


replace fuel filter.have idle speed control checked and scan it to check the egr valve.make sure it not stuck open.

Jul 22, 2009 | 1998 Ford Explorer

1 Answer

Engine starts rough intermittently


First thing that I would do is Replace the Fuel Filter and get the Fuel Pump Checked out. It sounds like it is one or Both of these.

Jan 22, 2009 | 1996 Toyota Camry

1 Answer

Engine running rough not starting


the spark plugs had damage to them ?.
First thing i would look at is the timing belt. not sure if it is a belt or chain but i'm willing to bet it has slipped or broken.

Robert

Sep 05, 2008 | 1996 Chevrolet Cavalier

Not finding what you are looking for?
1996 Toyota Camry Logo

69 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7772 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...