Question about BMW 323

1 Answer

My car starts fine but will not exceed 30 mph flat out any ideas thanks

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 195 Answers

Possible Mass Air Flow Sensor. This is located near the airfilter/intake area. It meters how much air goes into the intake/engine and can cause drivability issues you are speaking off.
Fuel Pump/Fuel Filter can also cause same issues, you must check fuel pump pressure and fuel pump volume with a guage.
With limited information this is the best i can do.

Posted on Oct 10, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2.5 liter no power


Check for back pressure in the exhaust. A plugged cat will cause the exact symptom you have described.

Feb 07, 2012 | 1987 Jeep Comanche

1 Answer

Go out in AM, car is cold, starts and runs fine. Drive short distance, stop and restart, runs fine, idles fine. Drive about 8 miles at 50-55 mph, pull up at a red light, when speed gets down to ~25-30...


The EGR valve is unserviceable which causes a bad or insufficient fuel control for em-missions......Hope this helps you out........EGR valves are not very expensive.

Oct 12, 2010 | 1985 AMC American Motors Eagle

1 Answer

I have a 90 Pontiac 6000 that starts just fine everytime, but it misses and shutters when I accelerate. once it's up to speed it runs great and at low speeds ie. 30 - 40 mph it runs great. it just misses...


Check your transmission lock-up. It's programmed to come in at at 40mph. You can replace the lock-up to come in at 60mph or better.
Or you may have some ignition wires going bad or distributor cap has crack in it.

Aug 16, 2009 | 2006 Pontiac 6000

1 Answer

Bogging and no power!


check your distributor cap for cracks, check te condition of your rotor, check your timing. hope this helps. good luck and remember to rate the comments you get thanx.

Oct 27, 2008 | 2001 Chevrolet Blazer

1 Answer

99 f250 SD 7.3


Your speed sensor in your trans. needs to be checked out sounds like its not working or not getting a good signal until its generating enough power and speed to start until it reaches 30 MPH. Check that out sometimes it could just be some dirt on it. It all makes sense the ABS light is on because its not reading the speed of the tires, and the AOD light is on because It has no idea when to shift into overdrive without knowing how fast its going. I sure Hope that Helps You Out, And Thanks, Bear001

Jun 17, 2008 | 2000 Ford F250 Super Duty Crew Cabs

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

105 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Frankie B

Level 2 Expert

65 Answers

Fred Sops

Level 2 Expert

272 Answers

Doberman

Level 2 Expert

254 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...