Question about 1983 Mazda RX-7

Open Question

1983 RX7 I was driving and heard a pop noise then car lost acceleration power. Pedal to the floor in first gear takes about 20 seconds to get up to 10 mph. Any ideas??

Posted by on

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

starlet4life
  • 89 Answers

SOURCE: I have an rx7 series

Asuming its a "normal clucth", im no "RotaExp". ill say release-bearing or springs=New clucth house.
But "pumping" realy just sounds like a very BAD idea...;)

Posted on Sep 27, 2008

  • 6 Answers

SOURCE: wiring diagram for a 1983 rx7

Search at www.RX7club.com , found everything I need for my 84

Posted on Sep 14, 2009

  • 3600 Answers

SOURCE: clutch Problems with my rx7

More than Likely your clutch reservoir is low on fluid and has leaked all the fluid out so check that first if the reservoir is empty then fill it with brake fluid. Then it will need to be bleed if you don't know how it would be better to take it to a mechanic. Let me know if you want to try it and I will help you.

Posted on Jun 01, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My vue is over accelerating as soon as i start it. changed the tps and it still happens.


2002 3.0 AWD...SES Light and won't accelerate - SaturnFans.com Forums

www.saturnfans.com > ... > Models > Saturn Vue > Vue Tech
Mar 10, 2009 - 4 posts - ‎2 authors SES Light and won't accelerate Vue Tech. ... As in DRIVE it will not over rev when you push the pedal to the floor. ... Does any one have any ideas where I should start? ....2004vue, Vue General, 14, 07-16-2004 12:57 PM ... 99 SL1 Won't accelerate
14 posts
Nov 25, 2013
slow accelerate 1st gear
20 posts
Aug 27, 2012
shaking during acceleration - what is it???
20 posts
May 9, 2010
If You Are Having Hesitation Problems on Acceleration ...
20 posts
Apr 25, 2004
More results from www.saturnfans.com

200 Complaints: 2003 Saturn Vue Power Train: Automatic ...

www.carcomplaints.com/Saturn/Vue/.../power_train-automatic_transmiss...
The 2003 Saturn Vue has 200 NHTSA complaints for the power train:automatic ... At 76,000 miles when accelerating to get on highway, the RPM's were roaring .... Car junked, waste of over $20,000, I can't believe there has been no recall. ... we think this problem makes this model a lemon from the beginning. ... Nov 192004 ...

Oct 30, 2015 | 2004 Saturn VUE

1 Answer

1995 oldsmobile cutlass ciera won't go in reverse


Without putting a scanner on the vehicle, ANYONE is only guessing but here is my 2 cents worth...

There a many popping noises and it could be Engine but since you lost Reverse at the same time...

I would also say that you broke the SUN SHELL inside your 4T60E Transmission and you lost Reverse, Second and 4th gear...

Apr 08, 2013 | 1996 Oldsmobile Cutlass Supreme Coupe

1 Answer

What's your problem?1983 mazda rx7 backfires when getting off gas pedal


sounds like the timing is out or the fuel mixture is wrong get a tune up and that will prob sort it

Oct 25, 2012 | Mazda Cars & Trucks

1 Answer

Very poor acceleration through all gears


diesel pump might not be working right. Try and check fuel pressure. I dont know if its turbo but if the turbo is failing then you will loose power

Feb 05, 2010 | 2006 BMW 5 Series

2 Answers

1997 s10 2 wheel drive truck. 4.3L v6 makes a loud noise as the car accelerates fast or under load. When running 55 I can release the gas pedal and the noise is not audible. I can put the truck in neutral...


Your noise sounds like it is power train related,If you have eliminated the engine,Since it doesn't make the noise while moving and in neutral.
It sounds like a universal joint in the drive shaft.Do you notice a vibration
along with the noise?

Nov 17, 2009 | 1997 Chevrolet S-10 Pickup

2 Answers

Sluggish loss of power and popping noises from engine


Clean the distributer cap in the inside, it has water in it thus causing all the noises and the back fire.

Jun 20, 2009 | 1994 Volkswagen Golf

1 Answer

Stops while driving


this is usually due to a dirty throttle body. just beware if you do try to clean it you will need to preform the idle relearn procedure. this does work, ive done it personally.

A. Accelerator Pedal Release Position Learning Procedure.
1. Make sure that the accelerator pedal is fully released.
2. Turn ignition switch “ON” and wait at least 2 seconds.
3. Turn ignition switch “OFF” wait at least 10 seconds.
4. Turn ignition switch “ON” and wait at least 2 seconds.
5. Turn ignition switch “OFF” wait at least 10 seconds (how would you know if you get it right?)


B. Throttle Valve Closed Position Learning
1. Make sure that accelerator pedal is fully released.
2. Turn ignition switch is “ON”.
3. Turn ignition switch is “OFF” wait at least 10 seconds.
Make sure that the throttle valve moves during above 10 seconds by confirming the operating sound (i never get this right because i never heard anything)

C. Idle Air Volume Learning (Throttle Position Learning)
It's best to time with a watch/clock.

1. Perform “Accelerator Pedal Released Position Learning”.
2. Perform “Throttle Valve Closed Position Learning”.
3. Start engine and warm it up to normal operating temperature.
4. Turn ignition switch “OFF” and wait at least 10 seconds.
5. Conform that accelerator pedal is fully released, turn ignition switch “ON” and wait 3 seconds.
6. Repeat the following (steps 7a, 7b) procedures quickly five times within 5 seconds.
7a. Fully depress the accelerator pedal (HARD)
7b. Fully release the accelerator pedal.
8. Wait 7 seconds, fully depress the accelerator pedal and keep it for approx. 20 seconds until the Check Engine Light (CEL) stops
blinking and turned ON.
9. Fully release the accelerator pedal within 3 seconds after the CEL is ON.
10. Start engine and let it idle.
11 Wait 20 seconds
12Rev up the engine two or three times and make sure the idle speed and ignition timing are within the specifications. (this is fine because SES light lets you know if you did it right the way it blinks)

Oct 25, 2008 | 2005 Infiniti G35

2 Answers

Lost all gears except 1st


your clutch pedal has broken easy fix

Oct 23, 2008 | 2000 Volkswagen Golf

Not finding what you are looking for?
1983 Mazda RX-7 Logo

Related Topics:

54 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8202 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...