Question about 1996 Land Rover Range Rover

1 Answer

My range rover 1996 model with a milage of 55000km, gave me a problem of the engine stopping to run after starting and running for 15min, when it stops running the car can not be started again until after 30min at times until the following day. I wonder what can be the problem please help me I like my car. Resently I took it to the experts who deal with the range rover and I was told everything seems to be fine on wires apart from the key that shows a problem on the computer.

Posted by on

  • jssibandah Oct 09, 2010

    Does it mean that if it is a bad connection on the ECM the car will cut every 15 munites from the time of running the engine? (2) The expert also tested if there is any power being supplied to the engine and there was non that was showing how ever the ignition key was able toput the desh board lights on and the engine did not crank when he tried to crank it. After waiting for 30 munites the car started again and cut off after 15 munites as if it was timed.



    Does it mean that a bad ECM connection cuts off the engine by cutting the power to the engine only for 15 minutes and then starts after 30minutes or the following day.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Land Rover Master
  • 11,800 Answers

If they told you the actual error codes you would have gotten a more precise idea what went wrong and why. Without them all i can do is to make an educated deduction: from what you described that looks like a bad connection on the ECM so their diagnostic appears correct.

Posted on Oct 08, 2010

  • Azrael SRL Oct 09, 2010

    From what you describe it appears that the power coming from the key doesn't reaches the ECM . This also explains why the power appears and disappears - the contact is lost at a plug connection that moves when it heats up = the defect is in the wiring harness between the key hub and the ECM, that is located in the dash.
    The instrument panel must be remove and th wiring accessed and fully tested.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1999 range rover 4.6she starter keeps running


Just changed mine for the same problem!!! replaced starter, problem solved! Unusual design by american standard, for the main motor to continue to drive, !?

Jan 29, 2013 | 1999 Land Rover Range Rover

1 Answer

Range rover 2.5D P38A model. Loss of accelerator


Give me some more information about this problem. May be i can help.

Jul 12, 2011 | 1996 Land Rover Range Rover

1 Answer

1996 Range Rover SE Rear Brake Fluid Leaking right over passeenger side wheel. Computer states (low break fluid) all three brake lights are on. Peddel goes all the way to the end. Very low brake support...


Replace the wheel cylinder on the wheel where you see it leaking then bleed brake system you ought to be ok on your brakes. As for the sun roof sounds like part of the track system is stripped happens all the time on automatic shoulder belts you can hear the motor running but no movement.

Jan 05, 2011 | 1996 Land Rover Range Rover

1 Answer

Car will not start without a jump start it is a recently fitted new battery


start engine ,with engine running disconnect neg terminal on battery if car stops renew the alternator ,if engine keeps running renew the battery ,or use a induction type amp meter in case vehicle uses a computer sensed alternator ,not sure as they changed around this time

Dec 23, 2010 | 2005 Land Rover Range Rover

1 Answer

Where is the crank position sensor in a 1996 Rang Rover P38 4.6? How do you replace the crank position sensor in a 1996 Rang Rover P38 4.6? Thanks In Advance For You Help. Greg


sensor should be next to harmonic balancer.usually bolted to motor.balancer has fins behind it which run through crank sensor magnets to send signals to onboard computer.ensure to replace as per removal method

Feb 28, 2010 | 1996 Land Rover Range Rover

1 Answer

Land rover 1999 starter is running but engine wont start


the unit where u put the key is broken on the back side of the unit is a swith that is y u can turn key in positions ....if there is a time damage often similar problems comming...

Aug 28, 2009 | 1996 Land Rover Discovery

1 Answer

2.5 diesal wont let fuel to injectors


if the engine is the same and all the sensor are positioned in the same place then have to look at the fuel lines if it is correctly connected.if the sensor are different you will require to obtain the wiring harns for this engine and ecu

May 03, 2009 | 1995 Land Rover Range Rover

4 Answers

1997 LAND ROVER RANGE ROVER 4.0


Yes the Land Rover 4.0L Motor is a V6 (6 Cylinder)

Feb 12, 2009 | 1996 Land Rover Range Rover

1 Answer

Range Rover p38 bmw 2.5 injection running problem


Hello,
It turned out to be a broken wire on the injector which was causing a bad connection,now running better than before.
The cold was just a coincidence.

Thank you and best regards,Yvonne

Jan 07, 2009 | 1996 Land Rover Range Rover

1 Answer

Rangeroverp38 6 cylinder bmw deisel engine running problem !


The fuel system is a drive by wire and there is no accellerator cable.Check the plug going into the injector pump and clean,there is probably water here stopping the correct voltage to the throttle pump spool.

Nov 09, 2008 | 1996 Land Rover Range Rover

Not finding what you are looking for?
1996 Land Rover Range Rover Logo

Related Topics:

37 people viewed this question

Ask a Question

Usually answered in minutes!

Top Land Rover Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Land Rover Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...