Question about 1991 Buick Riviera

1 Answer

Car must warmup for five minutes to run properly

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Buick Master
  • 6,826 Answers

Is there a Service Engine Soon light associated with the driveability problem?

Older engines can behave this way and not light the SES light, immediately.

Anything from Compression issues, to coolant temperature sensor issues can cause this problem.

Also, ignition problems can exist in the coil packs until it warms up since the coil packs are mounted on the back of the 4 cylinder engine in some cases.

I wish you luck on resolving this problem.

Posted on Oct 08, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Starts and then loses fuel and fire


Probably a fuel pump. Fuel injection requires 50-60 psi to run properly. Could be egr valve also after warm up.

Jul 31, 2014 | 1999 Dodge Ram

1 Answer

2003 dodge intrepid taps loudly after warmup


your doing good if you have 245000 miles on it,the lifters or tappets loose there prime and flatten out it is not uncommon for dodge to do this.if the engine runs smooth leave it alone.other wise you would have to replace internal parts,u could try to put some tranny fluid in the engine before your next oil change ,only 1 quart though.dont run to long 15 to 20 minutes.if tap does not go away you probly have worn internal parts.not much u can do besides replace lifters,big job.

Mar 17, 2013 | 1996 GMC Suburban

1 Answer

I have a '95 Nissan Quest that runs badly


ur havin warmup issues--get car scanned--do a complete checover also-makin sure radiator fluid is norml cause the coolant sensor gives info--inspect thermostat-mite not be closed on warmup--throttle body and idle air is probly filthy--

Feb 19, 2012 | 1995 Nissan Quest

1 Answer

Hot cold meter problems


One thing you are not driving far enough to warm the engine up. As far as running it ten minutes when cold you are not making the motor warm up as well It has to work to warm up.. They say it is a waste of money to run your car more than two or three minutes as newer cars are made to get in and drive right away when cold. I am wondering if your thermostat is working properly as well.

Jun 06, 2017 | Cars & Trucks

1 Answer

2002 vue v6...starts and runs well however when I stop , shut off the engine, then try to start after half hour , it wont start


Lookfor a light on the dash that says SECURITY or ANTITHEFT. If you see this light, that is a sign of a failed or failing antitheft system, which will disable your vehicle. This link explains

http://vatspasslockpasskeysecurityhelp.yolasite.com/

Nov 06, 2011 | 2002 Saturn VUE

1 Answer

Immediately after I start my '07 Corolla the idle speed is around at 1,400-1,600. This generally happens in the morning or after work. When that happens if I I let it idle for five minutes it goes down...


This idle condition is normal for a cold start, the computer is controlling the idle for proper fuel burn. It is not necessary to wait five minutes for the idle to come down. Allow about one minute before putting into gear and driving.

Nov 04, 2010 | 2007 Toyota Corolla

1 Answer

86 350 FI RUNS COLD REPLACED THERMO TWICE BLOCKED RAD. CLAMPED UPPER RAD HOSE STILL TOOK HALF HOUR


Check any bypass hoses that are around the engine for blockage or internal swelling. If the bypass hoses are restricted, warmup time will be extended. Even though the thermostat is new, the valve may still not be seating properly when closed and allowing some flow when engine is still cold and slowing warmup. Check by shining torch at thermostat valve seat to see if there any gaps. Most thermostats also have a little tickle valve in the outside rim, that is held closed by the water pump pressure but allow a trickle flow when engine is stopped for cool down. If this valve is missing or sticking, that will also slow the warmup process.

Oct 28, 2010 | 1986 GMC Jimmy

1 Answer

Electric cooling fan on ford five hundred not


Check the fuse for the fan and you could test to see if you have a voltage running to the fan when the car starts to overheat. If you have no power to the fan then trace the wore and see if you cant find the problem. If you have power then the fan motor is most likely bad.

Mar 03, 2010 | 2006 Ford Five Hundred

2 Answers

Runs great until it warms up and then no power


You could have a restriction in your exhaust system.
Check the vacuum pressure. High reading means you have backpressure. If so, you need to take your car to the muffler shop.

Oct 11, 2009 | 2002 Pontiac Grand Am

Not finding what you are looking for?
1991 Buick Riviera Logo

Related Topics:

54 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...