Question about 1997 Chevrolet Astro

2 Answers

OBD2 CODES P0131, P0137, P0151

RUNS PERFECT, AFTER 4 MILES DRIVEN ENGINE LOCK OF POWER SURGE. AS SOON THROTTLE PEDAL IS RELEASED TO 1/3 (30 MPH)IT RUNS PERFECT AGAIN. SOUNDS LIKE A BAD CATALYTIC BUT IS NOT. WHILE DRIVING IT I TURN IGNITION OFF AND ON AND FIX THE PROBLEM BY ITSELF FOR A MINUTE OR TWO AND AGAIN THE SAME OLD PROBLEM. AFTER 8 WEEKS SEARCHING SWAPPING AND INSTALLING NEW COMPONENTS I WENT TO CHEVROLET DEALER THEY INSTALL A REMAN. ECM. SAME ****. I TOOK THE ECM AND GET IT INSTALLED ONTO ANOTHER 97 ASTRO THAT IS WAS RUNNING RIGHT. GUESS WHAT?, THAT OTHER VAN RUNS PERFECT.
SWAPPED THE ECM BACK TO THE ORIGINAL VAN AND IS RUNNIG BAD. ENGINE WIRING HARNESS FAILURE SOMEWHERE?. THANKS.

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 4 Answers

On my 1998 Infinity QX4 I was getting randomly both of P0131 & P0151
This was caused by bad grounding between the intake manifold & the main ground cable.
Installing a thick jumper wire (#10 0r #8) between the intake manifold & the Cylinder head or Main Battery ground cable fixed the problem

Posted on Sep 06, 2014

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 625 Answers

Check for every posible loose ground arrownd the engine block
i had foud that many times and technicians have very hard time to find it if you see some thing wires atached to the engine block pull gently on it to see if they are open internally
and check also for clean and tie circuits at batterie and starter

Posted on May 29, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi, I have a 1993 honda goldwing 1500se starts and runs perfect but when im on motorway (i know i shouldnt) but when i turn the throttle at high speeds such as 70 to 90 mph when slightly under load to over...


I would check the spark plugs if you haven't changed them in a while. How many miles are on the bike? Maybe timing belts are getting bad, they are supposed to be replace at or about 60000 miles. If all that checks out. Must not be getting enough fuel. Please rate my answer so my points are awarded.

Jan 08, 2012 | Honda XR 250 R Cars & Trucks

2 Answers

Not Ready for Smog test


it is not how many miles but the type of driving.

here is a OBD2 drive cycle test.

Generic OBD II "Drive Cycle" Most OBD II ("On-Board Diagnostics II") diagnostic monitors will run at some time during normal operation of the vehicle.
However, to satisy all of the different Trip enable criteria and run all of the OBD II diagnostic monitors, the vehicle must be driven under a variety of conditions. The following drive cycle will (theoretically) allow all monitors to run on (??) vehicle. (Note: Drive cycle specifics vary by vehicle!)
  1. Ensure that the fuel tank is between 1/4 and 3/4 full.
  2. Start cold (below 86°F /30°C) and warm up until engine coolant temperature is at least 160° F (typically requires at least one minute; up to 3 minutes).
  3. Accelerate to 40-55 MPH at 25% throttle and maintain speed for five minutes.
  4. Decelerate without using the brake (coast down) to 20 MPH or less, then stop the vehicle. Allow the engine to idle for 10 seconds, turn the key off, and wait one minute.
  5. Restart and accelerate to 40-55 MPH at 25% throttle and maintain speed for two minutes.
  6. Decelerate with using the brake [or the clutch!] by coasting down to 20 MPH or less, then stop the vehicle. Allow the engine to idle for 10 seconds, turn the key off, and wait one minute.

Jun 04, 2010 | 2001 Kia Sephia

2 Answers

Reset computer in doege stratus wont pass inspection drove 50 miles and computer still didnt reset help


U have to operate the engine at all kinds of diff speeds and drive modes, it is called a OBDII drive cycle, here is how u do one.
1. As soon as the engine starts, idle the engine in drive for two and a half minutes with the A/C and rear defrost on. OBDII checks oxygen sensor heater circuits, air pump and EVAP purge.

2. Turn the A/C and rear defrost off, and accelerate to 55 mph at half throttle. OBDII checks for ignition misfire, fuel2_bing.gif trim and canister purge.

3. Hold at a steady state speed of 55 mph for three minutes.

OBDII monitors EGR, air pump, O2 sensors and canister purge.

4. Decelerate (coast down) to 20 mph without braking or depressing the clutch. OBDII checks EGR and purge functions.

5. Accelerate back to 55 to 60 mph at half throttle. OBDII checks misfire, fuel trim and purge again.

6. Hold at a steady speed of 55 to 60 mph for five minutes.

OBDII monitors catalytic converter efficiency, misfire, EGR, fuel trim, oxygen sensors and purge functions.

7. Decelerate (coast down) to a stop without braking. OBDII makes a final check of EGR and canister purge

Jun 02, 2010 | 2004 Dodge Stratus

1 Answer

Engine surge at 45-55 mph on 2002 Silverado 5.3l engine


I would start looking for a vacuum leak. Check all the vacuum lines for cracks or breakage. Spray penetrating fluid on them until you hear the engine start to stumble then focus the spray on that area until you are able to pinpoint the location of the leak. Best of luck,my friend, Dana

Aug 31, 2009 | 2000 Chevrolet Silverado

1 Answer

2000 Chevrolet S10, 4.3, 2wd, 162,000. Surges during take off or under load. New distributor and TPS, MAP 6 months old. Tune up has 40000 miles on it. Fuel pressure 60 psi idle, 70 psi full throttle. Truck...


Sounds to me like fuel delivery issue. If i am correct this engine has the injector unit inside the intake manifold. When the engine needs the extra fuel for accel or loads it just isnt there. You are going to have to do a fuel drop test to determie if the correct amount of fuel is being released for the amount of time the injector is open.

Aug 14, 2009 | 2001 Chevrolet S-10

2 Answers

The car runs perfect, but dies at idle.


remove & clean your IAC motor & see if that doesn't help. If it cures it for a while then does it again, replace it.

May 11, 2009 | 1997 Mitsubishi Galant

1 Answer

My engine wont rev on kickdown 1989 corvette


your torque convrtoer is shot. it is the at the front of the tranny to transfer motion from fly wheel ( engine side) to the trans. its a fairly cheap and easy fix.

Apr 06, 2009 | 1989 Chevrolet Corvette

Not finding what you are looking for?
1997 Chevrolet Astro Logo

890 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...