Question about 1997 Nissan Pickup

1 Answer

Rough Idle...97 pick up replaced egr, maf, and map sensor and it still is running rough and wanting to cut off...any ideas

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 143 Answers

Check for inlet manifold vacuum leak, spray some lube like RP7 into that area and you may find the engine will run rough, thats the problem

Posted on Oct 04, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I replaced the MAP sensor AND the MAF sensor. the car now has a rough idle. did those replacements cause the rough idle?


Did you disconnect the battery negative cable for 5 minutes after the parts were replaced? If not do so then drive it at least 20 miles in varying conditions of idle cruise and so on. See if that helps the rough idle. also rerun the fault code test and see if any codes reappear, I have a feeling you did not fix the problem but just threw parts at it.

Sep 29, 2016 | 2004 Buick LeSabre

1 Answer

Ford e150 codes: p0401, p1401 and p0174. read the more details to see what the symptoms are.


Stop, DO NOT replace expensive parts or O2 sensor! Ford Explorer codes p0174 , p0401 , rough idle and check engine light on. First thoroughly check all of the hoses and elbows connected to the intake and EGR (vacuum system) for splits, cracks, holes or tears, this could quickly cause these codes and fixes for less than $10. Check all connectors and the EGR valve sensor it could have a crack as well, inspect thoroughly because a split sensor could appear attached to the vacuum hoses but hoses could just be sitting there not actually attached due to a split or crack. This was my problem replaced the EGR valve sensor and the two little vacuum hoses attached to them for $50-60 with in stock parts at the local parts store. Took less than 10 minutes to replace and is easily accessible, the check engine light turned off immediately without having to reset the codes by disconnecting the battery, idle became normal and fuel efficiency better. If you have THOROUGHLY inspected every hose, connector and elbow and found no issues, clean the MAF with electrical contact cleaner ( let dry) and clean the EGR with carbon cleaner. A dirty MAF or EGR could also cause these codes to pop up. If this still doesn't work, then consider replacing the EGR, if that isn't it then try the O2 sensor. Good luck!

Jun 23, 2012 | 2002 Ford E-Series

1 Answer

Car dying during slow down to stop, and while in park vehicle will move slightly if accelerator is mashed


If this was a EGR problem you would have a rough idle,If you are a 3.1 you are equipt with a MAP sensor this map sensor has a high failure rate with the vacuum hose connection and the MAP itself,This can be you culprit, If you are a 3.8 the culprit is the MAF mass air flow sensor.3_17_2012_8_55_47_pm.jpg3_17_2012_8_55_56_pm.jpg

Mar 17, 2012 | 1992 Buick Regal

2 Answers

Want to know what a code PO171 means(system too lean bank1).car idles rough and blows black smoke when you rev it up.and is also misfiring.?


If the car is thinking its lean, but its blowing black smoke then it sounds like its confused. Sounds like the o2 sensor is bad. How does it run when its cold?

Feb 12, 2011 | Pontiac Sunfire Cars & Trucks

2 Answers

Rough idle


what was the code?

Jun 27, 2010 | 1997 Ford F150 Regular Cab

2 Answers

Where is the piont where you plug in the diagnostic connector on a 2001 petral vitara


The common faults on this engine are EGR valve and IAC valve.
The EGR causes rough running and cutting out,
The IAC causes just cutting out without the rough running, stalling at junctions etc is the usual complaint.
If you pm me the cars reg, chassis no etc i could see if i could email you the manual its a pdf so should be quite straight forward.

Jun 19, 2010 | 2001 Suzuki Vitara

Not finding what you are looking for?
1997 Nissan Pickup Logo

Related Topics:

708 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76070 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...