Question about 1991 Chevrolet S-10 Blazer

1 Answer

I went to start my 91 s10 blazer 4.3 4x4 and I had dash lights till I went to start it then I lost all power to everything inside and outside. I checked the starter wires and battery wires are all good, good battery also...looking for some help I realy need this blazer running. Thank you.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 343 Answers

Something is completely draining your system at start-up, I believe that your starter is bad ( take it out and have it checked) or you have a real bad short or grounded wire that could possibly start a fire. A low, or almost dead battery can also cause this...take your battery cables off battery and clean anyway to insure good contact ( if aftermarket , even reassemble and clean cable to clamp connections) corrosion/resistance can be a thin film somethimes

Posted on Oct 03, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

All power gone from car


All automobiles have a kind of power transfer port. The battery and everything requiring a 12volt supply passes through the wiring harness. Most everything gets its ground from the frame. So If all power is lost suspect the harness. Otherwise there would be power failure at whatever refuses to work. So check at the wiring harness. Carefully probe the harness under the hood at the fire wall. all the power gets to its destination on the other side of the harness that is inside the car under the dash. If there is no voltage outside there is a great likelihood that none will be inside. Your problem is interesting, you will discover it soon, just by eliminating things in a logical fashion. Post again if none of this has helped you. Finally, try to recall the last thing you were doing before everything quit.

Apr 10, 2014 | 1996 Mitsubishi Mirage

1 Answer

91 chevrolet s10 blazer heater core access?


not really. IT is under the dash on the passenger side. You should put some plastic down or pull the carpet or it will get soaked with anti freeze

Oct 01, 2009 | 1991 Chevrolet S-10

1 Answer

89 chevy S10 turns over won/t start but floods while turning over


If it has a carberater.The flots are probley sticking

Jul 19, 2009 | 1994 Chevrolet S-10 Blazer

1 Answer

91 chevy s10 junk


did you try changing the fuel filter or scanning for codes? This would be a great place to start.

Mar 12, 2009 | 1991 Chevrolet S-10 Blazer

3 Answers

Turn signal relay switch, 94 s10 chevy blazer


The Turn signal relay on a 94 s10 blazer is located under the cluster area right behind the panel that holds the parking brake release handle you will see it once a couple of trim panels get remove it will be to the right side of the brake release handle

Nov 18, 2008 | 1994 Chevrolet S-10 Blazer

1 Answer

1991 S10 blazer tail lights dont work


i own a 1991 chevy blazer myself but my problem is opposet of yours my back lights stay on well i went underneath the dash board an i look up underneath my steering column an i saw to components one was to my cruise control an the one in back of it was to my back lights an i moved this around an to my surprise my light swork good now but now my speed odometer doesnt not work an my gas gauge am my oil aa water gauge my power windows dont work an niether my a/c or heater defroster im jus wondering if i need to move this component alittke more to the left or right yesterday everything worked hmmmm

May 18, 2008 | 1991 Chevrolet S-10 Blazer

Not finding what you are looking for?
1991 Chevrolet S-10 Blazer Logo

151 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...